BGPコンフェデレーション
・BGPコンフェデレーションを使ってAS内にサブASを作る
・同一コンフェデレーション内では,経路情報のBGP属性が変わらないことを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
network 1.1.1.0 mask 255.255.255.0
neighbor 192.168.1.2 remote-as 65000
no auto-summary
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
!
interface Serial0
ip address 192.168.4.1 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.168.1.2 255.255.255.0
clockrate 64000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 200 ←コンフェデレーションID(サブASをまとめるメインAS)を定義
bgp confederation peers 65001
 ←同じコンフェデレーションとなるサブASを指定
neighbor 192.168.1.1 remote-as 65000
neighbor 192.168.2.2 remote-as 65001
neighbor 192.168.2.2 next-hop-self ←サブASはEBGPでつなぐため,ネクストホップを自身にして経路情報を通知
neighbor 192.168.4.2 remote-as 100
no auto-summary
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Ethernet0
ip address 192.168.2.2 255.255.255.0
!
interface Serial0
ip address 192.168.5.1 255.255.255.0
clockrate 64000
no fair-queue
!
interface Serial1
ip address 192.168.3.2 255.255.255.0
clockrate 64000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 200 ←コンフェデレーションID(サブASをまとめるメインAS)を定義
bgp confederation peers 65000 ←同じコンフェデレーションとなるサブASを指定

neighbor 192.168.2.1 remote-as 65000
neighbor 192.168.2.1 next-hop-self ←サブASはEBGPでつなぐため,ネクストホップを自身にして経路情報を通知
neighbor 192.168.3.1 remote-as 65001
neighbor 192.168.5.2 remote-as 100
no auto-summary
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterDのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterD
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Serial0
ip address 192.168.3.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
network 2.2.2.0 mask 255.255.255.0
neighbor 192.168.3.2 remote-as 65001
no auto-summary
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterEのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterE
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Serial0
ip address 192.168.4.2 255.255.255.0
!
interface Serial1
ip address 192.168.5.2 255.255.255.0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 3.3.3.0 mask 255.255.255.0
neighbor 192.168.4.1 remote-as 200
neighbor 192.168.5.1 remote-as 200
no auto-summary
!
line con 0
line aux 0
line vty 0 4
login
!
end
確認
IBGPでは,「全IBGPルーターが1ホップでそのほかの全ルーターに経路を配布できるように,フルメッシュでピアを張る」というのが基本です。
そのため,ルーターの数が増えるとピアの数が増えてしまいます。
その対策法として「ルート・リフレクタ」を使う方法がありましたが,それ以外にも「BGPコンフェデレーション」と呼ばれる手法があります。

●設定の確認
コンフェデレーション(confederation)とは「同盟」という意味です。
一つのAS内に複数のサブASを作ることができます。
こうすることにより,AS内にBGPスピーカが多くなったときに,BGPのピア数を減らすことができます。
例えば今回ネットワーク構成では,AS200内にBGPスピーカが4台あります。
そのため通常では,フルメッシュにして6個のピアが必要です。
そこで,BGPコンフェデレーションを使って,AS200を二つのサブAS(AS65000とAS65001)で構成します。
すると,合計3個のピア(A-B,B-C,C-D)で済みます。

【BGPコンフェデレーションの特徴】
BGPコンフェデレーションには,以下のような特徴があります。
・サブAS同士はEBGPでつなぐことになる。
・経路情報のNEXT_HOP,LOCAL_PREF,MEDといった属性は,サブAS同士のEBGPを経由しても変わらない
・サブASを経由するとAS_PATHに記録されるが,ベストパス選択時における対象にならない
・外部ASからサブASは見えない

以上の特徴を踏まえ,それぞれのルーターに上のコンフィグを入力したときの動作を見てみましょう。

●動作の確認
AS100にあるRouterEのBGPテーブルを見てみましょう。
AS200から1.1.1.0/24,2.2.2.0/24という経路情報を受信しているのがわかります。
外から見ると何も変わりはありません。

RouterE#show ip bgp
BGP table version is 4, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
       r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

  Network     Next Hop     Metric LocPrf Weight Path
*> 1.1.1.0/24    192.168.5.1               0  200 i
*             192.168.4.1               0  200 i
*> 2.2.2.0/24    192.168.5.1               0  200 i
*             192.168.4.1               0  200 i
*> 3.3.3.0/24    0.0.0.0         0      32768  i


では,AS200にあるRouterBのBGPテーブルを見てみます。

RouterB#show ip bgp
BGP table version is 4, local router ID is 192.168.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
       r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

  Network     Next Hop      Metric LocPrf Weight Path
*>i1.1.1.0/24    192.168.1.1       0  100    0  i
*> 2.2.2.0/24    192.168.2.2       0  100    0  (65001) i
* 3.3.3.0/24    192.168.2.2       0  100    0  (65001) 100 i

*>           192.168.4.2       0         0  100 i


「Path」の項目にカッコが付いたASパスがあります。
これが,サブASのASパスです。
見ると,2.2.2.0/24という経路情報は,65001から来たことがわかります。
同じく,3.3.3.0/24という経路情報は,AS100から65001を通って来たことがわかります(赤字の部分)。

RouterCのBGPテーブルも見ておきましょう。

RouterC#show ip bgp
BGP table version is 4, local router ID is 192.168.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
       r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

  Network     Next Hop      Metric LocPrf Weight Path
*> 1.1.1.0/24    192.168.2.1       0  100    0  (65000) i
*>i2.2.2.0/24    192.168.3.1       0  100    0  i
* 3.3.3.0/24    192.168.2.1       0  100    0  (65000) 100 i
*>           192.168.5.2       0          0  100 i


やはりサブASを経由していくつかの経路情報が伝わってきています(赤字の部分)。
ちなみに,ベストパスを決めるときには,カッコでくくられた部分のサブASは無視されます。

●BGPコンフェデレーション内では属性情報が変わらないことを確かめる
AS100からAS200にBGP属性を付けた経路情報を流して,その経路情報がどのように伝わるか見てみましょう。
RouterEからRouterCにMED属性(MED値は50)を付けた経路情報を流してみます。

RouterE(config)#route-map MED50 permit 10
RouterE(config-route-map)#match ip address 1
RouterE(config-route-map)#set metric 50
RouterE(config-route-map)#exit
RouterE(config)#access-list 1 permit 3.3.3.0 0.0.0.255
RouterE(config)#router bgp 100
RouterE(config-router)#neighbor 192.168.5.1 route-map MED50 out


設定が終わったら,RouterEの全BGPピアをリセットして再確立します。

RouterE#clear ip bgp *
RouterE#
*Mar 1 00:56:30.959: %BGP-5-ADJCHANGE: neighbor 192.168.4.1 Down User reset
*Mar 1 00:56:30.967: %BGP-5-ADJCHANGE: neighbor 192.168.5.1 Down User reset
*Mar 1 00:57:11.043: %BGP-5-ADJCHANGE: neighbor 192.168.4.1 Up
*Mar 1 00:57:18.027: %BGP-5-ADJCHANGE: neighbor 192.168.5.1 Up


RouterCのBGPテーブルを見てみましょう。

RouterC#show ip bgp
BGP table version is 8, local router ID is 192.168.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
       r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

  Network     Next Hop      Metric LocPrf Weight Path
*> 1.1.1.0/24    192.168.2.1       0  100   0   (65000) i
*>i2.2.2.0/24    192.168.3.1       0  100   0   i
*> 3.3.3.0/24    192.168.2.1       0  100   0   (65000) 100 i
*             192.168.5.2       50        0   100 i


192.1683.5.2(RouterE)から,MED値50の経路情報(3.3.3.0/24)を受け取っているのがわかります。
この経路情報はRouterBにどのように伝わったでしょうか。
RouterBのBGPテーブルを確認するため,いったん全ピアをリセットして再確立します。

RouterB#clear ip bgp *
RouterB#
01:10:24: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Down User reset
01:10:24: %BGP-5-ADJCHANGE: neighbor 192.168.2.2 Down User reset
01:10:24: %BGP-5-ADJCHANGE: neighbor 192.168.4.2 Down User reset
01:10:53: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up
01:11:00: %BGP-5-ADJCHANGE: neighbor 192.168.4.2 Up
01:11:03: %BGP-5-ADJCHANGE: neighbor 192.168.2.2 Up


RouterBのBGPテーブルを見てみましょう。

RouterB#show ip bgp
BGP table version is 4, local router ID is 192.168.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
       r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

  Network     Next Hop      Metric LocPrf Weight Path
*>i1.1.1.0/24    192.168.1.1       0  100    0  i
*> 2.2.2.0/24    192.168.2.2       0  100    0  (65001) i
* 3.3.3.0/24    192.168.2.2       50  100    0  (65001) 100 i
*>           192.168.4.2       0         0  100 i


MED値50の経路情報を受信しているのがわかります。
サブASを経由してもBGPの属性情報は変わらないことが確認できました。


●BGPケーススタディ(BGPコンフェデレーション)
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/459/bgp-toc-j.shtml#bgpconfed

BGPラボ
BGPの基本設定
BGP同期
BGPの経路集約
ルート・リフレクタ

経路選択(Local Preference)
経路選択(MED)

経路選択(AS Path)
経路情報のフィルタ(ネットワーク番号)
経路情報のフィルタ(AS Path)
BGPコンフェデレーション

バックドア・リンク

BGPコミュニティ