EIGRPのパッシブ・インタフェース
・EIGRPが動作しているインタフェースをパッシブ・インタフェースにする
・パッシブ・インタフェースからEIGRPのパケットが送出されなくなったことを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 64000
!
router eigrp 1
passive-interface Serial0 ←Serial0をパッシブ・インタフェースにする
network 192.168.1.0
network 192.168.2.0
no auto-summary ←自動集約はオフにしておく
eigrp log-neighbor-changes ←ネイバーがアップ/ダウンした際にメッセージを表示する
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 20.1.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
router eigrp 1
network 20.0.0.0
network 192.168.2.0
no auto-summary
no eigrp log-neighbor-changes
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
ほかのルーティング・プロトコルと同様に,EIGRPにもパッシブ・インタフェースの機能があります。
「ルーティング・アップデートやHelloパケットを受信するけど送信しない」という機能です。
EIGRPでパッシブ・インタフェースを使ってみましょう。

●設定の確認
EIGRPでパッシブ・インタフェースを有効にするには,EIGRPの設定モードで,

passive-interface インタフェース名

と入力します。
RIP,IGRP,OSPFと同じですね。

でははじめに,RouterBにpasive-interfaceコマンドを入れない状態の様子を見ておきましょう。
まずはルーティング・テーブル。
すべてのネットワークが見えています。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   20.0.0.0/24 is subnetted, 1 subnets
D    20.1.1.0 [90/2297856] via 192.168.2.2, 00:34:06, Serial1
   10.0.0.0/24 is subnetted, 1 subnets
D    10.1.1.0 [90/2297856] via 192.168.1.1, 00:00:13, Serial0
C  192.168.1.0/24 is directly connected, Serial0
C  192.168.2.0/24 is directly connected, Serial1


次に,RouterBのネイバー・テーブルを見てみましょう。
RouterA(192.168.1.1)とRouterC(192.168.2.2)がネイバーに登録されています。

RouterB#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H  Address         Interface  Hold Uptime  SRTT  RTO Q Seq Type
                    (sec)     (ms)    Cnt Num
1  192.168.1.1       Se0      10 00:01:09 743  4458 0 2
0  192.168.2.2       Se1      11 00:35:04  28    200 0 4


Helloパケットの送出の様子も見てみましょう。
Serial0からHelloパケットを(5秒間隔で)出しているのがわかります。

RouterB#debug eigrp packets hello
EIGRP Packets debugging is on
  (HELLO)
RouterB#
00:50:35: EIGRP: Sending HELLO on Serial0
00:50:35:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

00:50:36: EIGRP: Received HELLO on Serial0 nbr 192.168.1.1
00:50:36:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
00:50:37: EIGRP: Sending HELLO on Serial1
00:50:37:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
00:50:39: EIGRP: Received HELLO on Serial1 nbr 192.168.2.2
00:50:39:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
00:50:40: EIGRP: Sending HELLO on Serial0
00:50:40:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0


RouterBは,Helloを送ってRouterAとネイバーを確立している様子がわかりました。

●動作の確認
では,RouterBのSerial0をパッシブ・インタフェースに設定しましょう。
その前に,EIGRPの設定モードで,

eigrp log-neighbor-changes

と入力しておくと,ネイバーがアップ/ダウンしたときにメッセージが表示されるようになるので,入れておきます。
(IOSの12.3ではデフォルトでオンになっているようです。)
この状態でRouterBのSerial0をパッシブ・インタフェースに設定すると,ネイバーがダウンしたメッセージが表示されます。

RouterB(config)#router eigrp 1
RouterB(config-router)#passive-interface Serial 0
RouterB(config-router)#
00:51:56: %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.1.1 (Serial0) is down: interface passive


ネイバー・テーブルを見てみましょう。
RouterA(192.168.1.1)がネイバーとして登録されていません。
RouterAとのネイバーが解消されてしまっています。

RouterB#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H  Address         Interface  Hold Uptime  SRTT  RTO Q Seq Type
                    (sec)     (ms)    Cnt Num
0  192.168.2.2       Se1      13 00:39:47  27    200 0 5


Helloパケットの様子を見てみましょう。
Serial0からHelloパケットが送出されていません。

RouterB#debug eigrp packets hello
EIGRP Packets debugging is on
  (HELLO)
RouterB#
00:53:23: EIGRP: Sending HELLO on Serial1
00:53:23:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
00:53:24: EIGRP: Received HELLO on Serial1 nbr 192.168.2.2
00:53:24:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
00:53:28: EIGRP: Sending HELLO on Serial1
00:53:28:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
00:53:29: EIGRP: Received HELLO on Serial1 nbr 192.168.2.2
00:53:29:  AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0


パッシブ・インタフェースの設定によってSerial0からHelloパケットを送出しなくなったので,その先にいるRouterAとネイバーが確立できなくなったわけです。
ルーティング・テーブルを見てみると,やはり,RouterA経由の10.1.1.0/24の経路が見えません。

RouterB#show ip route
00:52:30: %SYS-5-CONFIG_I: Configured from console by consolete
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   20.0.0.0/24 is subnetted, 1 subnets
D    20.1.1.0 [90/2297856] via 192.168.2.2, 00:39:33, Serial1
C  192.168.1.0/24 is directly connected, Serial0
C  192.168.2.0/24 is directly connected, Serial1


パッシブ・インタフェースが設定されているかどうかは,show ip protocolsコマンドでもわかります。

RouterB#show ip protocols
Routing Protocol is "eigrp 1"
 Outgoing update filter list for all interfaces is
 Incoming update filter list for all interfaces is
 Default networks flagged in outgoing updates
 Default networks accepted from incoming updates
 EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
 EIGRP maximum hopcount 100
 EIGRP maximum metric variance 1
 Redistributing: eigrp 1
 Automatic network summarization is not in effect
 Routing for Networks:
  192.168.1.0
  192.168.2.0
 Passive Interface(s):
  Serial0

 Routing Information Sources:
  Gateway     Distance   Last Update
  192.168.1.1      90   00:08:11
  192.168.2.2      90   00:03:06
 Distance: internal 90 external 170


パッシブ・インタフェースは,「ルーティング・プロトコルの動作はオンにしたいけど,ルーティング・アップデートは送出したくない」というケースで使います。
例えば,インタフェースの先にほかにルーターがいない場合は,ルーティング・アップデートを送出しても意味がありません。
こうしたときに使うと,帯域の無駄な消費を押さえられます。

EIGRPラボ
EIGRPの基本設定
パッシブ・インタフェースの設定
不等コスト・ロードバランシング
タイマーの設定
NBMAネットワークにおけるEIGRPの設定