インタフェース・トラッキング
・RouterAのSerial0でインタフェース・トラッキングを有効にする
・RouterCのSerial0をダウンさせたときに,HSRPのActiveルーターがRouterBに移るようにする
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RotuerA
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
standby 1 ip 192.168.1.254
standby 1 priority 255
standby 1 preempt
standby 1 track Serial0 200 ←Serial0がダウンしたらプライオリティを200下げる
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
passive-interface Ethernet0
network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
standby 1 ip 192.168.1.254
standby 1 preempt ←Standbyルーターでプリエンプトを有効にしておく必要がある
!

interface Serial0
ip address 192.168.3.1 255.255.255.0
no fair-queue
!
router ospf 1
log-adjacency-changes
passive-interface Ethernet0
network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 192.168.4.1 255.255.255.0
ip ospf network point-to-point ←Loopbackアドレスを設定のマスク長で送信するようにする
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
interface Serial1
ip address 192.168.3.2 255.255.255.0
no fair-queue
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
login
!
end
確認
HSRPでは,特定のインタフェースを監視して,そのインタフェースがダウンしたらHSRPのプライオリティを下げるといった機能があります。
この機能が「インタフェース・トラッキング」です。
インタフェース・トラッキングを使うと,パソコン側のネットワークだけでなく,バックボーン側ネットワークがダウンしたときにも対応できるようになります。

●インタフェース・トラッキングをしないときの動作を確認
まず,インタフェース・トラッキングを設定していないときの動作を見てみましょう。
RouterAに「standby 1 track serial 0 200」という設定が入っていない状態です。

パソコンからRouterC(192.168.4.1)にpingを打ち続けます。
そして,RouterCのSerial0をshutdownしてみます。

RouterC(config)#interface serial 0
RouterC(config-if)#shutdown


するとパソコンの画面には,「Reply from 192.168.1.2: Destination host unreachable.」という結果が続いて,通信できなくなります。
RouterAのHSRPの様子を見てみると,RouterAがActiveになっています。

RotuerA#show standby
Ethernet0 - Group 1
State is Active
7 state changes, last state change 00:19:17
Virtual IP address is 192.168.1.254
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (bia)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.260 secs
Preemption enabled
Active router is local
Standby router is 192.168.1.2, priority 100 (expires in 8.584 sec)
Priority 255 (configured 255)
IP redundancy name is "hsrp-Et0-1" (default)


RouterAがActiveルーターになっていながら,RouterAのインタフェース(Serial0)がダウンしているのだから,通信できるはずがありませんよね。

●インタフェース・トラッキングを設定する
それでは,RouterAにインタフェース・トラッキングを設定します。
インタフェースの設定モードでstandbyコマンドに「track serial 0 200」というオプションを付けます。
すると,Serial0インタフェースを監視するようになり,ダウンするとプライオリティをから200を差し引きます。
つまり,RouterAのSerial0がダウンすると,プライオリティは,255から200を引いて「55」になるわけです。

RouterA(config)#interface ethernet 0
RouterA(config-if)#standby 1 track serial 0 200


あと,忘れていけないのは,RouterBで必ずpreemptを実行するということ。
インタフェーストラッキングでは他方のルーターにpreemptの設定が必要です。

RouterB(config)#interface ethernet 0
RouterB(config-if)#standby 1 preempt


設定は以上です。

●動作の確認(RouterCのSerial0をshutdownしてみる)
では,RouterCのSerial0を再度shutdownして,インタフェース・トラッキングの動作を確認してみましょう。

RouterCのSerial0をshutdownします。

RouterC(config)#interface serial 0
RouterC(config-if)#shutdown


すると,RouterAに以下のメッセージが出ました。
HSRPのメッセージを見てみると,ステータスがActiveではなくなった(Speakになった)という表示が出ました(赤字の部分)。

RouterA#
01:14:15: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.4.1 on Serial0 from FULL to DOWN, Neighbor Down: Interface down or detached
01:14:16: %LINK-3-UPDOWN: Interface Serial0, changed state to down
01:14:17: %HSRP-6-STATECHANGE: Ethernet0 Grp 1 state Active -> Speak
01:14:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down


RouterBのメッセージも見てみましょう。
代わりに,こちらがStandbyからActiveになったという表示が出ました(赤字の部分)。

RouterB#
01:14:16: %HSRP-6-STATECHANGE: Ethernet0 Grp 1 state Standby -> Active


show standbyコマンドを使って,両ルーターのHSRPの詳しい様子を見てみましょう。
RouterAは,確かにStandbyになっています。
プライオリティを見てみると,「55」になっていますね。
それから,「Track interface Serial0 state Down decrement 200」という表示から,インタフェース・トラッキングの対象がSerial0で,ダウンすると200を減ずる(decrement)ようになっていることがわかります(下の赤字)。

RouterA#show standby
Ethernet0 - Group 1
State is Standby
12 state changes, last state change 00:00:35
Virtual IP address is 192.168.1.254
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.648 secs
Preemption enabled
Active router is 192.168.1.2, priority 100 (expires in 9.668 sec)
Standby router is local
Priority 55 (configured 255)
Track interface Serial0 state Down decrement 200
IP redundancy name is "hsrp-Et0-1" (default)


一方,ActiveになっているのはRouterBです。
プライオリティは,デフォルトのままの「100」です(下の赤字)。
RouterAのプライオリティである「55」よりRouterBの「100」の方が高くなり,こちらが(preempt機能が働いて自動的に)Activeルーターになったわけです。

RouterB#show standby
Ethernet0 - Group 1
State is Active
11 state changes, last state change 00:01:07
Virtual IP address is 192.168.1.254
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (bia)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.128 secs
Preemption enabled
Active router is local
Standby router is 192.168.1.1, priority 55 (expires in 9.100 sec)
Priority 100 (default 100)
IP redundancy name is "hsrp-Et0-1" (default)


このように,インタフェース・トラッキングを使うと,HSRPの対象となっているインタフェース以外のインタフェースのダウンを検知して,HSRPの切り替え動作に反映できるようになるわけです。


●standby preemptおよびstandby trackコマンドの使用法
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/619/6-j.html

HSRPラボ
HSRPの基本
プリエンプト
インタフェース・トラッキング
HSRPを使ったロードバランシング
VRRP