VRRP
・RouterAとRouterBでVRRPを動かし,パソコンのデフォルトゲートウエイを2重化する
・RouterAでプリエンプトとインタフェーストラッキングを有効にする
・障害時の経路の切り替え動作を確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
track 1 interface Serial0/0 line-protocol ←Serial0/0をトラッキングの対象とする
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 192.168.1.254 ←仮想IPアドレスを設定する
vrrp 1 preempt delay minimum 30 ←ダウンから復旧して30秒後にマスターになる
vrrp 1 track 1 decrement 20 ←Serial0/0がダウンしたらプライオリティを20下げる

!
interface Serial0/0
ip address 192.168.2.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
vrrp 1 ip 192.168.1.254 ←仮想IPアドレスを設定する
vrrp 1 priority 90 ←プライオリティを90に設定する

!
interface Serial0/0
ip address 192.168.3.1 255.255.255.0
no fair-queue
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 192.168.4.1 255.255.255.0
ip ospf network point-to-point ←Loopbackアドレスを設定のマスク長で送信するようにする
!
interface Serial1/0
ip address 192.168.2.2 255.255.255.0
clock rate 64000
!
interface Serial1/1
ip address 192.168.3.2 255.255.255.0
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
line con 0
line aux 0
line vty 0 4
login
!
end
確認
ゲートウエイ冗長化プロトコルで標準となっているのがVRRPです。
(HSRPはシスコ独自のプロトコル。)
HSRPとVRRPでできることはほぼ同じですが,デフォルトで動作している機能やコンフィグがやや異なります。

●HSRPとVRRPの違い
複数のルーターが仮想IPアドレスを共有するという基本動作は,HSRPとVRRPは同じです。
一つのインタフェースに複数のVRRPグループを設定することもできます。
両者の主な違いは以下です。

【HSRPとVRRPの違い】
・HSRPは「Active」と「Standby」ですが,VRRPは「Master」と「Backup」
デフォルトでプリエンプトが有効になっている
・プリエンプト実行時にMasterに移り変わる時間を設定できる(delay minimumオプション)
インタフェーストラッキングは,対象インタフェースを別途設定する必要がある(trackコマンド)
・仮想IPアドレスにsecondaryアドレスを設定できる

VRRPでは,Masterルーターは同一グループ内のVRRPルーターにVRRPメッセージを送信します。
デフォルトではVRRPメッセージを1秒間隔で送信し,メッセージが3回来なかったらダウンとみなします。
VRRPメッセージのあて先は,224.0.0.18というマルチキャストアドレスです。

●VRRPを設定する
VRRPを設定するときに注意したいのは,インタフェーストラッキングの設定です。
HSRPではインタフェース設定モードでstandbyコマンドを使ってトラッキング対象インタフェースを指定しました。
しかしVRRPでは,いきなりインタフェース設定モードでトラッキングを設定すると(vrrpコマンド),「オブジェクトが存在しない」というエラーが出てしまいます。

RouterA(config-if)#vrrp 1 track 1 decrement 20
% tracked object does not exist


というのもVRRPでは,トラッキングする際は,オブジェクト(トラッキング対象)を設定しておく必要があります。
トラッキング対象は,グローバルコンフィグレーションモードでtrackコマンドを使います。
その後,目的のインタフェースのインタフェース設定モードでトラッキングを設定すればOKです。

RouterA(config)#track 1 interface serial 0/0 line-protocol
RouterA(config-track)#exit
RouterA(config-if)#vrrp 1 track 1 decrement 20

RouterA(config-if)#

VRRPに関するそのほかの設定も確認しておきましょう。
VRRPにおけるプライオリティのデフォルト値は100です。
今回,各ルーターのプライオリティ値は,RouterAはデフォルトの100を使い,RouterBは90に設定します。
そのため,プライオリティ値の大きいRouterAがMasterルーターになるはずです。

プリエンプトはデフォルトで有効なので,特に何も設定する必要はありません。
ただし,以下のコマンドでは,プリエンプト実行時(Master復帰時)にかかる時間を30秒に設定しています。

RouterA(config-if)#vrrp 1 preempt delay minimum 30

というのも,デフォルトでは,Masterが移り変わる際の待ち時間は0秒です。
しかし,例えばMasterルーター側が再起動したときは,ルーティング・テーブルが完成していないのに,Masterルーターとして動作してしまう可能性があります。
こうなると,Masterルーターでパケットを受信しても廃棄してしまうことになります。
こうしたときのために備えて,Masterルーターになるまでにある程度の時間を持たせます。


●動作の確認(定常状態)
設定後のVRRPの状態を確認しましょう。
RouterAのプライオリティ値は100で,こちらがMasterルーターになっています。

RouterA#show vrrp
FastEthernet0/0 - Group 1
 State is Master
 Virtual IP address is 192.168.1.254
 Virtual MAC address is 0000.5e00.0101
 Advertisement interval is 1.000 sec
 Preemption enabled, delay min 30 secs
 Priority is 100
  Track object 1 state Up decrement 20
 Master Router is 192.168.1.1 (local), priority is 100
 Master Advertisement interval is 1.000 sec
 Master Down interval is 3.609 sec


RouterBのプライオリティ値は90で,こちらはBackupルーターになっています。

RouterB#show vrrp
FastEthernet0/0 - Group 1
 State is Backup
 Virtual IP address is 192.168.1.254
 Virtual MAC address is 0000.5e00.0101
 Advertisement interval is 1.000 sec
 Preemption enabled
 Priority is 90
 Master Router is 192.168.1.1, priority is 100
 Master Advertisement interval is 1.000 sec
 Master Down interval is 3.648 sec (expires in 3.176 sec)


●切り替え動作の確認
それでは,切り替え動作を確認してみましょう。
RouterAのFa0/0のケーブルを抜いてみます。

RouterAの画面に出たメッセージを見てみます。
VRRPのステートがMasterからInitに変わって,Masterルーターでなくなったことがわかります。

RouterA#
01:13:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
01:13:18: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Master -> Init
01:13:18: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached


RouterBの画面に出たメッセージも確認しましょう。
ステートは,BackupからMasterになり,RouterBがMasterルーターになったことがわかります。

RouterB#
01:02:40: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Backup -> Master


この間,パソコンからRouterCの192.168.4.1あてにpingを連続で打つと,途切れるのは1回程度です。

RouterAとRouterBのVRRPの状態を確認すると,確かにRouterBがMasterになっているのがわかります。

RouterA#show vrrp
FastEthernet0/0 - Group 1
 State is Init
 Virtual IP address is 192.168.1.254
 Virtual MAC address is 0000.5e00.0101
 Advertisement interval is 1.000 sec
 Preemption enabled, delay min 30 secs
 Priority is 100
  Track object 1 state Up decrement 20
 Master Router is unknown, priority is unknown
 Master Advertisement interval is unknown
 Master Down interval is unknown


RouterB#show vrrp
FastEthernet0/0 - Group 1
 State is Master
 Virtual IP address is 192.168.1.254
 Virtual MAC address is 0000.5e00.0101
 Advertisement interval is 1.000 sec
 Preemption enabled
 Priority is 90
 Master Router is 192.168.1.2 (local), priority is 90
 Master Advertisement interval is 1.000 sec
 Master Down interval is 3.648 sec


●RouterAの経路が復旧したときの動作を確認
次に,RouterAのFa0/0につながるケーブルを戻してみます。

RouterAに表示されたメッセージを見てみます。
ケーブル復帰後すぐにBackupになり,30秒後にMasterになっているのがわかります。
確かにプリエンプトが有効になっていますね。

RouterA#
01:14:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
01:14:52: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Init -> Backup
01:14:57: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
01:15:22: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Backup -> Master


RouterBに表示されたメッセージも見てみます。
こちらは,MasterからBackupに降格したことがわかります。

RouterB#
01:04:22: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.2.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
01:04:47: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Master -> Backup

●インタフェーストラッキングの動作の確認
インタフェーストラッキングの動作も検証してみましょう。
RouterCのSerial1/0をshutdounします。

RouterAは,MasterからBackupになりました。

RouterA#
01:20:23: %LINK-3-UPDOWN: Interface Serial0/0, changed state to down
01:20:23: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.3.2 on Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
01:20:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
01:20:25: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Master -> Backup

そして,一方のRouterBがMasterになったことがわかります。

RouterB#
01:09:49: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Backup -> Master


show vrrpコマンドで,それぞれのルーターの状態を確認してみましょう。
RouterAを見ると,プライオリティ値は80になっています。
また,「一つのトラックオブジェクトがダウンして,プライオリティ値を20ダウンさせている」という表示も出ています。

RouterA#show vrrp
FastEthernet0/0 - Group 1
 State is Backup
 Virtual IP address is 192.168.1.254
 Virtual MAC address is 0000.5e00.0101
 Advertisement interval is 1.000 sec
 Preemption enabled, delay min 30 secs
 Priority is 80
  Track object 1 state Down decrement 20
 Master Router is 192.168.1.2, priority is 90
 Master Advertisement interval is 1.000 sec
 Master Down interval is 3.609 sec (expires in 2.897 sec)

RouterBのプライオリティ値は90なので,こちらがマスターになったわけです。

RouterB#show vrrp
FastEthernet0/0 - Group 1
 State is Master
 Virtual IP address is 192.168.1.254
 Virtual MAC address is 0000.5e00.0101
 Advertisement interval is 1.000 sec
 Preemption enabled
 Priority is 90
 Master Router is 192.168.1.2 (local), priority is 90
 Master Advertisement interval is 1.000 sec
 Master Down interval is 3.648 sec


VRRPで,インタフェーストラッキングが有効になっていることが確認できました。


●Configuring VRRP(英語)
http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hiap_c/ch20/haipvrrp.htm

HSRPラボ
HSRPの基本
プリエンプト
インタフェース・トラッキング
HSRPを使ったロードバランシング
VRRP