IGRPのパッシブ・インタフェース
・IGRPでパッシブ・インタフェースを設定する
・パッシブ・インタフェース設定時に,通知している経路情報を確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
router igrp 64 ←IGRPをAS番号64番で動作させる
passive-interface Serial0 ←Serial0をパッシブ・インタフェースにする
network 10.0.0.0 ←10.x.x.xのインタフェースでIGRPを動かす
network 172.16.0.0 ←172.16.x.xのインタフェースでIGRPを動かす
network 192.168.1.0
 ←192.168.1.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
no fair-queue
clockrate 500000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 500000
!
router igrp 64 ←IGRPをAS番号64番で動作させる
network 192.168.1.0 ←192.168.1.xのインタフェースでIGRPを動かす
network 192.168.2.0
 ←192.168.2.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Ethernet0
ip address 172.17.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
router igrp 64 ←IGRPをAS番号64番で動作させる
network 172.17.0.0 ←172.17.x.xのインタフェースでIGRPを動かす
network 192.168.2.0 ←192.168.2.xのインタフェースでIGRPを動かす

!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
IGRPにもRIPと同様なパッシブ・インタフェース機能があります。
「IGRPをオンにしたときに,受信するけど送信はしないよ」ってやつです。

パッシブインタフェースの設定方法と動作はRIPと同じです。
RouterAのSerial0をパッシブ・インタフェースにするには,passive-interface Serial0と入力します。
設定したら,IGRPの動作状況をshow ip protocolsコマンドで見てみましょう。

RouterA#show ip protocols
Routing Protocol is "igrp 64"
Sending updates every 90 seconds, next due in 36 seconds
Invalid after 270 seconds, hold down 280, flushed after 630
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
IGRP maximum hopcount 100
IGRP maximum metric variance 1
Redistributing: igrp 64
Routing for Networks:
10.0.0.0
172.16.0.0
192.168.1.0
Passive Interface(s):
Serial0

Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 100 00:00:42
Distance: (default is 100)


Serial0がパッシブ・インタフェースになっていることがわかります。
では,RouterAがSerial0から送信している経路情報を調べてみましょう。

RouterA#debug ip igrp transactions
IGRP protocol debugging is on
RouterA#
02:45:52: IGRP: received update from 192.168.1.2 on Serial0
02:45:52: network 172.17.0.0, metric 10576 (neighbor 8576)
02:45:52: network 192.168.2.0, metric 10476 (neighbor 8476)
02:45:58: IGRP: sending update to 255.255.255.255 via Ethernet0 (172.16.1.1)
02:45:58: network 172.17.0.0, metric=10576
02:45:58: network 10.0.0.0, metric=501
02:45:58: network 192.168.1.0, metric=8476
02:45:58: network 192.168.2.0, metric=10476
02:45:59: IGRP: sending update to 255.255.255.255 via Loopback0 (10.1.1.1)
02:45:59: network 172.17.0.0, metric=10576
02:45:59: network 172.16.0.0, metric=1100
02:45:59: network 192.168.1.0, metric=8476
02:45:59: network 192.168.2.0, metric=10476


Serial0は,経路情報を受信しているけど,送信はしていません。
パッシブ状態になっていることがわかります。

RouterAのルーティング・テーブルを見てみましょう。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

I 172.17.0.0/16 [100/10576] via 192.168.1.2, 00:00:35, Serial0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Ethernet0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Serial0
I 192.168.2.0/24 [100/10476] via 192.168.1.2, 00:00:35, Serial0


すべての経路が見えています。
では,RouterCのルーティング・テーブルを見てみましょう。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets
C 172.17.1.0 is directly connected, Ethernet0
I 192.168.1.0/24 [100/10476] via 192.168.2.1, 00:00:27, Serial0
C 192.168.2.0/24 is directly connected, Serial0


RouterAの先にある10.1.1.1/24と192.168.1.0/24の二つの経路情報がありません。
RouterAはRouterCがつながるSerial0に経路情報を送信していないので,RouterCはこの二つの経路情報を受信していないことがわかります。

IGRPラボ
IGRPの基本設定
パッシブ・インタフェースの設定
不等コスト・ロードバランシング
タイマーの設定
ユニキャスト・アップデートの設定