IGRPのタイマー設定
・RIPの各種タイマー(Update,Invalid,Holddown,Flush)を変更する
・変更前と変更後の動作を確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
router igrp 64 ←IGRPをAS番号64番で動作させる
timers basic 5 15 15 30 ←タイマーをUpdate:5秒,Invalid:15秒,Holddown:15秒,Flash:30秒に変更
network 10.0.0.0 ←10.x.x.xのインタフェースでIGRPを動かす
network 172.16.0.0 ←172.16.x.xのインタフェースでIGRPを動かす
network 192.168.1.0
 ←192.168.1.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
no fair-queue
clockrate 500000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 500000
!
router igrp 64 ←IGRPをAS番号64番で動作させる
timers basic 5 15 15 30 ←タイマーをUpdate:5秒,Invalid:15秒,Holddown:15秒,Flash:30秒に変更
network 192.168.1.0 ←192.168.1.xのインタフェースでIGRPを動かす
network 192.168.2.0
 ←192.168.2.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Ethernet0
ip address 172.17.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
router igrp 64 ←IGRPをAS番号64番で動作させる
timers basic 5 15 15 30 ←タイマーをUpdate:5秒,Invalid:15秒,Holddown:15秒,Flash:30秒に変更
network 172.17.0.0 ←172.17.x.xのインタフェースでIGRPを動かす
network 192.168.2.0 ←192.168.2.xのインタフェースでIGRPを動かす

!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
IGRPがRIPに似ているというのは,IGRPの動作をつかさどっているタイマーを見るとよくわかります。
タイマーの種類は,Update,Invalid,Holddown,Flushの四つで,すべて意味はRIPと同じです。
それぞれ,

Update…経路情報(RIPアップデート)を通知する間隔
Invalid…RIPアップデートが来なくなったときに,その経路情報を無効と判断するまでの時間
Holddown…無効と判断した経路情報を保持する時間
Flush…RIPアップデートが来なくなったときに,その経路情報をルーティング・テーブルから削除するまでの時間

でした。
ただ,タイマーにおいてIGRPがRIPと違うのは,デフォルト値です。
RIPのデフォルトは,Updateが30秒,Invalidが180秒,Holddownが180秒,Flashが240秒です。
IGRPのデフォルトはどうか,見てみましょう(上のコンフィグ設定前)。

RouterA#show ip protocols
Routing Protocol is "igrp 64"
Sending updates every 90 seconds, next due in 66 seconds
Invalid after 270 seconds, hold down 280, flushed after 630
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
IGRP maximum hopcount 100
IGRP maximum metric variance 1
Redistributing: igrp 64
Routing for Networks:
10.0.0.0
172.16.0.0
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 100 00:00:01
Distance: (default is 100)


IGRPのデフォルトは,Updateが90秒,Invalidが270秒,Holddownが280秒,Flashが630秒です(赤字の部分)。
RIPに比べてずいぶん長くなっています。
IGRPの通知が来なくなって経路情報が消えるまでに,最大で10分30秒(630秒)もかかるわけです。
これじゃ,実機検証もかなり時間がかかります(爆)。

というわけで,それぞれのタイマーの値を変更してしまいましょう。
ここからが,上のコンフィグです。
上のコンフィグでは,Updateを5秒,Invalidを15秒,Holddownを15秒,Flashを30秒にしています。
timers basic 5 15 15 30というコマンドがそれです。
3台のルーターすべてに同じ設定をしています。

設定が反映されているか,見てみましょう。

RouterA#show ip protocols
Routing Protocol is "igrp 64"
Sending updates every 5 seconds, next due in 2 seconds
Invalid after 15 seconds, hold down 15, flushed after 30
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
IGRP maximum hopcount 100
IGRP maximum metric variance 1
Redistributing: igrp 64
Routing for Networks:
10.0.0.0
172.16.0.0
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 100 00:00:00
Distance: (default is 100)


それぞれのタイマーの値が,目的の値に変わっているのがわかります(赤字の部分)。
次に,RouterAが送受信しているIGRPの経路情報を見てみましょう。

RouterA#debug ip igrp transactions
IGRP protocol debugging is on
RouterA#
00:35:16: IGRP: received update from 192.168.1.2 on Serial0
00:35:16: network 172.17.0.0, metric 10576 (neighbor 8576)
00:35:16: network 192.168.2.0, metric 10476 (neighbor 8476)
00:35:18: IGRP: sending update to 255.255.255.255 via Ethernet0 (172.16.1.1)
00:35:18: network 172.17.0.0, metric=10576
00:35:18: network 10.0.0.0, metric=501
00:35:18: network 192.168.1.0, metric=8476
00:35:18: network 192.168.2.0, metric=10476
00:35:18: IGRP: sending update to 255.255.255.255 via Loopback0 (10.1.1.1)
00:35:18: network 172.17.0.0, metric=10576
00:35:18: network 172.16.0.0, metric=1100
00:35:18: network 192.168.1.0, metric=8476
00:35:18: network 192.168.2.0, metric=10476
00:35:18: IGRP: sending update to 255.255.255.255 via Serial0 (192.168.1.1)
00:35:18: network 172.16.0.0, metric=1100
00:35:18: network 10.0.0.0, metric=501
00:35:21: IGRP: received update from 192.168.1.2 on Serial0
00:35:21: network 172.17.0.0, metric 10576 (neighbor 8576)
00:35:21: network 192.168.2.0, metric 10476 (neighbor 8476)


Serial0で受信した経路情報に注目してみます(赤色の部分)。
00:35:16に経路情報を受信して,そのあと00:35:21に同じ経路情報を受信しています。
5秒間隔(Updateタイマーの時間)で,経路情報を受信していることがわかります。

それぞれのタイマーの意味はRIPと同じなので,経路情報の削除などの動作はRIPと同じです。
Update以外のInvalid,Holddown,Flashの動作は,RIPラボのタイマーの設定を見てください。

IGRPラボ
IGRPの基本設定
パッシブ・インタフェースの設定
不等コスト・ロードバランシング
タイマーの設定
ユニキャスト・アップデートの設定