IGRPの不等コスト・ロードバランシング
・IGRPの不等コスト・ロードバランシング機能を設定する
・目的地までに複数の経路を用意して,パケットがロードバランシングされているか確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
router igrp 64 ←IGRPをAS番号64番で動作させる
variance 2 ←最適経路のメトリックの2倍までの経路をロードバランスの対象にする
network 10.0.0.0 ←10.x.x.xのインタフェースでIGRPを動かす
network 192.168.1.0 ←192.168.1.xのインタフェースでIGRPを動かす
network 192.168.3.0 ←192.168.3.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Ethernet 0
ip address 192.168.3.2 255.255.255.0
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
no fair-queue
clockrate 500000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 500000
!
router igrp 64 ←IGRPをAS番号64番で動作させる
network 192.168.1.0 ←192.168.1.xのインタフェースでIGRPを動かす
network 192.168.2.0
 ←192.168.2.xのインタフェースでIGRPを動かす
network 192.168.3.0 ←192.168.3.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 20.1.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
router igrp 64 ←IGRPをAS番号64番で動作させる
network 20.0.0.0 ←20.x.x.xのインタフェースでIGRPを動かす
network 192.168.2.0 ←192.168.2.xのインタフェースでIGRPを動かす

!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
IGRPの特徴に,不等コスト・ロードバランスという機能があります。
コスト(メトリック)の重みに合わせて,パケットをロードバランスして転送します。
デフォルトで四つのパスを利用できます(muximum-pathコマンドで最大6個まで指定可能)。
ちなみにRIPは,同じコストの経路だけをロードバランスの対象とする「等コスト・ロードバランス」です。

上のコンフィグでは,RouterAに不等コスト・ロードバランスをさせています。
variance 2というのがそのコマンドです。
これは,「最適経路のコストの2倍までのコストを持つ経路をロードバランスの対象経路とする」という意味です。
RouterAのルーティング・テーブルを見てみましょう。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

I 20.0.0.0/8 [100/9076] via 192.168.3.2, 00:00:34, Ethernet0
        [100/10976] via 192.168.1.2, 00:00:33, Serial0

10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Serial0
I 192.168.2.0/24 [100/8576] via 192.168.3.2, 00:00:34, Ethernet0
           [100/10476] via 192.168.1.2, 00:00:33, Serial0

C 192.168.3.0/24 is directly connected, Ethernet0


20.0.0.0/8あての経路として,Ethernet0経由とSerial0経由の二つが登録されています(赤字の部分)。
20.0.0.0/8あての最短経路は,コストが9076のEthernet0経由です。
ところが,variance 2のコマンドで,その2倍(9076×2=18152)までの経路も使うことになっています。
なので,コストが10976のSerial0経由の経路も,20.0.0.0/8あての経路として採用します。
つまり,RouterAが20.0.0.0/8へパケットを送るときは,Ethernet0経由とSerial0経由の二つの経路を使うことになります。

20.1.1.1あての経路を見てみましょう。

RouterA#show ip route 20.1.1.1
Routing entry for 20.0.0.0/8
Known via "igrp 64", distance 100, metric 9076
Redistributing via igrp 64
Advertised by igrp 64 (self originated)
Last update from 192.168.1.2 on Serial0, 00:00:58 ago
Routing Descriptor Blocks:
* 192.168.3.2, from 192.168.3.2, 00:00:58 ago, via Ethernet0
  Route metric is 9076, traffic share count is 1
  Total delay is 26000 microseconds, minimum bandwidth is 1544 Kbit
  Reliability 255/255, minimum MTU 1500 bytes
  Loading 1/255, Hops 1
 192.168.1.2, from 192.168.1.2, 00:00:58 ago, via Serial0
  Route metric is 10976, traffic share count is 1
  Total delay is 45000 microseconds, minimum bandwidth is 1544 Kbit
  Reliability 255/255, minimum MTU 1500 bytes
  Loading 1/255, Hops 1


Ethernet0経由とSerial0経由の二つの経路情報が表示されました。
*(アスタリスク)マークが付いている経路情報に注目してください。
これは,次に使われる予定の経路を示しています。
次は,Ethernet0経由の経路を使うわけですね。

そこで,20.1.1.1あてにpingを打って通信したあとに,再び20.1.1.1あての経路情報を見てみましょう。
まずはping。

RouterA#ping 20.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 8/12/16 ms

応答が返ってきました。
この状態で,再び20.1.1.1あての経路情報を見てみましょう。

RouterA#show ip route 20.1.1.1
Routing entry for 20.0.0.0/8
Known via "igrp 64", distance 100, metric 9076
Redistributing via igrp 64
Advertised by igrp 64 (self originated)
Last update from 192.168.3.2 on Ethernet0, 00:00:00 ago
Routing Descriptor Blocks:
 192.168.3.2, from 192.168.3.2, 00:00:00 ago, via Ethernet0
  Route metric is 9076, traffic share count is 1
  Total delay is 26000 microseconds, minimum bandwidth is 1544 Kbit
  Reliability 255/255, minimum MTU 1500 bytes
  Loading 1/255, Hops 1
* 192.168.1.2, from 192.168.1.2, 00:01:18 ago, via Serial0
  Route metric is 10976, traffic share count is 1
  Total delay is 45000 microseconds, minimum bandwidth is 1544 Kbit
  Reliability 255/255, minimum MTU 1500 bytes
  Loading 1/255, Hops 1


今度は,Serial0経由の経路情報のほうに*マークが付きました。
次は,Serial0経由の経路を使うわけです。
パケットがロードバランスされて送信されていることが確認できました。

IGRPのコストの計算方法は,
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/103/3-j.html
varianceコマンドを使ったロードバランスの詳細は,
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/105/46-j.shtml
が参考になります。

IGRPラボ
IGRPの基本設定
パッシブ・インタフェースの設定
不等コスト・ロードバランシング
タイマーの設定
ユニキャスト・アップデートの設定