IGRPのユニキャスト・アップデート
・ユニキャストを使って経路情報(IGRPアップデート)を送信する
・IGRPアップデートがユニキャストで出ていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
router igrp 64 ←IGRPをAS番号64番で動作させる
network 192.168.1.0
 ←192.168.1.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
!
router igrp 64 ←IGRPをAS番号64番で動作させる
network 2.0.0.0 ←2.x.x.xのインタフェースでIGRPを動かす
network 192.168.1.0
 ←192.168.1.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
!
interface Ethernet0
ip address 192.168.1.3 255.255.255.0
!
router igrp 64 ←IGRPをAS番号64番で動作させる
network 192.168.1.0
 ←192.168.1.xのインタフェースでIGRPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
IGRPもRIP同様,デフォルトはブロードキャストで経路情報を通知します。

RouterB#debug ip igrp transactions
IGRP protocol debugging is on
RouterB#
01:03:51: IGRP: sending update to 255.255.255.255 via Ethernet0 (192.168.1.2)
01:03:51: network 2.0.0.0, metric=501
01:03:51: IGRP: sending update to 255.255.255.255 via Loopback0 (2.2.2.2)
01:03:51: network 192.168.1.0, metric=1100


255.255.255.255というのがブロードキャストです(赤字の部分)。
ということは,IGRPの悩みもRIPと同じ。
つまり,一つのセグメント上に多くのIGRPルーターがあると,そのセグメントはIGRPのブロードキャストだらけになっていまします。
この解決方法もRIPと同じです(爆)。
passive-interfaceコマンドとneighborコマンドを組み合わせて,ユニキャストで特定のルーターだけに経路情報(IGRPアップデート)を送信できます。

RouterB(config)#router igrp 64
RouterB(config-router)#passive-interface Ethernet 0
RouterB(config-router)#neighbor 192.168.1.1


設定が反映されたか見てみましょう。
ルーティング・プロトコルの動作を調べるわけだから,show ip protocolコマンドを使います。

RouterB#show ip protocols
Routing Protocol is "igrp 64"
Sending updates every 90 seconds, next due in 71 seconds
Invalid after 270 seconds, hold down 280, flushed after 630
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
IGRP maximum hopcount 100
IGRP maximum metric variance 1
Redistributing: igrp 64
Neighbor(s):
192.168.1.1

Routing for Networks:
2.0.0.0
192.168.1.0
Passive Interface(s):
Ethernet0

Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 100)


設定がキチンと反映されています。
再び,RouterBが通知している経路情報のあて先を見てみましょう。

RouterB#debug ip igrp transactions
IGRP protocol debugging is on
RouterB#
01:29:18: IGRP: sending update to 255.255.255.255 via Loopback0 (2.2.2.2)
01:29:18: network 192.168.1.0, metric=1100
01:29:18: IGRP: sending update to 192.168.1.1 via Ethernet0 (192.168.1.2)
01:29:18: network 2.0.0.0, metric=501

Ethernet0へは,192.168.1.1あてのユニキャストが出ているのがわかります。
めでたしめでたし。

おまけで,この状態のRouterCのルーティング・テーブルを見てみましょう。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

I 2.0.0.0/8 is possibly down, routing via 192.168.1.2, Ethernet0
C 192.168.1.0/24 is directly connected, Ethernet0


2.0.0.0/8の経路情報がRouterBから通知されなくなって,ホールドダウン状態に入っています。
RouterBから2.0.0.0/8の経路情報が通知されなくなって270秒(Invalidタイマーの時間)経ったわけですね。
さらに待つこと360秒(6分)…

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, Ethernet0


ついに,2.0.0.0/8の経路情報がなくなりました。
IGRPアップデートの通知が来なくなってから630秒(Flushタイマーの時間)経って,ルーティング・テーブルから経路情報が削除されたんですね。

「あれ?RouterAから2.0.0.0/8の経路情報をもらわないの?」と思う人もいるかもしれません。
RouterAがどんな経路情報をやりとりしているか見てみましょう。

RouterA#debug ip igrp transactions
IGRP protocol debugging is on
RouterA#
01:31:10: IGRP: received update from 192.168.1.2 on Ethernet0
01:31:10: network 2.0.0.0, metric 1600 (neighbor 501)
01:32:19: IGRP: sending update to 255.255.255.255 via Ethernet0 (192.168.1.1) -suppressing null update


Ethernet0への送信は,「無効なアップデートを抑制中」と表示されました。
なぜなら,スプリット・ホライズンが効いているからです。
RouterAは,Ethernet0から2.0.0.0/8の経路情報を知りました。
なので,スプリット・ホライズンの法則により,2.0.0.0/8の経路情報はEthernet0へは出しません。

IGRPラボ
IGRPの基本設定
パッシブ・インタフェースの設定
不等コスト・ロードバランシング
タイマーの設定
ユニキャスト・アップデートの設定