ISDNのバックアップ・インタフェース
・RouterAのBri0/0をプライマリ回線のバックアップ・インタフェースにする
・プライマリ回線のリンクを切って,パケットがバックアップ用のISDN回線に迂回することを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
!
username RouterB password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0
backup delay 5 20 ←リンクが切れたら5秒後にバックアップ・インタフェースを起動,リンクが回復したら20秒後に戻す
backup interface BRI0/0 ←Bri0/0をバックアップ・インタフェースに指定
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
duplex auto
speed auto
!
interface BRI0/0
ip address 196.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 196.1.1.2 name RouterB broadcast 8995201
dialer load-threshold 1 outbound
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101 8995101
isdn spid2 5102 8995102

no fair-queue
ppp authentication chap
ppp multilink

!
router rip
network 192.168.1.0
network 192.168.2.0
network 196.1.1.0
!
dialer-list 1 protocol ip permit

!
line con 0
login
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
username RouterA password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
ip address 192.168.2.2 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface BRI0/0
ip address 196.1.1.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 196.1.1.1 name RouterA broadcast 8995101
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5201 8995201
isdn spid2 5202 8995202

no fair-queue
ppp authentication chap
ppp multilink

!
router rip
network 192.168.2.0
network 192.168.3.0
network 196.1.1.0
!
dialer-list 1 protocol ip permit
!
line con 0
password cisco
transport input none
line aux 0
line vty 0 4
login
!
end
確認
ISDN回線をバックアップ回線に仕立てましょう。
プライマリのインタフェースに明示的に,「このインタフェースのバックアップはBri0/0にする」と設定します。
これが,「バックアップ・インタフェース」です。
設定したインタフェースがダウンしたら,自動的にバックアップ・インタフェースをオンにして,ISDN回線を使うようになります。

●設定の確認
バックアップ・インタフェースのコマンドは以下の二つです。

backup delay 5 20
backup interface BRI0/0

「backup delay 5 20」の「5」と「20」の意味は,プライマリ回線のリンクが切断してから5秒後にISDN回線に切り替えて,プライマリ回線が復帰したら20秒後にISDN回線をオフにするという意味です。
これらの設定を,FastEthernet0/0のインタフェース設定モードで設定することに注意してください。
プライマリ回線のインタフェースにバックアップ・インタフェースを設定するわけです。
(ISDNとPPP関連の設定は,ISDNの基本設定のラボと同じです。)

●動作の確認
はじめに,プライマリ・リンク切断前の状態を確認しておきましょう。
Bri0/0インタフェースの状態を見てみると,スタンバイ・モードになってダウンしているのがわかります。

RouterA#show interfaces bri0/0
BRI0/0 is standby mode, line protocol is down
Hardware is PQUICC BRI
Internet address is 196.1.1.1/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Last input 00:01:42, output never, output hang never
Last clearing of "show interface" counters 00:18:59
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
335 packets input, 1725 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
350 packets output, 1888 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 output buffer failures, 0 output buffers swapped out
8 carrier transitions


ルーティング・テーブルも見てみましょう。
バックアップ・インタフェースのBri0/0はダウンしているので,表示されません。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 196.1.1.0/24 [120/1] via 192.168.2.2, 00:00:10, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Loopback0
C 192.168.2.0/24 is directly connected, FastEthernet0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:10, FastEthernet0/0


それでは,プライマリ回線をダウンさせてみます。
RouterAとRouterBをつなぐイーサネット・ケーブルを抜くのですが,その前に,
ISDN回線のリンク状態を見るために,PPPの認証を表示するデバッグ機能をオンにしておきます。

RouterA#debug ppp authentication
PPP authentication debugging is on


それでは,RouterBあて(192.168.3.1)にpingを打ちつつ,FastEthernet0/0のケーブルを抜きます。

RouterA#ping
Protocol [ip]:
Target IP address: 192.168.3.1
Repeat count [5]: 3000 ←192.168.3.1あてにpingパケットを3000個送信
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 3000, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!....
 
ここでケーブルを抜いた!

00:24:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
00:25:00: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
00:25:00: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to down
00:25:00: %LINK-3-UPDOWN: Interface BRI0/0, changed state to up
00:25:10748951988: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 66 changed to up
00:25:12884901888: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 66 changed to up
00:25:33: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
00:25:33: BR0/0:1 PPP: Treating connection as a callin
00:25:33: BR0/0:1 CHAP: O CHALLENGE id 5 len 28 from "RouterA"
00:25:33: BR0/0:1 CHAP: I CHALLENGE id 12 len 28 from "RouterB"
00:25:33: BR0/0:1 CHAP: Waiting for peer to authenticate first
00:25:33: BR0/0:1 CHAP: I RESPONSE id 5 len 28 from "RouterB"
00:25:33: BR0/0:1 CHAP: O SUCCESS id 5 len 4
00:25:33: BR0/0:1 CHAP: Processing saved Challenge, id 12
00:25:33: BR0/0:1 CHAP: O RESPONSE id 12 len 28 from "RouterA"
00:25:33: BR0/0:1 CHAP: I SUCCESS id 12 len 4

00:25:33: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
00:25:33: Vi1 PPP: Treating connection as a callin
00:25:146028888064: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 67 changed to up
00:25:146028888128: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to up
00:25:146028888128: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201 RouterB
00:25:146028888071: BR0/0:2 PPP: Treating connection as a callout
00:25:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
00:25:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
00:25:34: BR0/0:2 CHAP: O CHALLENGE id 5 len 28 from "RouterA"
00:25:34: BR0/0:2 CHAP: I CHALLENGE id 12 len 28 from "RouterB"
00:25:34: BR0/0:2 CHAP: O RESPONSE id 12 len 28 from "RouterA"
00:25:34: BR0/0:2 CHAP: I SUCCESS id 12 len 4
00:25:34: BR0/0:2 CHAP: I RESPONSE id 5 len 28 from "RouterB"
00:25:34: BR0/0:2 CHAP: O SUCCESS id 5 len 4

00:25:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:2, changed state to up
00:25:40: %ISDN-6-CONNECT: Interface BRI0/0:2 is now connected to 8995201 Router
B
...........!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!以後省略
Success rate is 98 percent (2963/3000), round-trip min/avg/max = 1/18/40 ms


ちょっと長いですが,以上のような表示が出ます。
はじめに,FastEthernet0/0がダウンしています(一番上の赤字の部分)。
その5秒後に,Bri0/0がオンになっています(2番目の赤字の部分)。
さらにその後,B1チャネル,B2チャネルの順番にアップして(赤字の部分),それぞれのチャネルでCHAP認証が行われています(青字の部分)。
その後,中断していたping通信が成功するようになりました。

経路が無事切り替わったはずです。
再び,Bri0/0インタフェースの状態を見てみましょう。
待機のためダウンしていたインタフェースが,アップしたことがわかります。

RouterA#show interfaces bri0/0
BRI0/0 is up, line protocol is up (spoofing)
Hardware is PQUICC BRI
Internet address is 196.1.1.1/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters 00:26:47
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
490 packets input, 2591 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
511 packets output, 2802 bytes, 0 underruns
0 output errors, 0 collisions, 6 interface resets
0 output buffer failures, 0 output buffers swapped out
11 carrier transitions


ルーティング・テーブルも見てみましょう。
192.168.3.0/24あての経路情報は,FastEthernet0/0経由に代わって,Bri0/0経由の経路情報が登録されました。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

196.1.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 196.1.1.0/24 is directly connected, BRI0/0
C 196.1.1.2/32 is directly connected, BRI0/0
C 192.168.1.0/24 is directly connected, Loopback0
R 192.168.3.0/24 [120/1] via 196.1.1.2, 00:00:05, BRI0/0


これで,確かに経路がISDN経由に切り替わったことが確認できました。

おまけで,抜いたイーサネット・ケーブルを再び戻してみます。

00:35:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
00:35:25: %ISDN-6-CONNECT: Interface BRI0/0:2 is now connected to 8995201 RouterB
00:35:25: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 8995201 RouterB, call lasted 592 seconds
00:35:25: %ISDN-6-DISCONNECT: Interface BRI0/0:2 disconnected from 8995201 RouterB, call lasted 590 seconds
00:35:25: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
00:35:25: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to down
00:35:107374182400: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0/0, TEI 66 changed to down
00:35:107374182400: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0/0, TEI 67 changed to down
00:35:107374182400: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 66 changed to down
00:35:107374182400: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 67 changed to down
00:35:25: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
00:35:25: %LINK-5-CHANGED: Interface BRI0/0, changed state to standby mode
00:35:25: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
00:35:25: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to down
00:35:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down
00:35:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:2, changed state to down
00:35:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down


FastEthernet0/0インタフェースがアップして,Bri0/0インタフェースが再びスタンバイ・モードに入りました(赤字の部分)。
タイムスタンプを見ると,FastEthernet0/0がアップしてちょうど20秒後に,Bri0/0がスタンバイ・モードに入っているのがわかります。

ISDNラボ
ISDN接続の基本設定
バックアップ・インタフェース
フローティング・スタティック
ダイヤラー・プロファイル
ダイヤラー・ウオッチ
PPPコールバック
スナップショット・ルーティング