ISDNの基本設定
・ルーター2台をISDN回線(ISDNシミュレータ)につないで通信させる
・L2の通信にPPPを使う。PPPの認証方式はCHAPを,通信方式にMP(multilink ppp)を使う
・通信が始まると,MPによって二つのBチャネルが利用されることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
!
username RouterB password cisco ←CHAP用のID(相手のルーター名)とパスワード(相手と共通)
!
!
isdn switch-type basic-ni ←ISDN交換機のタイプをNI1(北米タイプ)
!
!
interface BRI0/0
ip address 196.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp ←レイヤー2プロトコルにPPPを使う
dialer idle-timeout 90 ←通信がなくなってから回線が切断されるまでの時間
dialer map ip 196.1.1.2 name RouterB broadcast 8995201 ←接続先情報を設定
dialer load-threshold 1 outbound ←MPで2Bを使う際の利用率(1/255*100%になったら2Bを発呼)
dialer-group 1 ←このインタフェースでダイヤラ・リスト1番を適用
isdn spid1 5101 8995101 ←B1用のSPIDと電話番号
isdn spid2 5102 8995102 ←B2用のSPIDと電話番号

no fair-queue
ppp authentication chap ←PPPの認証にCHAPを利用
ppp multilink ←通信方式にMPを利用

!
dialer-list 1 protocol ip permit ←インタレスティング・パケット(発呼対象パケット)を設定
!
line con 0
login
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
username RouterA password cisco ←CHAP用のIDとパスワード(パスワードはRouterAと同じにする)
!
!
isdn switch-type basic-ni
!
interface BRI0/0
ip address 196.1.1.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 196.1.1.1 name RouterA broadcast 8995101
dialer-group 1
isdn spid1 5201 8995201
isdn spid2 5202 8995202

no fair-queue
ppp authentication chap
ppp multilink

!
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
ISDN回線を使ったルーター・ネットワークを作ってみましょう。
ISDN回線とくれば,「帯域が細い」&「従量課金」。
ということで,たいていはバックアップ用の回線として使われます。

●ISDNシミュレータを使う
ここでは,Virtual Console社のBRIが2ポート収容できるISDNシミュレータを使います。
ISDNシミュレータは,ISDN交換機の代わりをする装置です。
設定は簡単で,交換機のタイプと,二つのBRIの口のそれぞれに電話番号とSPID(必要なら)を設定するだけです。ISDNシミュレータ
参考までに,今回の例でのISDNシミュレータの設定は,

【Switch Type】
Basic-NI-1(北米タイプ)

【PortA】
Phone1:8995101
Phone2:8995102
SPID1:5101
SPID2:5102

【PortB】
Phone1:8995201
Phone2:8995202
SPID1:5201
SPID2:5202

となっています。

●設定の確認
ISDN関連の設定は,以下の5ステップです(RouterAのコンフィグの赤字の部分)。

1.交換機の設定(必要に応じてSPIDと電話番号を設定)
 isdn switch-type basic-ni
 isdn spid1 5201 8995201
 isdn spid2 5202 8995202

2.スタティック・ルートの設定
 今回スタティック・ルートはなし
3.インタレスティング・パケット(ダイヤルするきかっけになるパケット)の設定
 dialer-list 1 protocol ip permit
4.インタレスティング・パケットのインタフェースの適用
 dialer-group 1
5.あて先と電話番号の対応付け
 dialer map ip 196.1.1.1 name RouterA broadcast 8995101
今回はおまけで,タイムアウト時間を90秒に変更しています(デフォルトは120秒)。

あとは,PPP関連の設定になります(RouterAのコンフィグの青字の部分)。
上のコンフィグは,MPを使って二つのBチャネルをガンガン使う設定になっています。
それが,

dialer load-threshold 1 outbound

という設定です。
ここで設定する1という値は,255に対する割合です。
例えば,128ならは1本目のB1チャネルの帯域幅が50%を超えるとB2チャネル(2本目)がアップします。
今回は1にしているので,トラフィックが流れるとすぐに2本目のBチャネルがアップするわけです。
では,RouterAからRouterBにpingを打ってアクセスしてみます。

●動作の確認
RouterA#ping 196.1.1.2 ←ping送信

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 196.1.1.2, timeout is 2 seconds:
.!!!! ←4/5成功
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/21/24 ms

02:38:161070804796: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
02:38:37: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
02:38:163208757247: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to up
02:38:158913790016: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201 RouterB
02:38:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
02:38:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
02:38:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:2, changed state to up
02:38:43: %ISDN-6-CONNECT: Interface BRI0/0:2 is now connected to 8995201 RouterB


BRI0/0:1(B1チャネル)とBRI0/0:2(B2チャネル)がアップしました(赤字の部分)。
加えて,Virtual-Access1というインタフェースもアップしました(青字の部分)。
MPを使う場合,ルーターは「仮想アクセス・インタフェース」というインタフェースを作ります。
MPによって起動した二つのBチャネルはこの仮想インタフェースを通して通信し,この仮想インタフェースがそれぞれのBチャネルにパケットを振り分ける格好になります。

ISDNの接続状況を見てみましょう。
show isdn statusコマンドを使います。

RouterA#show isdn status
Global ISDN Switchtype = basic-ni
ISDN BRI0/0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 66, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 67, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

TEI 66, ces = 1, state = 8(established)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 7F, tid = 2
TEI 67, ces = 2, state = 8(established)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 7F, tid = 6
Layer 3 Status:
2 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 2
CCB:callid=803F, sapi=0, ces=1, B-chan=1, calltype=DATA
CCB:callid=8040, sapi=0, ces=2, B-chan=2, calltype=DATA
The Free Channel Mask: 0x80000000
Total Allocated ISDN CCBs = 2


レイヤー1〜3の状況が表示されます(赤字の部分)。
いろいろ表示されますが,青字の部分が,それぞれのレイヤーが確立していることを表しています。
個々の表示の意味は,TACのページを参考にして下さい。

次に,ダイヤリングの状態を見てみましょう。
show dialerコマンドを使います。

RouterA#show dialer

BRI0/0 - dialer type = ISDN

Dial String   Successes  Failures   Last DNIS   Last status
8995201    74        0        00:01:00   successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN
Idle timer (90 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: ip (s=196.1.1.1, d=196.1.1.2)
Connected to 8995201 (RouterB)

BRI0/0:2 - dialer type = ISDN
Idle timer (90 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: Multilink bundle overloaded
Connected to 8995201 (RouterB)


それぞれのチャネルごとに,切断時間やダイヤルした理由が表示されます(赤字の部分)。
BRI0/0:1は,196.1.1.1から196.1.1.2へIP通信があったのでダイヤルアップしました。
BRI0/0:2は,MPによりダイヤルアップしました。
切断時間はいずれも90秒で,これがデフォルトです。
通信がなくなってから90秒すると以下の表示が出て,いずれのチャネルも回線が切断されます。

02:40:09: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
02:40:09: %ISDN-6-CONNECT: Interface BRI0/0:2 is now connected to 8995201 RouterB
02:40:09: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 8995201 RouterB, call lasted 91 seconds
02:40:09: %ISDN-6-DISCONNECT: Interface BRI0/0:2 disconnected from 8995201 RouterB, call lasted 91 seconds
02:40:38654705668: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
02:40:38654705664: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to down

02:40:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down
02:40:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:2, changed state to down
02:40:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down


では,MPに関する機能をshow ppp multilinkコマンドを使って確認してみます。
ping実行前,つまり通信がなく接続前の状態では,以下の表示が出ます。

RouterA#show ppp multilink
No active bundles


では,再びRouterBへpingを打ってから,同様のコマンドを入れてみます。
すると,以下の表示が出ます。

RouterA#show ppp multilink

Virtual-Access1, bundle name is RouterB
Dialer interface is BRI0/0
0 lost fragments, 1 reordered, 0 unassigned, sequence 0xE/0xE rcvd/sent
0 discarded, 0 lost received, 3/255 load
Member links: 2 (max not set, min not set)
BRI0/0:1
BRI0/0:2


二つのBチャネルがメンバーとして含まれていることがわかります。

インタフェースの状態を見ても,MPで接続していることがわかります。
BRI0/0:1インタフェース(B1チャネル)を見てみましょう。

RouterA#show interfaces bri 0/0:1
BRI0/0:1 is up, line protocol is up
Hardware is PQUICC BRI
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
LCP Open, multilink Open
Last input 00:00:04, output 00:00:04, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
740 packets input, 22174 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
779 packets output, 30640 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
113 carrier transitions


MPで接続中であることがわかります。

MPに関しては,シスコのTACに詳しい資料があります。
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/131/mppp-ddr-j.html

ISDNラボ
ISDN接続の基本設定
バックアップ・インタフェース
フローティング・スタティック
ダイヤラー・プロファイル
ダイヤラー・ウオッチ
PPPコールバック
スナップショット・ルーティング