ISDNのダイヤラー・プロファイル
・ダイヤラー・プロファイルを使って対向ルーターにダイヤルアップする
・ダイヤラー・プロファイルを使ってダイヤルアップしたことを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
!
username RouterB password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface BRI0/0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1 ←ダイヤラー・プール1番のプロファイルを採用する
isdn spid1 5101 8995101
isdn spid2 5102 8995102
ppp authentication chap
!
interface Dialer0 ←仮想インタフェースとしてDialer0を定義する
ip address 196.1.1.1 255.255.255.0 ←このプロファイル利用時に物理インタフェースに割り当てるアドレス
no ip directed-broadcast
encapsulation ppp
dialer remote-name RouterB ←ダイヤルアップ先のルーター名を指定する
dialer pool 1 ←このプロファイルを,ダイヤラー・プール1番として定義する
dialer string 8995201 ←ダイヤルアップ先の電話番号を指定する
dialer-group 1

!
ip route 196.1.1.2 255.255.255.255 Dialer0
!
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
username RouterA password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface BRI0/0
ip address 196.1.1.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer map ip 196.1.1.1 name RouterA broadcast 8995101
dialer-group 1
isdn spid1 5201 8995201
isdn spid2 5202 8995202
ppp authentication chap
!
!
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
ダイヤラー・インタフェースは,IOS11.2以降でサポートしている機能です。
「ダイヤラー・インタフェース」という仮想インタフェースを用意しておいて,ダイヤルアップの要求があったら,物理回線(Bri0/0など)にそれらの一つを利用します。
あて先ごとに,ダイヤルする番号を変えたりダイヤルアップの条件を変えることができます。

●ダイヤラー・プロファイルの利点
・一つのインタフェースを使って,複数のあて先にダイヤルできる
・あて先ごとに異なった設定(インタフェースに割り当てるIPアドレスなど)を用意できる
 (マップ・クラスと合わせるとより細かく条件を設定可能)

●設定の確認
今回,ダイヤラー・プロファイルはRouterAに設定します。
RouterAの設定内容を確認しましょう。

interface Dialer0

で,仮想インタフェースのプロファイルを設定します。
設定の際,以下が,ダイヤラー・プロファイル特有の設定項目です。

dialer remote-name RouterB
dialer string 8995201
dialer pool 1

ダイヤラー・プロファイルで指定できる接続先は,プロファイルごとに一つです。
そのため,対向ルーターのIPアドレスはわからなくてもよく,ルーター名と電話番号を指定してやります。
(そのため,dialer mapではなくdialer stringを使います。)
そして,この仮想インタフェースの設定を,ダイヤラー・プール1番と定義します。
ここで定義したダイヤラー・プール番号は,Bri0/0の物理インタフェースで,

dialer pool-member 1

と設定すると,Bri0/0でDialer0のプロファイルが有効になります。

ip route 196.1.1.2 255.255.255.255 Dialer0

また,発呼条件を,以上のように設定することもできます。

以上を設定した状態で,ルーターの各種状態を見てみましょう。
まずはルーティング・テーブルを確認してみます。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

196.1.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 196.1.1.0/24 is directly connected, Dialer0
C 196.1.1.2/32 is directly connected, Dialer0


169.1.1.0/24あての通信は,仮想インタフェースであるDialer0を送出先にしています。
このあて先に通信したいときに,Dialer0のプロファイルを使ってダイヤルアップするわけです。

次に,show dialerコマンドで,ダイヤル情報を確認してみましょう。

RouterA#show dialer

BRI0/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

BRI0/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Di0 - dialer type = DIALER PROFILE
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
Number of active calls = 0


Dial String Successes Failures Last DNIS Last status
8995201 2 0 00:02:39 successful Default


設定で作ったDialer0仮想インタフェースが,「Di0」として表示されました。
Dialer stateはidleとなっているので,現在はこのプロファイルを使ってダイヤルアップしていないことがわかります。

●動作の確認
では,Dialer0のダイヤル・プロファイルを使って,ダイヤルアップしてみましょう。
対向ルーターであるRouterB(1.1.1.2)あてにpingを打ってみます。

RouterA#ping 196.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 196.1.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 28/30/32 ms

00:30:66581524284: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
00:30:68719476735: %DIALER-6-BIND: Interface BR0/0:1 bound to profile Di0
00:30:68719476735: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201
00:30:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
00:30:21: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201 RouterB


Bri0/0:1がDi0(Dialer0仮想インタフェース)を使ってダイヤルアップしました。
再び,show dialerコマンドで,ダイヤル情報を見てみましょう。

RouterA#show dialer

BRI0/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=196.1.1.1, d=196.1.1.2)
Interface bound to profile Di0
Time until disconnect 111 secs
Current call connected 00:00:11
Connected to 8995201 (RouterB)

BRI0/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Di0 - dialer type = DIALER PROFILE
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 1
Number of active circuit switched calls = 0

Dial String Successes Failures Last DNIS Last status
8995201 3 0 00:00:13 successful Default


Bri0/0:1がDi0(Dialer0仮想インタフェース)に対応付けられています。
また,Di0の表示を見ると,状態(Dialer dtate)が先ほどの「idle」から「data link layer up」に変わり,リンクがアップしたこともわかります(赤字の部分)。

ちなみに,一定時間(この場合はデフォルトの120秒)経つと,以下の表示が出ます。
Bri0/0:1が対応付けていたDi0のプロファイルを開放したことがわかります(赤字の部分)。

00:35:04: %DIALER-6-UNBIND: Interface BR0/0:1 unbound from profile Di0
00:35:04: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 8995201 RouterB, call lasted 122 seconds
00:35:17179869188: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
00:35:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down


この例は,あて先が1つだけでしたが(ISDNシミュレータの口が2個しかない!),ISDN経由であて先がいくつもある場合は,あて先ごとに電話番号を変えられるダイヤラー・プロファイルが便利です。

ISDNラボ
ISDN接続の基本設定
バックアップ・インタフェース
フローティング・スタティック
ダイヤラー・プロファイル
ダイヤラー・ウオッチ
PPPコールバック
スナップショット・ルーティング