ISDNのダイヤラー・ウオッチ
・RouterAに特定のネットワークを監視(ウオッチ)させる
・ウオッチしているネットワークがダウンさせ,対向のRouterBにダイヤルアップすることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
username RouterB password 0 cisco
!
isdn switch-type basic-ni
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
duplex auto
speed auto
!
interface BRI0/0
ip address 196.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 196.1.1.2 name RouterB broadcast 8995201
dialer map ip 192.168.3.0 name RouterB broadcast 8995201
dialer watch-group 1
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101 8995101
isdn spid2 5101 8995101
ppp authentication chap
!
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 196.1.1.0
!
!
access-list 100 deny eigrp any any
access-list 100 permit ip any any
access-list 100 permit icmp any any
dialer watch-list 1 ip 192.168.3.0 255.255.255.0
dialer-list 1 protocol ip list 100
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
username RouterA password 0 cisco
!
isdn switch-type basic-ni
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
ip address 192.168.2.2 255.255.255.0
no ip directed-broadcast
!
interface BRI0/0
ip address 196.1.1.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 196.1.1.1 name RouterA broadcast 8995101
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5201 8995201
isdn spid2 5202 8995202
ppp authentication chap
!
!
router eigrp 1
network 192.168.2.0
network 192.168.3.0
network 196.1.1.0
!
access-list 100 deny eigrp any any
access-list 100 permit ip any any
access-list 100 permit icmp any any
dialer-list 1 protocol ip list 100
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
ダイヤラー・ウオッチもバックアップ手法の一つです。
ウオッチするネットワークを設定し,そのネットワークがダウンしたら特定のルーターにダイヤルアップさせます。

●設定の確認
以下が,ダイヤラー・ウオッチの設定です。
ウオッチする経路情報をdialer watch-listとして作り,それをBRIインタフェースにdialer watch-groupとして適用します。
その際,ダイヤラーウオッチ用のダイヤラー・マップを設定しておく必要があります。

dialer map ip 192.168.3.0 name RouterB broadcast 8995201
dialer watch-group 1
dialer watch-list 1 ip 192.168.3.0 255.255.255.0

また,ルーティング・プロトコルを使っている場合,そのパケットでISDN回線がオンになってしまいます。
そのため,インタレスティング・パケットでルーティング・プロトコルのパケットをdenyにしておきます。
以下の設定では,IPとICMPのパケットではダイヤルアップするようにしています。

access-list 100 deny eigrp any any
access-list 100 permit ip any any
access-list 100 permit icmp any any

●動作の確認
RouterAのルーティング・テーブルを見てみましょう。
FastEthernet経由で,RouterBから192.168.3.0/24の経路情報がEIGRPで流れてきています。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 196.1.1.0/24 is directly connected, BRI0/0
C 192.168.1.0/24 is directly connected, Loopback0
C 192.168.2.0/24 is directly connected, FastEthernet0/0
D 192.168.3.0/24 [90/409600] via 192.168.2.2, 00:15:33, FastEthernet0/0


ここで,RouterAがウオッチしている192.168.3.0/24の経路情報を,わざとダウンさせてみましょう。
RouterBのloopback 0インタフェースをshutdownします。
その前に,ダイヤルした時点でその情報を表示させるため,debugコマンドを入れておきます。
debug dialer eventコマンドを使います。

RouterA#debug dialer event
Dial on demand events debugging is on


では,RouterBのloopback 0インタフェースをshutdownします。

RouterB#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RouterB(config)#interface loopback 0
RouterB(config-if)#shutdown


するとRouterAには,以下の表示が出ます。
DDRの表示に「Dialer WatchでGroup 1がダウンした。それがダイヤルの理由」とあります(上の赤字)。
そして,BRI0/0が8995201へダイヤルアップしています(下の赤字

RouterA#
03:53:42: DDR: Dialer Watch: watch-group = 1
03:53:42: DDR: network 192.168.3.0/255.255.255.0 DOWN,
03:53:42: DDR: primary DOWN
03:53:42: DDR: Dialer Watch: Dial Reason: Primary of group 1 DOWN
03:53:42: DDR: Dialer Watch: watch-group = 1,
03:53:42: DDR: dialing secondary by dialer map 192.168.3.0 on BR0/0
03:53:42: BR0/0 DDR: Attempting to dial 8995201
03:53:182545641276: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
03:53:180388626432: BR0/0:1 DDR: Dialer Watch: resetting call in progress
03:53:180388626496: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201
03:53:42: BR0/0:1 DDR: dialer protocol up
03:53:43: DDR: Dialer Watch: watch-group = 1
03:53:43: DDR: network 192.168.3.0/255.255.255.0 DOWN,
03:53:43: DDR: primary DOWN
03:53:43: DDR: Dialer Watch: Dial Reason: Primary of group 1 DOWN
03:53:43: DDR: Dialer Watch: watch-group = 1,
03:53:43: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
03:53:48: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201 RouterB


再び,RouterAのルーティング・テーブルを見てみましょう。
192.168.1.3/24の経路情報は消えています。
その代わり,RouterBあてのホスト・ルート(196.1.1.2/32)が出来ています(赤字の部分)。
これは,PPPの接続が確立すると,対向リンクへのホスト・ルートが自動生成されるためです。
ウオッチしていた経路情報が消えたので,設定どおり,RouterBにダイヤルアップたことがわかります。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

196.1.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 196.1.1.0/24 is directly connected, BRI0/0
C 196.1.1.2/32 is directly connected, BRI0/0
C 192.168.1.0/24 is directly connected, Loopback0
C 192.168.2.0/24 is directly connected, FastEthernet0/0


この例では,ISDN回線のタイムアウト時間は,90秒です(dialer idle-timeout 90)。
つまり,90秒間ISDN回線に何もパケットが流れなかったら,回線が切断されます。
そのまま何もしなければ,ウオッチしている192.168.3.0/24の経路情報はダウンしたままです。
そのため,タイムアウト時間が過ぎて回線がダウンしたら,すぐにまたISDN回線がアップします。
192.168.3.0/24がダウンしている状態では,ずっと以下が繰り返されます。

04:04:17179869184: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 8995201 RouterB, call lasted 89 seconds
04:04:19338910660: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
04:04:17179869184: BR0/0:1 DDR: Dialer Watch: resetting call in progress
04:04:17179869184: DDR: Dialer Watch: watch-group = 1
04:04:17179869184: DDR: network 192.168.3.0/255.255.255.0 DOWN,
04:04:17209247489: DDR: primary DOWN
04:04:17179869184: DDR: Dialer Watch: Dial Reason: Secondary of group 1 DOWN
04:04:17179869184: DDR: Dialer Watch: watch-group = 1,
04:04:17179869184: DDR: dialing secondary by dialer map 192.168.3.0 on BR0/0
04:04:17179869216: BR0/0 DDR: Attempting to dial 8995201
04:04:17179869184: BR0/0:1 DDR: disconnecting call
04:04:17179869184: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
04:04:17179869184: BR0/0:1 DDR: Dialer Watch: resetting call in progress
04:04:17179869248: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201
04:04:04: BR0/0:1 DDR: dialer protocol up
04:04:10: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201 RouterB


最後に,ダウンさせていた192.168.3.0/24の経路情報を復活させてみましょう。

RouterB#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RouterB(config)#interface loopback 0
RouterB(config-if)#no shutdown


RouterAは,192.168.3.0/24の経路情報がアップしたのを検知しました(上の赤字)。
そして,ISDN回線をダウンさせました(下の赤字)。

04:11:150323855360: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 89
95201 RouterB, call lasted 89 seconds
04:11:152482896836: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
04:11:150323855360: BR0/0:1 DDR: Dialer Watch: resetting call in progress
04:11:150323855360: DDR: Dialer Watch: watch-group = 1
04:11:150323855360: DDR: network 192.168.3.0/255.255.255.0 UP,
04:11:150353235330: DDR: primary UP
04:11:152482897056: BR0/0:1 DDR: disconnecting call
04:11:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down



ISDNラボ
ISDN接続の基本設定
バックアップ・インタフェース
フローティング・スタティック
ダイヤラー・プロファイル
ダイヤラー・ウオッチ
PPPコールバック
スナップショット・ルーティング