ISDNのフローティング・スタティック
・フローティング・スタティックの設定をする
・プライマリ経路が消えたら,スタティックに設定しておいた経路情報がルーティング・テーブルに出現することを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
!
username RouterB password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
duplex auto
speed auto
!
interface BRI0/0
ip address 196.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 196.1.1.2 name RouterB broadcast 8995201
dialer load-threshold 1 outbound
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101 8995101
isdn spid2 5102 8995102
no fair-queue
ppp authentication chap
ppp multilink
!
router rip
network 192.168.1.0
network 192.168.2.0
!
ip route 192.168.3.0 255.255.255.0 196.1.1.2 121 ←192.168.3.0/24の経路情報を,スタティック・ルートで登録。その際,アドミニストレイティブ・ディスタンスを121に設定
!
dialer-list 1 protocol ip permit
!
line con 0
login
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
username RouterA password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
ip address 192.168.2.2 255.255.255.0
no ip directed-broadcast
!
interface BRI0/0
ip address 196.1.1.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 90
dialer map ip 196.1.1.1 name RouterA broadcast 8995101
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5201 8995201
isdn spid2 5202 8995202
no fair-queue
ppp authentication chap
ppp multilink
!
router rip
network 192.168.2.0
network 192.168.3.0

!
dialer-list 1 protocol ip permit
!
line con 0
password cisco
transport input none
line aux 0
line vty 0 4
login
!
end
確認
バックアップのテクニックの一つに,「フローティング・スタティック」があります。
普段はダイナミック・ルーティングで受信している経路を使うんだけど,それとは別にスタティック・ルートで経路を設定しておきます。
そして,普段使っている経路がダウンしたら,スタティック・ルートの経路情報が登場(浮上:floating)するようにします。

●アドミニストレイティブ・ディスタンスとは?
ルーターに同じあて先の経路情報が複数あるとき,以下の優先順位で経路情報を選びます。

1.プレフィックス長(ロンゲスト・マッチ)
2.プレフィックス長が同じだったら,アドミニストレイティブ・ディスタンス
3.アドミニストレイティブ・ディスタンスも同じだったら,メトリック

フローティング・スタティックは,この2番を利用したものです。
通常,スタティック・ルートとして登録した経路情報のアドミニストレイティブ・ディスタンス値は,「1」です。
そこでフローティリング・スタティックでは,スタティック・ルートのアドミニストレイティブ・ディスタンスを高い値に変更して,普段はダイナミック・ルーティングで受信した経路情報を優先するようにします。
そして,ダイナミック・ルーティングで受信した経路情報がなくなったら(ダウンしたら),スタティック・ルートとして登録した経路情報を利用するようにします。

アドミニストレイティブ・ディスタンスのデフォルト値や概要はこちらが参考になります

●設定の確認
フローティング・スタティックの設定は,以下の1行です。
普通のスタティック・ルーティングの設定ですが,最後に最後の「121」がアドミニストレイティブ・ディスタンスです。

ip route 192.168.3.0 255.255.255.0 196.1.1.2 121

アドミニストレイティブ・ディスタンス値を121にして,RIPのデフォルト値である120より大きくしてあります。

●動作の確認
では,フローティング・スタティックの動作を確認してみましょう。
RouterAのルーティング・テーブルを見てみます。
192.168.3.0/24あての経路として,RIPで受信した経路情報を採用しています(赤字の部分)。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 196.1.1.0/24 is directly connected, BRI0/0
C 192.168.1.0/24 is directly connected, Loopback0
C 192.168.2.0/24 is directly connected, FastEthernet0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:17, FastEthernet0/0


Bri0/0インタフェースの状況を見てみましょう。

RouterA#show interfaces bri 0/0
BRI0/0 is up, line protocol is up (spoofing)
Hardware is PQUICC BRI
Internet address is 196.1.1.1/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters 01:36:29
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
3793 packets input, 15338 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
3805 packets output, 15519 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions


インタフェースは,アップしているのがわかります(赤字の部分)。
これが,フローティング・スタティックが,バックアップ・インタフェースと違うところです。
バックアップ・インタフェースは,プライマリ回線がダウンしないとアップしませんが,フローティング・スタティックは,通常のDDRと同じく,インタレスティング・トラフィックが発生すればリンクがアップします。

試しに,RouterB(196.1.1.2)にpingを打ってみます。
すると,プライマリ回線がダウンしていなくても,ダイヤルアップします。

RouterA#ping 196.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 196.1.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/20/20 ms

01:42:53696622396: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
01:42:12: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
01:42:60129542143: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to up
01:42:55834574912: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 89952
01
01:42:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
01:42:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
01:42:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:2, changed state to up
01:42:19: %ISDN-6-CONNECT: Interface BRI0/0:2 is now connected to 8995201 RouterB


つまりフローティング・スタティックは,「通常のDDRの動作」に「アドミニストレイティブ・ディスタンスを使った経路情報の操作を加えたもの」というわけです。

ここからが本番です。
しばらく経ってBri0/0の二つのリンク(Bチャネル×2)がダウンするのを待ちます。
ダウンしたら,プライマリ回線をつないでいるイーサネット・ケーブルを抜きます。

01:46:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down

RouterAに以上の表示が出て,FastEthernet0/0インタフェースがダウンしたことがわかります。
この状態で,RouterAのルーティング・テーブルを見てみましょう。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 196.1.1.0/24 is directly connected, BRI0/0
C 192.168.1.0/24 is directly connected, Loopback0
S 192.168.3.0/24 [121/0] via 196.1.1.2


今度は,192.168.3.0/24の経路情報として,スタティックに設定しておいたアドミニストレイティブ・ディスタンス値121のルートが登録されました。
アドミニストレイティブ・ディスタンス値が次に高いこの経路情報が採用されたわけです。

もちろん,192.168.3.0/24あてに通信できます。
pingを打ってみましょう。

RouterA#ping 192.168.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/21/24 ms

01:47:152480870204: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
01:47:35: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
01:47:154618822655: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to up
01:47:150323855424: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201
01:47:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
01:47:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
01:47:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:2, changed state to up
01:47:41: %ISDN-6-CONNECT: Interface BRI0/0:2 is now connected to 8995201 RouterB


Bri0/0にダイヤルアップしてpingが成功しました。
ISDN回線がバックアップ経路として使えるようになったわけです。

最後に,スタティック・ルーティングの注意点を。
今回は,RouterAにフローティング・スタティックを設定してRouterAからRouterBの先へ通信できるようにしました。
同様に,RouterBからRouterAの先に通信できるようにするには,RouterBにもフローティング・スタティックの設定をしておく必要があります。
RouterBのルーティング・テーブルに192.168.1.0/24あての経路情報が登録されないので,RouterBからRouterAの先(192.168.1.0/24)に通信できなくなってしまうからです。

今回の場合はRouterBに,

ip route 192.168.1.0 255.255.255.0 196.1.1.1 121

と設定することになります。

ISDNラボ
ISDN接続の基本設定
バックアップ・インタフェース
フローティング・スタティック
ダイヤラー・プロファイル
ダイヤラー・ウオッチ
PPPコールバック
スナップショット・ルーティング