PPPコールバック
・RouterAをコールバック・クライアント,RouterBをコールバック・サーバーに設定して,コールバックさせる
・RouterBがRouterAにコールバックしていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.0
service timestamps debug datetime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
!
username RouterB password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface BRI0/0
ip address 196.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer map ip 196.1.1.2 name RouterB broadcast 8995201
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101 8995101
isdn spid2 5102 8995102
ppp callback request
ppp authentication chap
!
!
access-list 100 permit ip any any
access-list 100 permit icmp any any
dialer-list 1 protocol ip list 100
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
username RouterA password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface BRI0/0
ip address 196.1.1.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer callback-secure
dialer map ip 196.1.1.1 name RouterA class dial1 broadcast 8995101
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5201 8995201
isdn spid2 5202 8995202
ppp callback accept
ppp authentication chap callin
!
!
map-class dialer dial1
dialer callback-server username
!
access-list 100 permit ip any any
access-list 100 permit icmp any any
dialer-list 1 protocol ip list 100
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
ISDNの特徴に「コールバック」というものがあります。
接続相手に電話をかけ直してもらうという機能です。
「電話代は相手持ちねっ!」という使い方ができます。

●設定の確認
コールバックをするときには,ルーターを「コールバック・クライアント」と「コールバック・サーバー」にします。
接続の流れは,
1.クライアントがサーバーにダイヤルアップする
2.ダイヤルアップした接続をいったん接続する
3.サーバーがクライアントにダイヤルアップし直す(コールバックする)
となります。
今回は,クライアントがRouterAで,サーバーがRouterBです。

●動作の検証
PPPの動作を見るために,デバックを実行しておきます。

RouterA#debug ppp authentication
PPP authentication debugging is on


では,対向ルーターであるRouterBあてにpingでパケットを送ってみます。

RouterA#ping 196.1.1.2

00:04:242675183420: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
00:04:240518168640: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201
*Mar 1 00:04:56: BR0/0:1 PPP: Treating connection as a callout
*Mar 1 00:04:56: BR0/0:1 CHAP: O CHALLENGE id 3 len 28 from "RouterA"
*Mar 1 00:04:56: BR0/0:1 CHAP: I CHALLENGE id 2 len 28 from "RouterB"
*Mar 1 00:04:56: BR0/0:1 CHAP: O RESPONSE id 2 len 28 from "RouterA"
*Mar 1 00:04:56: BR0/0:1 CHAP: I SUCCESS id 2 len 4
*Mar 1 00:04:56: BR0/0:1 CHAP: I RESPONSE id 3 len 28 from "RouterB"
*Mar 1 00:04:56: BR0/0:1 CHAP: O SUCCESS id 3 len 4
00:04:240518168580: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 196.1.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

00:05:11: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
00:05:11: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201
*Mar 1 00:05:11: BR0/0:1 PPP: Treating connection as a callin
*Mar 1 00:05:11: BR0/0:1 CHAP: O CHALLENGE id 4 len 28 from "RouterA"
*Mar 1 00:05:11: BR0/0:1 CHAP: I RESPONSE id 4 len 28 from "RouterB"
*Mar 1 00:05:11: BR0/0:1 CHAP: O SUCCESS id 4 len 4
00:05:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
00:05:17: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201 RouterB


すると,最初にBRI0/0:1がアップしてPPPをコールアウトしています(1番目と2番目の赤字)。
そしてすぐに,BRI0/0:1がダウンしています(3番目の赤字)。
ところがすかさず,PPPのコールインがありました(4番目の赤字)。
そして最終的に,BRI0/0:1がアップしてRouterBと接続が完了しています(5番目の赤字)。

RouterBのダイヤルの状況を見てみましょう。
show dialerコマンドを使います。
すると,ダイヤルした理由として「Callback return call」とあり,コールバックでダイヤルしたことがわかります。

RouterB#show dialer

BRI0/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status
8995101 3 0 00:01:47 successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Callback return call
Time until disconnect 94 secs
Connected to 8995101 (RouterA)

BRI0/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle



●参照
IOS12.2 Configuration Guide(英語)
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fdial_c/fnsprt10/dafcbddr.htm
ISDN を経由したPPPコールバックの設定(日本語)
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/793/access_dial/isdn-ppp-callback-j.html

ISDNラボ
ISDN接続の基本設定
バックアップ・インタフェース
フローティング・スタティック
ダイヤラー・プロファイル
ダイヤラー・ウオッチ
PPPコールバック
スナップショット・ルーティング