スナップショット・ルーティング
・RouterAをコールバック・クライアント,RouterBをコールバック・サーバーに設定して,コールバックさせる
・RouterBがRouterAにコールバックしていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
!
username RouterB password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.0
!
interface BRI0/0
ip address 196.1.1.1 255.255.255.0
encapsulation ppp
dialer map snapshot 1 name RouterB broadcast 8995201
dialer map ip 196.1.1.2 name RouterB broadcast 8995201
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101 8995101
isdn spid2 5102 8995102
snapshot client 5 8 dialer
ppp authentication chap
!
!
router rip
network 10.0.0.0
network 196.1.1.0
!
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
username RouterA password 0 cisco
!
!
isdn switch-type basic-ni
!
!
interface Loopback0
ip address 20.20.20.20 255.255.255.0
no ip directed-broadcast
!
interface BRI0/0
ip address 196.1.1.2 255.255.255.0
encapsulation ppp
dialer map ip 196.1.1.1 name RouterA broadcast 8995101
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5201 8995201
isdn spid2 5202 8995202
snapshot server 5 dialer
ppp authentication chap
!
!
router rip
network 20.0.0.0
network 196.1.1.0
!
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
RIPやIGRPといったディスタンス・ベクトル方式のルーティング・プロトコルをISDN回線上で使う場合に,「スナップショット・ルーティング」と呼ばれる機能が用意されています。
スナップショット・ルーティングには,クライアントとサーバーが存在します。
クライアントは,アクティブ時間の間だけダイヤルアップして接続して,ルーティング・アップデートを交換します。
アクティブ時間が終わるとダイヤルアップ回線を切断しますが,ルーティング・テーブルの情報はそのまま保持します。
このルーティング・テーブルを保持する時間のことを,クワイエット時間と呼びます。
スナップショット(写真)を撮るように,ルーティング・テーブルを保存するわけですね。

●設定の確認
スナップショット・サーバーはRouterAです。
snapshot client 5 8 dialer
このコマンドで,アクティブ時間を5分,クワイエット時間を8分に指定します。
あとは,dialer mapコマンドでスナップショットの接続先を登録します。
dialer map snapshot 1 name RouterB broadcast 8995201

スナップショット・クライアントはRouterBです。
snapshot server 5 dialer
アクティブ時間を5分に設定しています。
これは,クライアントの設定と合わせる必要があります。

●動作の確認
設定が完了すると,RouterAがダイヤルアップしてリンクがアップします。

00:19:105236229948: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
00:19:103079215168: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201
00:19:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up
00:19:30: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8995201 RouterB


ダイヤルアップした原因を調べてみましょう。
show dialerを見ると,「dialer reason」の部分に「snapshot」と記述されているのがわかります(赤字の部分)。

RouterA#show dialer

BRI0/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status
8995201 2 0 00:01:26 successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: snapshot
Time until disconnect 119 secs
Connected to 8995201 (RouterB)

BRI0/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle


RouterAのルーティング・テーブルを見てみましょう。
RouterBからRIPで20.0.0.0/8の経路情報を受け取ったことがわかります(赤字の部分)。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 20.0.0.0/8 [120/1] via 196.1.1.2, 00:00:03, BRI0/0
196.1.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 196.1.1.0/24 is directly connected, BRI0/0
C 196.1.1.2/32 is directly connected, BRI0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback0


スナップショットの状態を見てみましょう。
show snapshotというコマンドがあります。
RouterAが,スナップショット・クライアントのルーターであることがわかります。
(RouterBに同じコマンドを入れると,「Snapshot server」と表示されます。)
また,今はアクティブ時間であることがわかります。
アクティブ時間中は,RIPのルーティング・アップデートを交換します(要は,通常の動作をする)。

RouterA#show snapshot
BRI0/0 is up, line protocol is up Snapshot client
Options: dialer support
Length of active period: 5 minutes
Length of quiet period: 8 minutes
Length of retry period: 8 minutes
For dialer address 1
Current state: active, remaining/exchange time: 5/1 minutes
Connected dialer interface:
BRI0/0:1
Updates received this cycle: ip


アクティブ時間の5分が経過するとどうなるでしょう。
2分間の「ポスト・アクティブ」と呼ばれる時間に入ります。
(※時間を計ってみたらアクティブ時間は6分間でした。なぜだ?情報求む!)
さらに2分間,この状態が続くことになります。
(※この動作も,「5分」という設定と実際の動作が違っています。情報求む!)

RouterA#show snapshot
BRI0/0 is up, line protocol is upSnapshot client
Options: dialer support
Length of active period: 5 minutes
Length of quiet period: 8 minutes
Length of retry period: 8 minutes
For dialer address 1
Current state: client post active->quiet, remaining time: 2 minutes
Updates received this cycle: ip


2分間のポスト・アクティブ時間が経過すると,リンクがダウンします。

00:26:25: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 8995201 RouterB, call lasted 454 seconds
00:26:255562111940: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
00:27:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down


show snapコマンドでスナップショットの状態を見てみましょう。
8分間のクワイエット時間に入っています。
もちろんリンクがダウンしているので,RIPアップデートのやりとりは中断されます。

RouterA#show snap
BRI0/0 is up, line protocol is upSnapshot client
Options: dialer support
Length of active period: 5 minutes
Length of quiet period: 8 minutes
Length of retry period: 8 minutes
For dialer address 1
Current state: quiet, remaining: 7 minutes


再び,RouterAのルーティング・テーブルを見てみましょう。
リンクがダウンしたにもかかわらず,RIPで受信した20.0.0.0/8の経路情報を維持しています。
通常は,RIPパケットが3分(180秒)来なければダウンと判断するのですが,10分を超えても経路情報が消えずに残っています(赤字の部分)。
スナップショットが効いていることがwかります。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 20.0.0.0/8 [120/1] via 196.1.1.2, 10:03:17, BRI0/0
C 196.1.1.0/24 is directly connected, BRI0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Loopback0


これを利用すると,定期的なアップデートによって回線がつなぎっぱなしになることを防止できます。
ちなみに,debug snapshotでも,回線のアップやダウンの状態が逐一表示されます。

●参照
IOS12.2 Configuration Guide(英語)
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fdial_c/fnsprt5/dafnsnap.htm
スナップショットルーティングQ&A(日本語)
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/458/20-j.html

ISDNラボ
ISDN接続の基本設定
バックアップ・インタフェース
フローティング・スタティック
ダイヤラー・プロファイル
ダイヤラー・ウオッチ
PPPコールバック
スナップショット・ルーティング