エリア設定(NSSA,トータリースタブNSSA)
・スタブエリアをNSSA(Not So Stubby Area)に変更する
・NSSAをトータリースタブNSSAに変更する
・それぞれのエリアで受信する経路情報がどのように変わるかを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 192.168.200.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
area 1 nssa ←エリア1をNSSAにする
redistribute rip metric 20 subnets ←RIPで学習した経路情報をOSPF(のコスト20)で再配布する
network 192.168.1.0 0.0.0.255 area 1
!
router rip
network 192.168.200.0
!
line con 0
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.168.0.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
area 1 nssa default-information-originate ←エリア1をNSSAにし,外部ネットワークへのデフォルト・ルートを通知させる
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 1
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Serial0
ip address 192.168.0.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
ip address 192.168.100.1 255.255.255.0
clockrate 64000
!
router ospf 1
log-adjacency-changes
redistribute rip metric 10 subnets ←RIPで学習した経路情報をOSPF(のコスト10)で再配布する
network 192.168.0.0 0.0.0.255 area 0
!
router rip
network 192.168.100.0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterDのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterD
!
interface Loopback0
ip address 192.168.110.1 255.255.255.0
!
interface Loopback1
ip address 192.168.120.1 255.255.255.0
!
interface Loopback2
ip address 192.168.130.1 255.255.255.0
!
interface Loopback3
ip address 192.168.140.1 255.255.255.0
!
interface Loopback4
ip address 192.168.150.1 255.255.255.0
!
interface Loopback5
ip address 192.168.160.1 255.255.255.0
!
interface Loopback6
ip address 192.168.170.1 255.255.255.0
!
interface Serial0
ip address 192.168.100.2 255.255.255.0
!
router rip
network 192.168.100.0
network 192.168.110.0
network 192.168.120.0
network 192.168.130.0
network 192.168.140.0
network 192.168.150.0
network 192.168.160.0
network 192.168.170.0
!
ip route 0.0.0.0 0.0.0.0 192.168.100.1 ←デフォルト・ルートをRouterCに向ける
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
スタブ・エリアは,ルーターが受信するLSAを少なくできて便利ですが,ASBRを置けません。
ところが,「スタブ・エリアでもOSPF以外の経路情報をOSPFで再配送したい!」というケースがあります。
そんなときは,スタブ・エリアの機能を持ちながもエリア内にASBRを置いてOSPF以外の経路情報を配信できるようにした,NSSA(Not So Stubby Area)を使います。

●スタブ・エリアの動作を確認する
エリア1をスタブ・エリアにしたときの動作から見ていきましょう。
全ルーターの設定は,エリア設定(標準,スタブ,トータリースタブ)に記載しているコンフィグを入れた状態です。

エリア1がスタブ・エリアの場合,RouterAのルーティング・テーブルは以下のようになります。
RIPネットワークあての経路が,デフォルト・ルートになっていますね。
これがスタブ・エリアの機能です。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

O IA 192.168.0.0/24 [110/128] via 192.168.1.2, 00:00:22, Serial0
C  192.168.1.0/24 is directly connected, Serial0
O*IA 0.0.0.0/0 [110/65] via 192.168.1.2, 00:00:22, Serial0


RouterAのLSDBも見てみます。
外部ルートを表すLSAのType4とType5はありません。
その代わり,ほかのエリアを表すType3のデフォルト・ルートを受信しています。
これはRouterBが,RIPネットワークの経路情報であるType5のLSAを,Type3のデフォルト・ルートにして通知したためです(詳しくはエリア設定(標準,スタブ,トータリースタブ)の回を見てください)。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.1.1) (Process ID 1)

        Router Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum Link count
192.168.1.1   192.168.1.1   1725    0x8000000D 0x00EF91 2
192.168.1.2   192.168.1.2   1725    0x80000004 0x00F88E 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum
0.0.0.0      192.168.1.2   1731    0x80000001 0x00923F
192.168.0.0   192.168.1.2   1731    0x80000001 0x0059CF


ではここで,RouterAをASBRにしてみます。
RouterAのLoopback0インタフェースに192.168.200.0/24というサブネットを作って,この経路情報をRIPでエリア1に再配送します。

RouterA(config)#interface Loopback0
RouterA(config-if)#ip address 192.168.200.1 255.255.255.0
RouterA(config)#router ospf 1
RouterA(config-router)#redistribute rip metric 20 subnets
Warning: Router is currently an ASBR while having only one area which is a stub area


「このルーターはASBRで,スタブ・エリアに所属しています」という警告メッセージが出てしまいました。
再配送の設定自体は入っているのですが,経路情報はOSPFで流れていません。
スタブ・エリアにASBRは置けないのです。

●スタブ・エリアをNSSAに変更する
NSSAを直訳すると,「そんなにスタブじゃないエリア」という意味です。
何がスタブっぽくないかというと,スタブ・エリアにASBRを置いて,外部ネットワークのLSAを流せるところです。

RouterAにNSSAの設定をしましょう。
RouterAのスタブの設定を消したあとに,NSSAの設定をします。

RouterA(config)#router ospf 1
RouterA(config-router)#no area 1 stub
RouterA(config-router)#area 1 nssa
RouterA(config-router)#
*Mar 1 00:43:44.571: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.2 on Serial0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset

RouterBにも同様にNSSAの設定をします。

RouterB(config)#router ospf 1
RouterB(config-router)#no area 1 stub
RouterB(config-router)#area 1 nssa
RouterB(config-router)#
00:46:24: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from LOADING to FULL, Loading Done


これでエリア1がNSSAになったはずです。
RouterBのルーティング・テーブルを見てみましょう。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

O E2 192.168.120.0/24 [110/10] via 192.168.0.2, 00:04:57, Serial1
O E2 192.168.150.0/24 [110/10] via 192.168.0.2, 00:04:57, Serial1
O E2 192.168.110.0/24 [110/10] via 192.168.0.2, 00:04:57, Serial1
O E2 192.168.130.0/24 [110/10] via 192.168.0.2, 00:04:57, Serial1
O E2 192.168.160.0/24 [110/10] via 192.168.0.2, 00:04:57, Serial1
O E2 192.168.140.0/24 [110/10] via 192.168.0.2, 00:04:58, Serial1
O E2 192.168.170.0/24 [110/10] via 192.168.0.2, 00:04:59, Serial1
O E2 192.168.100.0/24 [110/10] via 192.168.0.2, 00:04:59, Serial1
O N2 192.168.200.0/24 [110/20] via 192.168.1.1, 00:04:58, Serial0
C  192.168.0.0/24 is directly connected, Serial1
C  192.168.1.0/24 is directly connected, Serial0


エリア1内にあるRIPネットワークの経路情報(192.168.0.200/24)が,OSPFで配信されました。
「N2」は,NSSAの経路情報であることを示しています。

RouterAのLSDBはどうなっているでしょうか。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.1.1) (Process ID 1)

        Router Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum Link count
192.168.1.1   192.168.1.1   269     0x80000010 0x0077FC 2
192.168.1.2   192.168.1.2   269     0x80000008 0x007EFA 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum
192.168.0.0   192.168.1.2   278     0x80000004 0x00DA43

        Type-7 AS External Link States (Area 1)

Link ID     ADV Router   Age     Seq#    Checksum Tag
192.168.200.0  192.168.1.1   408     0x80000001 0x00335A 0


192.168.200.0/24の経路情報を,Type7のLSAとして保持しています。

RouterBのLSDBを確認してみましょう。

RouterB#show ip ospf database

      OSPF Router with ID (192.168.1.2) (Process ID 1)

        Router Link States (Area 0)

Link ID      ADV Router   Age     Seq#    Checksum Link count
192.168.1.2    192.168.1.2   404     0x80000006 0x2BF5  2
192.168.100.1  192.168.100.1  784     0x80000003 0xDAE6  2

        Summary Net Link States (Area 0)

Link ID      ADV Router   Age     Seq#    Checksum
192.168.1.0   192.168.1.2   516     0x80000004 0x2AF8

        Router Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum Link count
192.168.1.1   192.168.1.1   396     0x80000010 0x77FC  2
192.168.1.2   192.168.1.2   396     0x80000008 0x7EFA  2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum
192.168.0.0   192.168.1.2   405     0x80000004 0xDA43

        Type-7 AS External Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum Tag
192.168.200.0  192.168.1.1   537     0x80000001 0x335A  0

        Type-5 AS External Link States

Link ID      ADV Router   Age     Seq#    Checksum Tag
192.168.100.0  192.168.100.1  786     0x80000002 0xAE5E  0
192.168.110.0  192.168.100.1  786     0x80000002 0x40C2  0
192.168.120.0  192.168.100.1  786     0x80000002 0xD127  0
192.168.130.0  192.168.100.1  786     0x80000002 0x638B  0
192.168.140.0  192.168.100.1  786     0x80000002 0xF4EF  0
192.168.150.0  192.168.100.1  786     0x80000002 0x8654  0
192.168.160.0  192.168.100.1  786     0x80000002 0x18B8  0
192.168.170.0  192.168.100.1  786     0x80000002 0xA91D  0

192.168.200.0  192.168.1.2    385     0x80000001 0xC1D4  0


LSAのType7とType5に192.168.200.0の経路情報があります。
というのもRouterBは,RouterAから受け取ったType7の経路情報(192.168.200.0/24)を,Type5に変換してバックボーン・エリアに送信しています。
その証拠に,RouterCにE2(OSPF外部ネットワーク)の経路情報ができています。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

R  192.168.120.0/24 [120/1] via 192.168.100.2, 00:00:02, Serial1
R  192.168.150.0/24 [120/1] via 192.168.100.2, 00:00:02, Serial1
R  192.168.110.0/24 [120/1] via 192.168.100.2, 00:00:02, Serial1
R  192.168.130.0/24 [120/1] via 192.168.100.2, 00:00:02, Serial1
R  192.168.160.0/24 [120/1] via 192.168.100.2, 00:00:02, Serial1
R  192.168.140.0/24 [120/1] via 192.168.100.2, 00:00:02, Serial1
R  192.168.170.0/24 [120/1] via 192.168.100.2, 00:00:03, Serial1
O E2 192.168.200.0/24 [110/20] via 192.168.0.1, 00:08:05, Serial0
C  192.168.0.0/24 is directly connected, Serial0
C  192.168.100.0/24 is directly connected, Serial1

O IA 192.168.1.0/24 [110/128] via 192.168.0.1, 00:08:22, Serial0

ここまでは,NSSA内にある外部ネットワークのLSAの伝わり方を見てきました。
LSAが左から右へ伝達する様子ですね。
今度は逆に,RouterDにある外部ネットワーク(RIPのネットワーク)のLSAの伝わり方に注目します。
まず,NSSA設定後のRouterAのルーティング・テーブルを見てみます。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C  192.168.200.0/24 is directly connected, Loopback0
O IA 192.168.0.0/24 [110/128] via 192.168.1.2, 00:01:43, Serial0
C  192.168.1.0/24 is directly connected, Serial0


このルーティング・テーブルをじっくり見て下さい。
RouterDの先にある外部ネットワークへ到達するためのデフォルト・ルートがありません。
このように,NSSAのABR(RouterB)は,ほかのエリアにある外部ネットワークの経路情報(Type5のLSA)をブロックしますが,その代わりとなるデフォルト・ルートを通知してくれません。
(RouterBがRouterCからType5のLSAを受信している様子は,上の青字の部分でわかります。
このように,NSSAを使うと,自分のエリアでは外部ネットワークを通知しながらも,ほかの外部ネットワークから来るLSAをブロックできるわけです。

ただこのままでは,RouterDの先にあるRIPネットワークへ通信できません。
そこで,RouterBに外部ネットワークあてのデフォルト・ルートを通知させましょう。
NSSAの設定コマンドに,default-information-originateオプションを付けて再設定してやります。

RouterB(config)#router ospf 1
RouterB(config-router)#area 1 nssa default-information-originate
RouterB(config-router)#
01:02:03: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
01:02:09: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from LOADING to FULL, Loading Done


一度アジャセンシーがダウンして,再びアップしました。
RouterAのルーティング・テーブルを見てみます。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

C  192.168.200.0/24 is directly connected, Loopback0
O IA 192.168.0.0/24 [110/128] via 192.168.1.2, 00:00:37, Serial0
C  192.168.1.0/24 is directly connected, Serial0
O*N2 0.0.0.0/0 [110/1] via 192.168.1.2, 00:00:37, Serial0


すると,N2(NSSA)のデフォルト・ルートができました。
RouterAのLSDBを見ると,0.0.0.0のLSAをType7で受信しています。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.1.1) (Process ID 1)

        Router Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum Link count
192.168.1.1   192.168.1.1   221     0x80000012 0x0073FE 2
192.168.1.2   192.168.1.2   221     0x8000000A 0x007AFC 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum
192.168.0.0   192.168.1.2   1175    0x80000004 0x00DA43

        Type-7 AS External Link States (Area 1)

Link ID       ADV Router   Age     Seq#    Checksum Tag
0.0.0.0       192.168.1.2   227     0x80000001 0x004791 0
192.168.200.0  192.168.1.1   1305    0x80000001 0x00335A 0


このように,NSSAでdefault-information-originateコマンドを使うと,外部ネットワークあてのデフォルト・ルートをType7のLSAで通知するようになるわけです。
結局,NSSAにはType7のLSAが,バックボーン・エリアにはType5のLSAが流れることになります(下図)。


   NSSAで外部ネットワークの経路情報がどのように伝わるか

エリア1がNSSAになっているかどうかと,default-information-originateコマンドでデフォルト・ルートを通知しているかどうかは,show ip ospfで確認できます。

RouterB#show ip ospf
Routing Process "ospf 1" with ID 192.168.1.2 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an area border and autonomous system boundary router
Redistributing External Routes from,
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 9. Checksum Sum 0x4A2FE
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 0 stub 1 nssa
External flood list length 0
  Area BACKBONE(0)
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 14 times
    Area ranges are
    Number of LSA 3. Checksum Sum 0x100EC
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0
  Area 1
    Number of interfaces in this area is 1
    It is a NSSA area
    Perform type-7/type-5 LSA translation
    generates NSSA default route with cost 1

    Area has no authentication
    SPF algorithm executed 25 times
    Area ranges are
    Number of LSA 5. Checksum Sum 0x1F451
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


●NSSAをトータリースタブNSSAに変更する
NSSAより,さらに経路情報を効率化できるのが,「トータリースタブNSSA」です。
「トータリーNSSA」や「NSSAトータリースタブ」などと呼ばれることもあります。

コマンドは,NSSAの設定にno-summaryオプションを付けるだけです。
RouterBのNSSAの設定を消して,トータリースタブNSSAの設定をしてみましょう。

RouterB(config)#router ospf 1
RouterB(config-router)#no area 1 nssa default-information-originate
RouterB(config-router)#area 1 nssa no-summary
RouterB(config-router)#
05:48:08: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
05:48:15: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from LOADING to FULL, Loading Done


一度アジャセンシーがダウンして,しばらくしてまたアップしました。
RouterAのLSDBを見てみましょう。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.1.1) (Process ID 1)

        Router Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum Link count
192.168.1.1   192.168.1.1   65     0x8000001D 0x005D0A 2
192.168.1.2   192.168.1.2   65     0x80000015 0x006408 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum
0.0.0.0      192.168.1.2   70     0x80000002 0x0018B0

        Type-7 AS External Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum Tag
192.168.200.0  192.168.1.1   166     0x80000007 0x002760 0


Type3(Summary Net Link States)にあった192.168.0.0のLSAがなくなって,代わりにType3のデフォルト・ルートが出来ました。
RouterAのルーティング・テーブルはどうなっているでしょうか。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

C  192.168.200.0/24 is directly connected, Loopback0
C  192.168.1.0/24 is directly connected, Serial0
O*IA 0.0.0.0/0 [110/65] via 192.168.1.2, 00:07:14, Serial0


ABRに向けたデフォルト・ルートがあるのはNSSAと同じです。
NSSAと違うのは,N2(NSSA)のデフォルト・ルートではなく,IA(外部エリア)のデフォルト・ルートになっています。
ABR(RouterB)は,外部ネットワークの経路情報に加えて外部エリアの経路情報も,デフォルト・ルートとしてまとめて通知したわけです。
こちらはNSSAとは違い,特別にコマンドを入力しなくてもデフォルト・ルートを通知するからラクですね。

OSPFラボ
OSPFの基本設定
パッシブ・インタフェースの設定
プライオリティの設定と代表ルーターの選出
NBMAネットワーク(ノンブロードキャスト)
NBMAネットワーク(ブロードキャスト)
NBMAネットワーク(ポイントツーマルチポイント)
OSPFコストの設定
エリア設定(標準,スタブ,トータリースタブ)
エリア設定(NSSA,トータリースタブNSSA)
OSPFバーチャルリンク
OSPFの経路集約
ネイバー認証
(ツール)OSPFトポロジ表示フラッシュ