OSPFのパッシブ・インタフェース
・OSPFで余分なインタフェースからはHelloパケットを送出しないようにする
・パッシブ・インタフェースになっていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
no keepalive
!
interface Serial0
ip address 192.168.0.1 255.255.255.0
clockrate 64000
!
router ospf 64
log-adjacency-changes
passive-interface Ethernet0 ←Ethernet0をパッシブ・インタフェースにする
network 10.10.10.1 0.0.0.0 area 0
network 192.168.0.1 0.0.0.0 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Ethernet0
ip address 20.20.20.1 255.255.255.0
no keepalive
!
interface Serial0
ip address 192.168.0.2 255.255.255.0
no fair-queue
!
router ospf 64
log-adjacency-changes
passive-interface default ←すべてのインタフェースをパッシブ・インタフェースにする
no passive-interface Serial0 ←Serial0をパッシブから解除する
network 0.0.0.0 255.255.255.255 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
OSPFのHelloパケットは,EthernetやSerial(HDLCやPPP)インタフェースなら10秒間隔で出ます。
しかしこの定期的な送信は,OSPFルーターの相手がいないサブネットでは無駄です。
インタフェースでOSPFはオンにしたいけど,Helloパケットの送信は帯域の無駄だから止めたいというときは,パッシブ・インタフェースを使います。

●動作の確認
今回のケースでは,RouterAとRouterBのEthernet0インタフェースの先にはOSPFルーターはありません。
そのため,EthernetインタフェースからHelloパケットを送出するのは意味がありません。
そこで,両ルーターのEthernet0インタフェースをパッシブ・インタフェースに設定します。
そのコマンドが,

passive-interface Ethernet0

ですが,このコマンドを設定していない状態から見てみましょう。
まず,RouterAからどんなパケットが出ているのかをデバッグ・コマンドで調べてみます。

RouterA#debug ip packet
IP packet debugging is on
RouterA#
00:09:06: IP: s=10.10.10.1 (local), d=224.0.0.5 (Ethernet0), len 64, sending broad/multicast
00:09:09: IP: s=192.168.0.1 (local), d=224.0.0.5 (Serial0), len 68, sending broad/multicast
00:09:09: IP: s=192.168.0.2 (Serial0), d=224.0.0.5, len 68, rcvd 0
00:09:16: IP: s=10.10.10.1 (local), d=224.0.0.5 (Ethernet0), len 64, sending broad/multicast
00:09:19: IP: s=192.168.0.1 (local), d=224.0.0.5 (Serial0), len 68, sending broad/multicast
00:09:19: IP: s=192.168.0.2 (Serial0), d=224.0.0.5, len 68, rcvd 0


すると,Ethernet0とSerial0から224.0.0.5というマルチキャスト・パケットを10秒間隔で出しているのがわかります。
これは,OSPFのHelloパケットです。

では,RouterAのEthernet0をパッシブ・インタフェースにします。
OSPFの設定モードでpassive-interfceコマンドを使います。

RouterA(config)#router ospf 64
RouterA(config-router)#
passive-interface Ethernet 0


設定がきちんと反映されたか確認してみましょう。
show ip protocolsコマンドでわかります。

RouterA#show ip protocols
Routing Protocol is "ospf 64"
Invalid after 0 seconds, hold down 0, flushed after 0
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Routing for Networks:
10.10.10.1/32
192.168.0.1/32
Passive Interface(s):
Ethernet0

Routing Information Sources:
Gateway Distance Last Update
192.168.0.2 110 00:13:29
Distance: (default is 110)


確かにEthernet0がパッシブ・インタフェースになっていますね。

心配だったら(?),再びデバッグで送出パケットを見てみましょう。

RouterA#debug ip packet
IP packet debugging is on
RouterA#
00:14:39: IP: s=192.168.0.1 (local), d=224.0.0.5 (Serial0), len 68, sending broad/multicast
00:14:39: IP: s=192.168.0.2 (Serial0), d=224.0.0.5, len 68, rcvd 0
00:14:49: IP: s=192.168.0.1 (local), d=224.0.0.5 (Serial0), len 68, sending broad/multicast
00:14:49: IP: s=192.168.0.2 (Serial0), d=224.0.0.5, len 68, rcvd 0


マルチキャストは,Serial0からしか出ていません。
これで,RouterAのEthernet0インタフェースは,OSPFはオンになっているけどHelloパケットは送らないパッシブの状態になりました。

RouterBのEthernet0も同様にパッシブ・インタフェースに設定します。
こっちは,RouterAと違う方法で設定してみましょう。
passive-interface defaultと入力すると,RouterBのすべてのインタフェースがパッシブ・インタフェースになります。
実行してみます。

RouterB(config-router)#passive-interface default
RouterB(config-router)#
00:20:04: %OSPF-5-ADJCHG: Process 64, Nbr 192.168.0.1 on Serial0 from FULL to DOWN, Neighbor Down: Interface down or detached


Serial0もパッシブ・インタフェースになったので,RouterA(192.168.0.1)とのネイバーがダウンしてしまいました。
こんなときは,no passive-interfaceコマンドを使って,Serial0だけパッシブを解除してやります。

RouterB(config-router)#no passive-interface Serial 0
RouterB(config-router)#
00:20:27: %OSPF-5-ADJCHG: Process 64, Nbr 192.168.0.1 on Serial0 from LOADING to FULL, Loading Done


RouterA(192.168.0.1)とアジャセンシーが確立されたことを示すメッセージが出ました。
これでRouterBも,Ethernet0だけパッシブ・インタフェースになりました。

OSPFラボ
OSPFの基本設定
パッシブ・インタフェースの設定
プライオリティの設定と代表ルーターの選出
NBMAネットワーク(ノンブロードキャスト)
NBMAネットワーク(ブロードキャスト)
NBMAネットワーク(ポイントツーマルチポイント)
OSPFコストの設定
エリア設定(標準,スタブ,トータリースタブ)
エリア設定(NSSA,トータリースタブNSSA)
OSPFバーチャルリンク
OSPFの経路集約
ネイバー認証
(ツール)OSPFトポロジ表示フラッシュ