OSPFプライオリティの設定と代表ルーターの選出
・インタフェースにOSPFプライオリティを設定する
・OSPFプライオリティを変更して,代表ルーターが変わることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip ospf priority 100 ←OSPFプライオリティを100に設定
!
router ospf 64
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.2
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0
ip address 192.168.0.2 255.255.255.0
ip ospf priority 0 ←OSPFプライオリティを0に設定
!
router ospf 64
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Ethernet0
ip address 192.168.0.3 255.255.255.0
ip ospf priority 2 ←OSPFプライオリティを2に設定
!
router ospf 64
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterDのコンフィグ
!
version 12.2
service timestamps log uptime
no service password-encryption
!
hostname RouterD
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface Ethernet0
ip address 192.168.0.4 255.255.255.0 ←OSPFプライオリティはデフォルトのまま
!
router ospf 64
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 192.168.0.0 0.0.0.255 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
OSPFを語るときに必ず出てくるのが「代表ルーター(DR)」です。
イーサネットなどのマルチアクセス環境では,サブネット上に自分以外のたくさんのルーターがいます。
そこで,このような環境では,LSAをやりとりする代表ルーターを1台決めます。
ルーターは,経路情報の変更があったら代表ルーターに通知し,その変更情報を代表ルーターがとりまとめてサブネット上のほかのルーターに配る,という形をとります。

ここでは,インタフェースにOSPFプライオリティを設定して,代表ルーターがどのように決まるのかを見てみます。

●設定の確認
代表ルーターの選出が行われるのはEthernetインタフェースのサブネットです。
なので,各ルーターのEthernetインタフェースに以下のコマンドを入力します。

ip ospf priority プライオリティ値

ここでは,以下のような設定になっています。

RouterA:プライオリティ100
RouterB:プライオリティ0
RouterC:プライオリティ1
RouterD:設定なし

代表ルーターになるのは,サブネット上でOSPFプライオリティが一番大きなルーターです。
そして,プライオリティ0のルーターは,代表ルーターにはなりません
この設定で,代表ルーターがどうなっているのか見てみましょう。

●動作の確認
RouterAのネイバーを確認してみます。
ここで「Pri」とあるのがOSPFプライオリティです。

RouterA#show ip ospf neighbor

Neighbor ID   Pri     State        Dead Time   Address    Interface
2.2.2.2       0     FULL/DROTHER  00:00:34    192.168.0.2  Ethernet0
3.3.3.3       2     FULL/BDR     00:00:30    192.168.0.3  Ethernet0
4.4.4.4       1     FULL/DROTHER  00:00:32    192.168.0.4  Ethernet0


「Pri」が一番大きい「2」の192.168.0.3(RouterC)が代表ルーター?
いやいや,192.168.0.3は,「State」の欄を見ると「BDR」となっています。
これは,バックアップ代表ルーターです。
自分を忘れてはいけません(爆)。
自分のOSPFインタフェースがどうなっているのか見てみます。

RouterA#show ip ospf interface Ethernet 0
 Ethernet0 is up, line protocol is up
 Internet Address 192.168.0.1/24, Area 0
 Process ID 64, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
 Transmit Delay is 1 sec, State DR, Priority 100
 Designated Router (ID) 1.1.1.1, Interface address 192.168.0.1
 Backup Designated router (ID) 3.3.3.3, Interface address 192.168.0.3
 Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
  oob-resync timeout 40
  Hello due in 00:00:08
 Index 1/1, flood queue length 0
 Next 0x0(0)/0x0(0)
 Last flood scan length is 1, maximum is 1
 Last flood scan time is 4 msec, maximum is 4 msec
 Neighbor Count is 3, Adjacent neighbor count is 3
  Adjacent with neighbor 2.2.2.2
  Adjacent with neighbor 3.3.3.3 (Backup Designated Router)
  Adjacent with neighbor 4.4.4.4
 Suppress hello for 0 neighbor(s)


「State」がDRで,やはり自分が代表ルーターになっています。
プライオリティが100というのも表示されていますね。

プライオリティを設定しなかったRouterDのプライオリティはどうなっているでしょう?
同様に,RouterDのOSPFインタフェースも見てみます。

RouterD#show ip ospf interface ethernet 0
 Ethernet0 is up, line protocol is up
 Internet Address 192.168.0.4/24, Area 0
 Process ID 64, Router ID 4.4.4.4, Network Type BROADCAST, Cost: 10
 Transmit Delay is 1 sec, State DROTHER, Priority 1
 Designated Router (ID) 1.1.1.1, Interface address 192.168.0.1
 Backup Designated router (ID) 3.3.3.3, Interface address 192.168.0.3
 Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
  Hello due in 00:00:00
 Index 1/1, flood queue length 0
 Next 0x0(0)/0x0(0)
 Last flood scan length is 1, maximum is 1
 Last flood scan time is 0 msec, maximum is 0 msec
 Neighbor Count is 3, Adjacent neighbor count is 2
  Adjacent with neighbor 3.3.3.3 (Backup Designated Router)
  Adjacent with neighbor 1.1.1.1 (Designated Router)
 Suppress hello for 0 neighbor(s)


「State」がDROTHERで,プライオリティが1です。
DROTHERというのは,代表ルーターでもバックアップ代表ルーターでもないルーターのことです。
何も設定しなければ,OSPFプライオリティは1になるわけですね。

RouterA以外の三つのルーターのネイバーも見ておきましょう。
まずはRouterBです。
「State」の2WAYというのは,ネイバー(アジャセンシーではなく)が確立している状態です。
これは,Helloを受信してして同一サブネットにいることを認識している状態です。
「LSAはやりとりしないけど,お隣さんとして認識しているよ」ということです。

RouterB#show ip ospf neighbor

Neighbor ID   Pri    State        Dead Time   Address    Interface
4.4.4.4       1   2WAY/DROTHER  00:00:36    192.168.0.4  Ethernet0
3.3.3.3       2   FULL/BDR      00:00:34    192.168.0.3  Ethernet0
1.1.1.1     100   FULL/DR       00:00:39    192.168.0.1  Ethernet0


下がRouterCです。

RouterC#show ip ospf neighbor

Neighbor ID   Pri    State        Dead Time    Address    Interface
4.4.4.4       1   FULL/DROTHER   00:00:37    192.168.0.4  Ethernet0
1.1.1.1     100   FULL/DR       00:00:30    192.168.0.1  Ethernet0
2.2.2.2       0   FULL/DROTHER   00:00:30    192.168.0.2  Ethernet0


そしてRouterDが以下です。

RouterD#show ip ospf neighbor

Neighbor ID   Pri    State         Dead Time    Address    Interface
3.3.3.3       2    FULL/BDR      00:00:31    192.168.0.3  Ethernet0
1.1.1.1     100    FULL/DR       00:00:36    192.168.0.1  Ethernet0
2.2.2.2       0    2WAY/DROTHER  00:00:35    192.168.0.2  Ethernet0


皆,プライオリティが一番高いRouterAを代表ルーターとして認識していることがわかります。

これだけではつまらないので,意図的に代表ルーターを変更させてみましょう。
RouterBのOSPFプライオリティを,200に変更してみます。
以下のコマンドを入力します。

RouterB(config)#interface ethernet 0
RouterB(config-if)#ip ospf priority 200

入力したら,RouterDのネイバーを見てみましょう。

RouterD#show ip ospf neighbor

Neighbor ID   Pri    State          Dead Time    Address   Interface
3.3.3.3       2   FULL/BDR        00:00:38   192.168.0.3  Ethernet0
1.1.1.1     100   FULL/DR         00:00:36   192.168.0.1  Ethernet0
2.2.2.2     200   2WAY/DROTHER    00:00:36  192.168.0.2  Ethernet0

RouterBのプライオリティが200で一番高いのに,DROTHERになってます。
でもこれはこれで正常な動きです。
実は,代表ルーターが変わるときは,タイミングが決まっているのです。
それは,

・DR/BDRがダウンまたは再起動したとき
・DR/BDRのインタフェースをshutdownしたとき
・no router ospf プロセスIDコマンドで,OSPFプロセスを終了したとき
・clear ip ospf processコマンドで,OSPFプロセスを初期化したとき

です。
ではここで,RouterAの電源を落としてみます。
パチっとな。
すると十数秒後くらいに,RouterDに以下のメッセージが出てきます。

01:47:02: %OSPF-5-ADJCHG: Process 64, Nbr 1.1.1.1 on Ethernet0 from FULL to DOWN, Neighbor Down: Dead timer expired
01:47:09: %OSPF-5-ADJCHG: Process 64, Nbr 2.2.2.2 on Ethernet0 from LOADING to FULL, Loading Done


1行目は,RouterA(1.1.1.1)とのネイバー確立がダウンしたことを知らせるメッセージです。
2行目は,RouterB(2.2.2.2)とFULLステータスまで行って,アジャセンシーを確立したことを示すメッセージです。

RouterDのネイバーは,どのように変わったでしょうか。

RouterD#show ip ospf neighbor

Neighbor ID   Pri    State         Dead Time    Address   Interface
3.3.3.3       2    FULL/DR       00:00:38   192.168.0.3   Ethernet0
2.2.2.2     200    FULL/BDR      00:00:35   192.168.0.2   Ethernet0


これまでバックアップ代表ルーター(BDR)だったRouterBが代表ルーター(DR)に昇格しています。
で,RouterBがバックアップ代表ルーターになったことがわかります。
しっかりとバックアップが効いているんですね。
エライ!

OSPFラボ
OSPFの基本設定
パッシブ・インタフェースの設定
プライオリティの設定と代表ルーターの選出
NBMAネットワーク(ノンブロードキャスト)
NBMAネットワーク(ブロードキャスト)
NBMAネットワーク(ポイントツーマルチポイント)
OSPFコストの設定
エリア設定(標準,スタブ,トータリースタブ)
エリア設定(NSSA,トータリースタブNSSA)
OSPFバーチャルリンク
OSPFの経路集約
ネイバー認証
(ツール)OSPFトポロジ表示フラッシュ