エリア設定(標準,スタブ,トータリースタブ)
・標準エリアをスタブ・エリアに変更する
・スタブ・エリアをトータリースタブ・エリアに変更する
・それぞれのエリアで受信する経路情報がどのように変わるかを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
area 1 stub ←エリア1をスタブ・エリアにする
network 192.168.1.0 0.0.0.255 area 1
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.168.0.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
area 1 stub ←エリア1をスタブ・エリアにする
network 192.168.0.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 1
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Serial0
ip address 192.168.0.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
ip address 192.168.100.1 255.255.255.0
clockrate 64000
!
router ospf 1
log-adjacency-changes
redistribute rip metric 10 subnets ←RIPで学習した経路情報をOSPF(のコスト10)で再配布する
network 192.168.0.0 0.0.0.255 area 0
!
router rip
network 192.168.100.0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterDのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterD
!
interface Loopback0
ip address 192.168.110.1 255.255.255.0
!
interface Loopback1
ip address 192.168.120.1 255.255.255.0
!
interface Loopback2
ip address 192.168.130.1 255.255.255.0
!
interface Loopback3
ip address 192.168.140.1 255.255.255.0
!
interface Loopback4
ip address 192.168.150.1 255.255.255.0
!
interface Loopback5
ip address 192.168.160.1 255.255.255.0
!
interface Loopback6
ip address 192.168.170.1 255.255.255.0
!
interface Serial0
ip address 192.168.100.2 255.255.255.0
!
router rip
network 192.168.100.0
network 192.168.110.0
network 192.168.120.0
network 192.168.130.0
network 192.168.140.0
network 192.168.150.0
network 192.168.160.0
network 192.168.170.0
!
ip route 0.0.0.0 0.0.0.0 192.168.100.1 ←デフォルト・ルートをRouterCに向ける
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
OSPFの最大の特徴を挙げるとしたら,それは「マルチエリア」です。
エリアという概念があるから,拡張性があり,負荷を抑え,きめ細やかな運用ができるようになります。

●マルチエリアOSPFで出てくる用語
ただOSPFは,高機能なだけに前提知識も必要になってきます。
専門用語も多いので,最初にざっとまとめておきます。
この先読み進めていって,「この用語なんだっけ?」と思ったらここに戻ってくるといいと思います。

【OSPFのエリアの種類】
・バックボーン・エリア……すべてのエリアと接続する中核エリア。必須
・非バックボーン・エリア…バックボーン・エリアに接続するエリア
 ├標準エリア……………………すべてのLSAが通知される
 ├スタブ・エリア …………………外部ネットワークがデフォルト・ルートとして通知される
 ├トータリースタブ・エリア………外部ネットワークと外部エリアがデフォルト・ルートとして通知される
 ├NSSA(Not So Stuby Area)…外部ネットワークを直接つなげるようにしたスタブエリア
 └トータリーNSSA………………外部エリアがデフォルト・ルートとして通知されるようにしたNSSA
  ※外部ネットワークとは,OSPF以外のルーティング・プロトコルが動作するネットワークのこと

【OSPFルーターの種類】
・IR(内部ルーター)……………全インタフェースが一つのエリアに所属するルーター
・ABR(エリア境界ルーター)…複数のエリアにインタフェースを持つルーター
・ASBR(AS境界ルーター)……OSPF以外が動作するネットワークとつながるルーター

【LSAのタイプ】
・タイプ1:ルーターLSA…………………ルーターのインタフェース情報など。全OSPFルーターが作る
・タイプ2:ネットワークLSA ……………マルチアクセス・ネットワーク内のルーター情報など。DRが作る
・タイプ3:ネットワーク・サマリーLSA…他エリアの経路情報。ABRが作る
・タイプ4:ASBRサマリーLSA…………ASBRあての経路情報。ABRが作る
・タイプ5:AS外部LSA…………………外部ネットワークの経路情報。ASBRが作る
・タイプ7:NSSA外部LSA ……………NSSAを通じて通知する外部ネットワークの経路情報。NSSA内のASBRが作る

●設定の確認
OSPFの設定をしているのは,RouterA,RouterB,RouterCの3台です。
それぞれのルーターの役割を確認しましょう。

RouterAは,すべてのインタフェースが一つのエリアに属しているので,これは内部ルーターです。
RouterBは,エリア0とエリア1の二つのエリア境界に位置しているので,ABRです。
ルーターに二つのエリアを設定した時点で,そのルーターはABRになります。
ルーターがABRになっているかは,show ip ospfコマンドで確認できます。

RouterB#show ip ospf
Routing Process "ospf 1" with ID 192.168.1.2 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an area border router
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 8. Checksum Sum 0x470E2
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
External flood list length 0
  Area BACKBONE(0)
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 10 times
    Area ranges are
    Number of LSA 3. Checksum Sum 0x10EEA
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0
  Area 1
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 12 times
    Area ranges are
    Number of LSA 4. Checksum Sum 0x2D515
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


OSPF以外で学習した経路情報をOSPFで再配布するように設定したルーターが,ASBRになります。
RouterCには,RIPからOSPFへの再配布の設定がしてあるので,RouterCがASBRです。
これもshow ip ospfコマンドで確認できます。

RouterC#show ip ospf
Routing Process "ospf 1" with ID 192.168.100.1 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an autonomous system boundary router
Redistributing External Routes from,
  rip with metric mapped to 10, includes subnets in redistribution
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 8. Checksum Sum 0x440FA
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
  Area BACKBONE(0)
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 4 times
    Area ranges are
    Number of LSA 3. Checksum Sum 0x11FE1
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


それぞれのエリアに注目すると,エリア0がバックボーン・エリアで,エリア1が標準エリアです。
RIPネットワークが,外部ネットワークになります。

●標準エリアの状態を確認する
スタブ・エリアに関する設定は,RouterAとRouterBのコンフィグにある
area 1 stub
というコマンドです。
このコマンドを入れることによって,エリア1をスタブ・エリアにできます。
RouterAとRouterBにこのコマンドを入れていない,エリア1が標準エリアの状態から見ていきましょう

まず,標準エリアの状態で,RouterAのルーティング・テーブルを見てみます。

RouterA#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O E2 192.168.120.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O E2 192.168.150.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O E2 192.168.110.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O E2 192.168.130.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O E2 192.168.160.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O E2 192.168.140.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O E2 192.168.170.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O E2 192.168.100.0/24 [110/10] via 192.168.1.2, 00:06:58, Serial0
O IA 192.168.0.0/24 [110/128] via 192.168.1.2, 00:08:24, Serial0

C  192.168.1.0/24 is directly connected, Serial0

一番左に「O」の印があるのがOSPFで学習した経路情報です。
その中で,「E2」とあるのが外部ネットワークの経路情報で,「IA」というのが他エリアの経路情報です。
OSPFによって経路情報が漏れなく来ているのがわかります。

OSPFルーターは,LSAを集めたデータベース(LSDB)を作り,それを基にネットワークの全体像を把握します。
RouterAのLSDBを確認してみましょう。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.1.1) (Process ID 1)

        Router Link States (Area 1)

Link ID      ADV Router   Age     Seq#      Checksum Link count
192.168.1.1   192.168.1.1   462     0x80000005  0x00E1A5 2
192.168.1.2   192.168.1.2   476     0x80000005  0x00D8AB 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#      Checksum
192.168.0.0   192.168.1.2   476     0x80000006  0x0031F0

        Summary ASB Link States (Area 1)

Link ID      ADV Router   Age     Seq#      Checksum
192.168.100.1 192.168.1.2   476     0x80000004  0x00CCF0


        Type-5 AS External Link States

Link ID      ADV Router   Age     Seq#      Checksum Tag
192.168.100.0  192.168.100.1  38     0x80000004  0x00AA60 0
192.168.110.0  192.168.100.1  38     0x80000004  0x003CC4 0
192.168.120.0  192.168.100.1  40     0x80000004  0x00CD29 0
192.168.130.0  192.168.100.1  40     0x80000004  0x005F8D 0
192.168.140.0  192.168.100.1  40     0x80000004  0x00F0F1 0
192.168.150.0  192.168.100.1  40     0x80000004  0x008256 0
192.168.160.0  192.168.100.1  40     0x80000004  0x0014BA 0
192.168.170.0  192.168.100.1  40     0x80000004  0x00A51F 0


ここでは,青字と緑字のLSAに注目します。
Summary ASB Link States」というのは,ASBRへの経路情報を示したLSAで,これはタイプ4のLSAです(青字)。
その下の「Type-5 AS External Link States」は外部ネットワーク内の経路情報を示したLSAで,これはタイプ5のLSAです(緑字)。
ここまで頭に入れておいて,準備はOKです。

●標準エリアをスタブ・エリアに変更する
ここからが本番。エリア1をスタブ・エリアにします。
RouterBにコマンドを入力します。

RouterB(config)#router ospf 1
RouterB(config-router)#area 1 stub
RouterB(config-router)#
02:28:54: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset


すると,RouterA(192.168.1.1)とのネイバーがダウンしてしまいました。
なぜでしょうか?
RouterAでOSPFのHelloパケットをデバッグして調べてみます。

RouterA#debug ip ospf hello
OSPF hello events debugging is on
RouterA#
*Mar 1 02:32:18.659: OSPF: Rcv hello from 192.168.1.2 area 1 from Serial0 192.168.1.2
*Mar 1 02:32:18.663: OSPF: Hello from 192.168.1.2 with mismatched Stub/Transit area option bit
*Mar 1 02:32:18.871: OSPF: Send hello to 224.0.0.5 area 1 on Serial0 from 192.168.1.1
*Mar 1 02:32:28.659: OSPF: Rcv hello from 192.168.1.2 area 1 from Serial0 192.168.1.2
*Mar 1 02:32:28.663: OSPF: Hello from 192.168.1.2 with mismatched Stub/Transit area option bit
*Mar 1 02:32:28.875: OSPF: Send hello to 224.0.0.5 area 1 on Serial0 from 192.168.1.1


すると,「スタブエリアに関するオプション・ビットがミスマッチ」と表示されました。
というのも,OSPFルーター同士でネイバーが確立できる条件として,お互いのHelloパケット内にスタブであることを示す情報が入っている必要があります(具体的には,Helloパケット内のオプション・フィールドのEビットが0になっている必要があります)。
そのため,ネイバーを確立するためには,対向ルーターであるRouterAにも同様の設定をする必要があります。

RouterAにも同様にスタブの設定をします。

RouterA(config)#router ospf 1
RouterA(config-router)#area 1 stub
*Mar 1 02:34:19.015: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.2 on Serial0 from LOADING to FULL, Loading Done


RouteBとのネイバーが確立して,さらにアジャセンシーを確立したメッセージが表示されました。
これでエリア1が,スタブエリアになりました。

再びRouterAのルーティング・テーブルを見てみましょう。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

O IA 192.168.0.0/24 [110/128] via 192.168.1.2, 00:00:19, Serial0
C  192.168.1.0/24 is directly connected, Serial0
O*IA 0.0.0.0/0 [110/65] via 192.168.1.2, 00:00:19, Serial0


外部ネットワークを示す「E2」の経路情報がなくなって,一つのデフォルト・ルートに置き換わりました。
こうして経路情報を効率化するのがスタブ・エリアの機能というわけです。

再度RouterAのLSDBを見てみましょう。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.1.1) (Process ID 1)

        Router Link States (Area 1)

Link ID     ADV Router   Age     Seq#    Checksum Link count
192.168.1.1   192.168.1.1   58     0x80000007 0x00FB8B 2
192.168.1.2   192.168.1.2   59     0x80000007 0x00F291 2

        Summary Net Link States (Area 1)

Link ID     ADV Router   Age     Seq#    Checksum
0.0.0.0      192.168.1.2   379     0x80000001 0x00923F
192.168.0.0   192.168.1.2   379     0x80000007 0x004DD5


タイプ4とタイプ5のLSAがなくなって,代わりにタイプ3のデフォルト・ルートを受け取っています。
つまり,ABRであるRouterBが,外部ネットワークに関するタイプ5とタイプ4のLSAの代わりに,タイプ3のデフォルト・ルートをRouterAに通知したわけです。
このように,受信するLSAの量を減らして経路情報を効率化するのがスタブ・エリアの機能です。

RouterAのエリア1がスタブ・エリアになったかどうかは,show ip ospfコマンドで確認できます。

RouterA#show ip ospf
Routing Process "ospf 1" with ID 192.168.1.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 0 normal 1 stub 0 nssa
External flood list length 0
  Area 1
    Number of interfaces in this area is 1
    It is a stub area
    Area has no authentication
    SPF algorithm last executed 01:29:01.020 ago
    SPF algorithm executed 14 times
    Area ranges are
    Number of LSA 4. Checksum Sum 0x02B63C
    Number of opaque link LSA 0. Checksum Sum 0x000000
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


●スタブ・エリアをトータリースタブ・エリアに変更する
さらに経路情報を効率化するのが,トータリースタブです。
トータリースタブの設定コマンドは,
area 1 stub no-summary
です。
スタブエリアの設定コマンドに「no-summary」オプションが付きます。

トータリースタブはABRであるRouteBだけに設定すればOKです。

RouterB(config)#router ospf 1
RouterB(config-router)#area 1 stub no-summary
RouterB(config-router)#
04:31:18: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
04:31:24: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial0 from LOADING to FULL, Loading Done


設定すると,いったんネイバーがダウンして,再びアップしました。
RouterAのルーティング・テーブルを見てみます。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

C  192.168.1.0/24 is directly connected, Serial0
O*IA 0.0.0.0/0 [110/65] via 192.168.1.2, 00:00:33, Serial0


すると,スタブエリアのときにあった外部エリアの経路情報(192.168.0.0/24)がなくなって,これもデフォルト・ルートに置き換わりました。
エリアをトータリースタブにすると,外部ネットワークの経路情報に加えて,外部エリアの経路情報もデフォルト・ルートに一本化するわけです。
スタブより,さらにルーティング・テーブルを効率化できることになります。

RouterAのLSDBを確認はどうなっているでしょうか。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.1.1) (Process ID 1)

        Router Link States (Area 1)

Link ID     ADV Router   Age     Seq#    Checksum Link count
192.168.1.1   192.168.1.1   63     0x8000000F 0x00EB93 2
192.168.1.2   192.168.1.2   68     0x8000000F 0x00E299 2

        Summary Net Link States (Area 1)

Link ID     ADV Router   Age     Seq#    Checksum
0.0.0.0     192.168.1.2   69     0x80000004 0x008C42


「Summary Net Link States」は,外部エリアの経路情報を示すタイプ3のLSAです。
ここにあったLSAが,デフォルト・ルートに置き換わっているのがわかります。

エリア1がトータリースタブになったかどうかは,ASBR(RouterB)でshow ip ospfコマンドを入力すると確認できます。

RouterB#show ip ospf
Routing Process "ospf 1" with ID 192.168.1.2 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an area border router
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 8. Checksum Sum 0x43102
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 1 normal 1 stub 0 nssa
External flood list length 0
  Area BACKBONE(0)
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 18 times
    Area ranges are
    Number of LSA 3. Checksum Sum 0x108ED
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0
  Area 1
    Number of interfaces in this area is 1
    It is a stub area, no summary LSA in this area
     generates stub default route with cost 1
    Area has no authentication
    SPF algorithm executed 32 times
    Area ranges are
    Number of LSA 3. Checksum Sum 0x22C85
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


このように,受信するLSAを少なくして経路情報を効率化するのが,スタブ・エリアとトータリースタブ・エリアの機能というわけです。

スタブ・エリアとトータリースタブ・エリアは,エリアの出口となるルーターが一つなんだから,「デフォルト・ルートをABRに向けておけばいいや!」と考えたくなりますよね。
逆に言えば,ABRに「これはエリア外や外部ネットワークの経路だから,スタブ・エリアのルーターにはデフォルト・ルートを教えればいいや」という動作をさせればいいわけです。
こういった動作をさせるためには,伝播している経路情報がどいうものかわからないといけません。
なのでOSPFのLSAには,Type3とかType5とか,細かくタイプが決められているんですね。

OSPFラボ
OSPFの基本設定
パッシブ・インタフェースの設定
プライオリティの設定と代表ルーターの選出
NBMAネットワーク(ノンブロードキャスト)
NBMAネットワーク(ブロードキャスト)
NBMAネットワーク(ポイントツーマルチポイント)
OSPFコストの設定
エリア設定(標準,スタブ,トータリースタブ)
エリア設定(NSSA,トータリースタブNSSA)
OSPFバーチャルリンク
OSPFの経路集約
ネイバー認証
(ツール)OSPFトポロジ表示フラッシュ