OSPFの経路集約
・ASBRで,外部ネットワークの経路情報を集約して送信する
・ABRで,外部エリアの経路情報を集約して送信する
・それぞれの経路情報が集約されていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Serial0
ip address 192.168.0.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 1
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Loopback0
ip address 192.168.1.129 255.255.255.192
ip ospf network point-to-point ←Loopbackアドレスを設定のマスク長で送信するようにする
!
interface Serial0
ip address 192.168.0.2 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.168.1.1 255.255.255.128
!
router ospf 1
log-adjacency-changes
area 0 range 192.168.1.0 255.255.255.0 ←エリア0の経路情報を192.168.1.0/24に集約
network 192.168.0.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 192.168.1.193 255.255.255.192
ip ospf network point-to-point ←Loopbackアドレスを設定のマスク長で送信するようにする
!
interface Serial0
ip address 192.168.1.2 255.255.255.128
no fair-queue
clockrate 64000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 64000
!
router ospf 1
log-adjacency-changes
summary-address 172.16.0.0 255.255.248.0 ←外部ネットワークの経路情報を172.16.1.0/21に集約
redistribute rip metric 10 subnets ←RIPで学習した経路情報をOSPFで再配信
network 192.168.1.0 0.0.0.255 area 0
!
router rip
version 2
network 192.168.2.0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterDのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterD
!
interface Loopback0
ip address 172.16.0.1 255.255.255.0
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
!
interface Loopback3
ip address 172.16.3.1 255.255.255.0
!
interface Loopback4
ip address 172.16.4.1 255.255.255.0
!
interface Loopback5
ip address 172.16.5.1 255.255.255.0
!
interface Loopback6
ip address 172.16.6.1 255.255.255.0
!
interface Loopback7
ip address 172.16.7.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
!
router rip
version 2
network 172.16.0.0
network 192.168.2.0
no auto-summary ←RIPの自動集約はオフにしておく
!
ip route 0.0.0.0 0.0.0.0 192.168.2.1 ←デフォルト・ゲートウエイをRouterCに向ける
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
マルチ・エリアOSPFだと,ネットワーク全体の経路情報は多くなりがちです。
そこでポイントとなってくるのが,経路情報の集約です。
ルーター同士がやりとりするLSAの数を少なくできるので,ルーターの負荷を抑えらることができます。

●設定の確認
OSPFで経路情報を集約できるルーターは,ASBRとABRの二つです。
今回の場合,以下の二つのコマンドが経路集約のコマンドです。
ASBR(RouterC)のsummary-address 172.16.0.0 255.255.248.0
ABR(RouterB)のarea 0 range 192.168.1.0 255.255.255.0 
まずは,この二つのコマンドをを入力していない状態から見ていきましょう

今回は,RouterAの経路情報に注目していきます。
RouterAのルーティング・テーブルを見てみましょう。
外部ネットワーク(RouterDのRIPネットワーク)の経路情報が「E2」として登録されていますね(赤字の部分)。
また,外部エリア(エリア0)の経路情報が「IA」として登録されています(青字の部分)。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

   172.16.0.0/24 is subnetted, 8 subnets
O E2  172.16.0.0 [110/10] via 192.168.0.2, 00:00:07, Serial0
O E2  172.16.1.0 [110/10] via 192.168.0.2, 00:00:07, Serial0
O E2  172.16.2.0 [110/10] via 192.168.0.2, 00:00:07, Serial0
O E2  172.16.3.0 [110/10] via 192.168.0.2, 00:00:08, Serial0

O E2  172.16.4.0 [110/10] via 192.168.0.2, 00:00:07, Serial0
O E2  172.16.5.0 [110/10] via 192.168.0.2, 00:00:07, Serial0
O E2  172.16.6.0 [110/10] via 192.168.0.2, 00:00:07, Serial0
O E2  172.16.7.0 [110/10] via 192.168.0.2, 00:00:07, Serial0
C  192.168.0.0/24 is directly connected, Serial0
   192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O IA  192.168.1.0/25 [110/128] via 192.168.0.2, 01:17:09, Serial0
O IA  192.168.1.192/26 [110/129] via 192.168.0.2, 01:15:49, Serial0
O IA  192.168.1.128/26 [110/65] via 192.168.0.2, 01:17:10, Serial0

O E2 192.168.2.0/24 [110/10] via 192.168.0.2, 00:00:09, Serial0


RouterAのLSDBも確認しておきます。
外部ネットワークのLSAをType5として受け取っています(赤字の部分)。
外部エリアのLSAはType3として受け取っています(青字の部分)。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.0.1) (Process ID 1)

        Router Link States (Area 1)

Link ID     ADV Router   Age     Seq#    Checksum Link count
192.168.0.1   192.168.0.1   844     0x80000004 0x00CE3E 2
192.168.1.129  192.168.1.129  916     0x80000004 0x00B7D1 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#    Checksum
192.168.1.0   192.168.1.129  916     0x80000005 0x002EF3
192.168.1.128  192.168.1.129  916     0x80000003 0x00366C
192.168.1.192  192.168.1.129  670     0x80000003 0x0036EB


        Summary ASB Link States (Area 1)

Link ID     ADV Router   Age     Seq#    Checksum
192.168.1.193  192.168.1.129  180     0x80000001 0x009350

        Type-5 AS External Link States

Link ID     ADV Router   Age     Seq#    Checksum Tag
172.16.0.0   192.168.1.193  185     0x80000001 0x006061 0
172.16.1.0   192.168.1.193  186     0x80000001 0x00556B 0
172.16.2.0   192.168.1.193  186     0x80000001 0x004A75 0
172.16.3.0   192.168.1.193  186     0x80000001 0x003F7F 0
172.16.4.0   192.168.1.193  186     0x80000001 0x003489 0
172.16.5.0   192.168.1.193  186     0x80000001 0x002993 0
172.16.6.0   192.168.1.193  186     0x80000001 0x001E9D 0
172.16.7.0   192.168.1.193  186     0x80000001 0x0013A7 0

192.168.2.0   192.168.1.193  186     0x80000001 0x001EF4 0


●外部ネットワークの経路情報を集約する
最初に,OSPF外部ネットワーク(RIPネットワーク)の経路情報を集約して,OSPFネットワークに配信します。
RIPネットワークにある8個のネットワーク(172.16.0.0/24〜192.168.7.0/24)は,172.16.0.0/21という一つのネットワークに集約できます。
そこで,ASBRであるRouterCに,172.16.0.0/21という集約経路を配信させます。
ASBRの経路集約は,summary-addressコマンドを使います。

RouterC(config)#router ospf 1
RouterC(config-router)#summary-address 172.16.0.0 255.255.248.0


RouterAの経路情報を見てみましょう。
8個あった経路情報が集約されて172.16.0.0/21になりました。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

   172.16.0.0/21 is subnetted, 1 subnets
O E2  172.16.0.0 [110/10] via 192.168.0.2, 00:02:00, Serial0

C  192.168.0.0/24 is directly connected, Serial0
   192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O IA  192.168.1.0/25 [110/128] via 192.168.0.2, 01:26:16, Serial0
O IA  192.168.1.192/26 [110/129] via 192.168.0.2, 01:24:56, Serial0
O IA  192.168.1.128/26 [110/65] via 192.168.0.2, 01:26:16, Serial0
O E2 192.168.2.0/24 [110/10] via 192.168.0.2, 00:09:15, Serial0


RouterAのLSDBはどうなっているでしょうか。
こちらも,8個あったType5のLSAが一つにまとめられました。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.0.1) (Process ID 1)

        Router Link States (Area 1)

Link ID      ADV Router   Age      Seq#     Checksum Link count
192.168.0.1   192.168.0.1   1250    0x80000004 0x00CE3E 2
192.168.1.129  192.168.1.129  1322    0x80000004 0x00B7D1 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age      Seq#     Checksum
192.168.1.0   192.168.1.129  1322    0x80000005 0x002EF3
192.168.1.128  192.168.1.129  1322    0x80000003 0x00366C
192.168.1.192  192.168.1.129  1076    0x80000003 0x0036EB

        Summary ASB Link States (Area 1)

Link ID      ADV Router   Age     Seq#      Checksum
192.168.1.193  192.168.1.129  586     0x80000001 0x009350

        Type-5 AS External Link States

Link ID      ADV Router   Age     Seq#     Checksum Tag
172.16.0.0   192.168.1.193  147     0x80000002 0x003B8C 0
192.168.2.0   192.168.1.193  593     0x80000001 0x001EF4 0


RouterCのルーティング・テーブルも見てみましょう。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
R    172.16.0.0/24 [120/1] via 192.168.2.2, 00:00:02, Serial1
R    172.16.1.0/24 [120/1] via 192.168.2.2, 00:00:02, Serial1
R    172.16.2.0/24 [120/1] via 192.168.2.2, 00:00:03, Serial1
R    172.16.3.0/24 [120/1] via 192.168.2.2, 00:00:03, Serial1
R    172.16.4.0/24 [120/1] via 192.168.2.2, 00:00:01, Serial1
R    172.16.5.0/24 [120/1] via 192.168.2.2, 00:00:01, Serial1
R    172.16.6.0/24 [120/1] via 192.168.2.2, 00:00:01, Serial1
R    172.16.7.0/24 [120/1] via 192.168.2.2, 00:00:01, Serial1
O    172.16.0.0/21 is a summary, 00:00:23, Null0
O IA 192.168.0.0/24 [110/192] via 192.168.1.1, 00:07:43, Serial0
   192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
C    192.168.1.0/25 is directly connected, Serial0
C    192.168.1.192/26 is directly connected, Loopback0
O    192.168.1.128/26 [110/65] via 192.168.1.1, 00:07:44, Serial0
C  192.168.2.0/24 is directly connected, Serial1


ネクストホップが「Null0」という経路情報ができました。
Null0あてのパケットは破棄されます。
これは,パケットのループ防止のために,自動的に作られた経路情報です。
集約した経路情報の中にダウンしているものがあったら,そのパケットのあて先はNull0になります。
こうして,行き先のないパケットがループするのを防ぎます。
この機能は,IOS12.0以降のルーターがサポートしています。

また,RouterCで経路情報が集約されているかどうかは,show ip ospf summary-addressコマンドで確認できます。

RouterC#show ip ospf summary-address

OSPF Process 1, Summary-address

172.16.0.0/255.255.248.0 Metric 10, Type 2, Tag 0



●外部エリアの経路情報を集約する
次に,一つのエリア内の経路情報を集約して,その集約経路をほかのエリアに送信します。
エリア0にある三つのネットワーク(192.168.1.0/25,192.168.1.128/26,192.168.1.192/26)は,192.168.1.0/24という一つのネットワークに集約できます。
そこで,ABRであるRouterBに,192.168.1.0/24という集約経路を配信させます。
ABRの経路集約は,「area エリア番号 range」コマンドを使います。

RouterB(config)#router ospf 1
RouterB(config-router)#area 0 range 192.168.1.0 255.255.255.0

RouterAの経路情報を見てみましょう。
3個あった経路情報が集約されて192.168.1.0/24になりました(下の青字の部分)。
経路集約をしていない最初と比べて,だいぶルーティング・テーブルがスッキリしました。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

   172.16.0.0/21 is subnetted, 1 subnets
O E2  172.16.0.0 [110/10] via 192.168.0.2, 00:23:56, Serial0

C  192.168.0.0/24 is directly connected, Serial0
O IA 192.168.1.0/24 [110/65] via 192.168.0.2, 00:11:03, Serial0
O E2 192.168.2.0/24 [110/10] via 192.168.0.2, 00:31:11, Serial0

RouterAのLSDBはどうなっているでしょうか。
こちらも,3個あったType3のLSAが一つにまとめられました(下の青字の部分)。

RouterA#show ip ospf database

      OSPF Router with ID (192.168.0.1) (Process ID 1)

        Router Link States (Area 1)

Link ID     ADV Router    Age     Seq#      Checksum Link count
192.168.0.1   192.168.0.1    501     0x80000005 0x00CC3F 2
192.168.1.129  192.168.1.129  622     0x80000005 0x00B5D2 2

        Summary Net Link States (Area 1)

Link ID      ADV Router   Age     Seq#     Checksum
192.168.1.0   192.168.1.129  622     0x80000007 0x00AE31

        Summary ASB Link States (Area 1)

Link ID      ADV Router   Age     Seq#     Checksum
192.168.1.193  192.168.1.129  1894    0x80000001 0x009350

        Type-5 AS External Link States

Link ID      ADV Router   Age     Seq#     Checksum Tag
172.16.0.0   192.168.1.193  1455    0x80000002 0x003B8C 0
192.168.2.0   192.168.1.193  1899    0x80000001 0x001EF4 0


RouterBのルーティング・テーブルを見てみましょう。
やはり,集約経路あての送出先インタフェースがNull0になっている経路情報ができました(下の青字の部分)。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   172.16.0.0/21 is subnetted, 1 subnets
O E2  172.16.0.0 [110/10] via 192.168.1.2, 00:39:22, Serial1
C  192.168.0.0/24 is directly connected, Serial0
   192.168.1.0/24 is variably subnetted, 4 subnets, 3 masks
O    192.168.1.0/24 is a summary, 00:39:22, Null0
C    192.168.1.0/25 is directly connected, Serial1
O    192.168.1.192/26 [110/65] via 192.168.1.2, 00:39:22, Serial1
C    192.168.1.128/26 is directly connected, Loopback0
O E2 192.168.2.0/24 [110/10] via 192.168.1.2, 00:39:22, Serial1


RouterBで経路情報が集約されているかは,showe ip ospfコマンドで確認できます。

RouterB#show ip ospf
Routing Process "ospf 1" with ID 192.168.1.129 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an area border router
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 2. Checksum Sum 0x5881
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
External flood list length 0
  Area BACKBONE(0)
    Number of interfaces in this area is 2
    Area has no authentication
    SPF algorithm executed 7 times
    Area ranges are
      192.168.1.0/24 Active(1) Advertise

    Number of LSA 3. Checksum Sum 0xBB71
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0
  Area 1
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 4 times
    Area ranges are
    Number of LSA 4. Checksum Sum 0x2C392
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


OSPFラボ
OSPFの基本設定
パッシブ・インタフェースの設定
プライオリティの設定と代表ルーターの選出
NBMAネットワーク(ノンブロードキャスト)
NBMAネットワーク(ブロードキャスト)
NBMAネットワーク(ポイントツーマルチポイント)
OSPFコストの設定
エリア設定(標準,スタブ,トータリースタブ)
エリア設定(NSSA,トータリースタブNSSA)
OSPFバーチャルリンク
OSPFの経路集約
ネイバー認証
(ツール)OSPFトポロジ表示フラッシュ