OSPFバーチャルリンク
・バックボーン・エリア(エリア0)に直接接続していないエリアをバーチャルリンクでつなぐ
・バーチャルリンクによって,離れたエリアのABRがエリア0に所属することを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
no fair-queue
clockrate 64000
!
router ospf 1
log-adjacency-changes
area 1 virtual-link 3.3.3.3 ←RouterCあてにバーチャルリンクを設定
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 1
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
area 1 virtual-link 2.2.2.2 ←RouterBあてにバーチャルリンクを設定
network 192.168.2.0 0.0.0.255 area 1
network 192.168.3.0 0.0.0.255 area 4
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterDのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterD
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface Ethernet0
ip address 192.168.3.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.3.0 0.0.0.255 area 4
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
マルチ・エリアOSPFでは,「すべてのエリアがバックボーン・エリア(エリア0)と隣接している必要がある」というお約束があります。
でも,利用できる回線数やエリア分けの都合などで,そうはいかなくなるケースもあります。
そんなときに使うのが,OSPFの「バーチャルリンク」と呼ばれる機能です。

●設定の確認
目標は,バックボーン・エリアと離れているエリア4を,バーチャルリンクを使ってバックボーン・エリアに接続することです。
では,離れた状態のままだとどうなっているでしょうか。
RouterBとRouterCの
area 1 virtual-link 3.3.3.3
area 1 virtual-link 2.2.2.2
というコマンドを入れていない状態を確認しておきます。

RouterDのルーティング・テーブルを見てみます。
自分が所属するエリア4以外の経路情報を学習できていません。

RouterD#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   4.0.0.0/24 is subnetted, 1 subnets
C    4.4.4.0 is directly connected, Loopback0
C  192.168.3.0/24 is directly connected, Ethernet0


RouterAは,エリア4内の経路情報を学習できていません。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   1.0.0.0/24 is subnetted, 1 subnets
C    1.1.1.0 is directly connected, Loopback0
C  192.168.1.0/24 is directly connected, Ethernet0
O IA 192.168.2.0/24 [110/138] via 192.168.1.2, 00:22:54, Ethernet0


RouterBも同様に,エリア4内の経路情報を学習できていません。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   2.0.0.0/24 is subnetted, 1 subnets
C    2.2.2.0 is directly connected, Loopback0
C  192.168.1.0/24 is directly connected, Ethernet0
C  192.168.2.0/24 is directly connected, Serial0


このように,バックボーン・エリアに所属しないエリアは,ほかのエリアと経路情報をやりとりできません。

RouterCのエリアの様子も確認しておきましょう。
エリア1とエリア4が見ていていますね。

RouterC#show ip ospf
Routing Process "ospf 1" with ID 3.3.3.3 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x0
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
External flood list length 0
  Area 1
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 3 times
    Area ranges are
    Number of LSA 3. Checksum Sum 0x1B462
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0
  Area 4
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 3 times
    Area ranges are
    Number of LSA 3. Checksum Sum 0x1D234
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


●動作の確認
では,バーチャルリンク機能を使ってエリア4をエリア0に隣接させましょう。
バーチャルリンクを設定するのは,RouterBとRouterCです。

まずは,RouterBにバーチャルリンクを設定します。
バーチャルリンクを確立する相手ルーター(RouterC)のルーターID(3.3.3.3)を指定します。

RouterB(config)#router ospf 1
RouterB(config-router)#area 1 virtual-link 3.3.3.3


RouterBのみにバーチャルリンクを設定すると,RouterCで以下のようなエラー・メッセージが出ます。

RouterC(config)#
03:16:36: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbo
ne area must be virtual-link but not found from 192.168.2.1, Serial0
03:16:46: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbo
ne area must be virtual-link but not found from 192.168.2.1, Serial0
03:16:56: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbo
ne area must be virtual-link but not found from 192.168.2.1, Serial0


10秒間隔で表示されているので,Helloパケットを受信するごとにエラーが表示されていることがわかります。
内容は,「エリアIDがミスマッチ」とあります。
さらに直訳してみると,「バックボーン・エリアからはバーチャルリンクでなければならない。でも192.168.2.1(RouterB)からは見つからなかった」とあります。
つまり,バーチャルリンクの相手先が見つからないわけですね。
ってことで,RouterCにもバーチャルリンクの相手を設定してやります。

RouterC(config)#router ospf 1
RouterC(config-router)#area 1 virtual-link 2.2.2.2
RouterC(config-router)#
01:25:52: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on OSPF_VL0 from LOADING to FULL, Loading Done


すると,バーチャルリンクのアジャセンシーが確立しました。
バーチャルリンクの設定は以上です。

再びRouterDのルーティング・テーブルを見てみましょう。
今度は,すべての経路情報が見えていますね。

RouterD#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

   4.0.0.0/24 is subnetted, 1 subnets
C    4.4.4.0 is directly connected, Loopback0
O IA 192.168.1.0/24 [110/84] via 192.168.3.1, 00:01:59, Ethernet0
O IA 192.168.2.0/24 [110/74] via 192.168.3.1, 00:02:04, Ethernet0

C  192.168.3.0/24 is directly connected, Ethernet0


バーチャルリンクの様子を見てみましょう。
show ip ospf virtual-linksというコマンドを入力します。

RouterC#show ip ospf virtual-links
Virtual Link OSPF_VL0 to router 2.2.2.2 is up
 Run as demand circuit
 DoNotAge LSA allowed.
 Transit area 1, via interface Serial0, Cost of using 64
 Transmit Delay is 1 sec, State POINT_TO_POINT,
 Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
  Hello due in 00:00:00
  Adjacency State FULL (Hello suppressed)
  Index 1/3, retransmission queue length 0, number of retransmission 0
  First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
  Last retransmission scan length is 0, maximum is 0
  Last retransmission scan time is 0 msec, maximum is 0 msec


「トランジットエリアが1」となっています。
これは,バーチャルリンクがエリア1を経由しているという意味です。
そのほか,バーチャルリンクがポイント・ツー・ポイントのネットワーク・タイプとして扱われており,Helloパケットが抑制(suppressed)されていることもわかります。

RouterCが所属するエリアを確認してみましょう。

RouterC#show ip ospf
Routing Process "ospf 1" with ID 3.3.3.3 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an area border router
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x0
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 3. 3 normal 0 stub 0 nssa
External flood list length 0
  Area BACKBONE(0)
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 2 times
    Area ranges are
    Number of LSA 7. Checksum Sum 0x28B16
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 4
    Flood list length 0

  Area 1
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 5 times
    Area ranges are
    Number of LSA 6. Checksum Sum 0x32A9B
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0
  Area 4
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm executed 5 times
    Area ranges are
    Number of LSA 5. Checksum Sum 0x315EF
    Number of opaque link LSA 0. Checksum Sum 0x0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0


バーチャルリンクを設定することにより,エリア0(バックボーン・エリア)に所属しました。
仮想的にバックボーン・エリアに隣接させたことがわかります。

●参考文献
「%OSPF-4-ERRRCV」エラー メッセージの意味
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/104/19-j.html

OSPFラボ
OSPFの基本設定
パッシブ・インタフェースの設定
プライオリティの設定と代表ルーターの選出
NBMAネットワーク(ノンブロードキャスト)
NBMAネットワーク(ブロードキャスト)
NBMAネットワーク(ポイントツーマルチポイント)
OSPFコストの設定
エリア設定(標準,スタブ,トータリースタブ)
エリア設定(NSSA,トータリースタブNSSA)
OSPFバーチャルリンク
OSPFの経路集約
ネイバー認証
(ツール)OSPFトポロジ表示フラッシュ