IGRPとEIGRPの再配信
・RouterBで,IGRPの経路情報とEIGRPの経路情報を相互に再配信する
・経路情報が再配信されているか確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
!
router igrp 100
network 192.168.0.0
network 192.168.1.0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 192.168.1.254 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.168.2.254 255.255.255.0
clockrate 64000
!
router eigrp 100 ←IGRPとEIGRPは,AS番号が同じなら自動的に相互に再配信される
network 192.168.2.0

auto-summary
no eigrp log-neighbor-changes
!
router igrp 100 ←IGRPとEIGRPは,AS番号が同じなら自動的に相互に再配信される
network 192.168.1.0

!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
no fair-queue
!
router eigrp 100
network 192.168.2.0
network 192.168.3.0
auto-summary
no eigrp log-neighbor-changes
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
IGRPとEIGRPのネットワークにある経路情報を相互に再配信してみましょう。
この二つは,シスコ独自のルーティング・プロトコルです。
そのため気が利いていて,AS番号が同じなら,何もしなくても経路情報を相互に再配信してくれます。
実際に確かめて見ましょう。

●ルーティング・プロトコルを設定する
上のコンフィグの黒字の部分を設定していない状態から見ていきます
ここで上のコンフィグのように,普通に,RouterBにIGRPとEIGRPを設定します。
AS番号は二つとも100とします。

RouterB(config)#router igrp 100
RouterB(config-router)#network 192.168.1.0
RouterB(config-router)#exit
RouterB(config)#router eigrp 100
RouterB(config-router)#network 192.168.2.0


再配信のためのコマンドであるrestributeコマンドは入力していません。

●設定後の各ルーターの経路情報を確認
この状態で,各ルーターのルーティング・テーブルを見てみましょう。
最初にRouterBを見てみると,すべての経路情報が見えています。
RouterBでは,IGRPとEIGRPの両方が動いているわけですから,これは当たり前ですね。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

I  192.168.0.0/24 [100/8976] via 192.168.1.1, 00:00:19, Serial0
C  192.168.1.0/24 is directly connected, Serial0
C  192.168.2.0/24 is directly connected, Serial1
D  192.168.3.0/24 [90/2297856] via 192.168.2.1, 00:00:43, Serial1


次に,RouterAのルーティング・テーブルを見てみます。
RouterAはIGRPのみが動いていますが,EIGRPが動いている192.168.2.0/24と192.168.3.0/24の経路情報が見えています。
この二つの経路情報は「I」となっているので,IGRPで受信した経路情報であることがわかります。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
     E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
     * - candidate default, U - per-user static route, o - ODR
     P - periodic downloaded static route

Gateway of last resort is not set

C  192.168.0.0/24 is directly connected, Loopback0
C  192.168.1.0/24 is directly connected, Serial0
I   192.168.2.0/24 [100/10476] via 192.168.1.254, 00:00:07, Serial0
I   192.168.3.0/24 [100/10976] via 192.168.1.254, 00:00:07, Serial0


最後に,RouterCのルーティング・テーブルを見てみます。
RouterCではEIGRPのみが動いていますが,IGRPが動いている192.168.0.0/24と192.168.1.0/24の経路情報が見えています。
この二つの経路情報は「D EX」となっているので,EIGRPで再配送された経路情報であることがわかります。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
     E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
     * - candidate default, U - per-user static route, o - ODR
     P - periodic downloaded static route

Gateway of last resort is not set

D EX 192.168.0.0/24 [170/2809856] via 192.168.2.254, 00:00:21, Serial0
D EX 192.168.1.0/24 [170/2681856] via 192.168.2.254, 00:00:21, Serial0

C   192.168.2.0/24 is directly connected, Serial0
C   192.168.3.0/24 is directly connected, Loopback0


このように,IGRPとEIGRPは,AS番号が同じなら自動的に相互に再配信されるわけです。

●おまけ IGRPのAS番号を100→200に変更してみる
それでは,IGRPとEIGRPのAS番号が違う場合はどうなるでしょうか。
IGRP側のAS番号を200に変更してみます。

RouterAで動いているIGRPのAS番号を200に変更します。

RouterA(config)#no router igrp 100
RouterA(config)#router igrp 200
RouterA(config-router)#network 192.168.0.0
RouterA(config-router)#network 192.168.1.0


次に,RouterBで動いているIGRPのAS番号を200に変更します。

RouterB(config)#no router igrp 100
RouterB(config)#router igrp 200
RouterB(config-router)#network 192.168.1.0


これで,IGRPのAS番号が200で,EIGRPのAS番号は100という状態になりました。
RouterAのルーティング・テーブルを確認してみましょう。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
     E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
     * - candidate default, U - per-user static route, o - ODR
     P - periodic downloaded static route

Gateway of last resort is not set

C  192.168.0.0/24 is directly connected, Loopback0
C  192.168.1.0/24 is directly connected, Serial0


これまであった192.168.2.0/24と192.168.3.0/24の経路情報(「I」の経路情報)がなくなっています。
これはRouterBで,EIGRPの経路情報をIGRPで再配送しなくなったからですね。

最後に,RouterCの経路情報み見てみましょう。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
     E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
     * - candidate default, U - per-user static route, o - ODR
     P - periodic downloaded static route

Gateway of last resort is not set

C  192.168.2.0/24 is directly connected, Serial0
C  192.168.3.0/24 is directly connected, Loopback0


これまであった192.168.0.0/24と192.168.1.0/24の経路情報(「D EX」の経路情報)がなくなっています。
こちらも,AS番号を変えたことで,IGRPの経路情報がEIGRPで再配送されなくなったことがわかりました。

このとき,特に再配信時のメトリック(シード・メトリック)を指定する必要はありません。
というのも,IGRPとEIGRPで使うメトリックの算出方法は基本的に同じなので,簡単にメトリックを変換できるからです。
具体的には,IGRPのメトリック計算で使う全パラメータ(帯域幅,遅延,負荷,信頼性)を256倍した値をEIGRPのパラメータとして使います。
ただし,IGRPとEIGRPで使うK値は一致している必要があります。

●EIGRPのメトリックの計算方法
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/103/eigrp-toc-j.shtml#eigrpmetrics
●IGRPのメトリックの計算方法
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/103/3-j.html

ちなみに,IGRPとEIGRPの再配信において,異なるAS同士で再配布を実行するには,redistributeコマンドを使います。
これについては,以下のWebページが参考になります。

●2つの異なるASにあるEIGRPとIGRP間での再配布
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/103/eigrp-toc-j.shtml#redisbetweeneigrpandigrp

再配信ラボ
RIPとIGRPの再配信
ルートマップを使った再配信
IGRPとEIGRPの再配信
OSPFとRIPの再配信
OSPFとEIGRPの再配信