OSPFとEIGRPの再配信
・以下のネットワークで,再配信を使って通信できるようにする
・経路情報が再配信されているか確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 172.16.0.1 255.255.255.240
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface Serial0
ip address 172.16.2.1 255.255.255.252
!
router ospf 1
log-adjacency-changes
redistribute connected subnets ←直接接続している経路情報をOSPFで再配信
network 172.16.1.0 0.0.0.255 area 1
network 172.16.2.0 0.0.0.3 area 1
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 172.16.2.2 255.255.255.252
clockrate 64000
!
interface Serial1
ip address 172.16.3.1 255.255.255.252
clockrate 64000
!
router ospf 1
log-adjacency-changes
network 172.16.2.0 0.0.0.3 area 1
network 172.16.3.0 0.0.0.3 area 0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Serial0
ip address 172.16.3.2 255.255.255.252
!
interface Serial1
ip address 172.16.4.1 255.255.255.0
clockrate 64000
!
router eigrp 1
redistribute ospf 1 ←OSPFで受信した経路情報をRIPで再配信
network 172.16.4.0 0.0.0.255
default-metric 56 100 255 1 1500 ←EIGRPで再配信するときのシードメトリックを設定
auto-summary
no eigrp log-neighbor-changes
!
router ospf 1
log-adjacency-changes
redistribute eigrp 1 subnets ←EIGRPで受信した経路情報をOSPFで再配信
network 172.16.3.0 0.0.0.3 area 0
default-metric 64 ←OSPFで再配信するときのシードメトリックを設定
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterDのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterD
!
interface Loopback0
ip address 172.16.5.1 255.255.255.240
!
interface Serial0
ip address 172.16.4.2 255.255.255.0
no fair-queue
!
router eigrp 1
network 172.16.4.0 0.0.0.255
network 172.16.5.0 0.0.0.255
auto-summary
no eigrp log-neighbor-changes
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
OSPFとEIGRPが動作しているネットワークで再配信を活用して,経路情報を正しく伝播させてみます。
ネットワークの構成は,「OSPFとRIPの再配信」のラボ・シナリオと同じです。

●RouterCに再配信を設定
上のコンフィグの,太字の部分を入力していない状態から見ていきます。

OSPFネットワークとRIPネットワークの境界に位置するのはRouterCです。
そのため,RouterCでOSPFとEIGRPを相互に再配信させます。
OSPFネットワークへの再配信ではsubnetsオプションを付けて,EIGRPネットワーク内にあるサブネット情報がOSPFネットワーク内に伝わるようにします(下の青字)。

RouterC(config)#router eigrp 1
RouterC(config-router)#redistribute ospf 1
RouterC(config-router)#default-metric 56 100 255 1 1500
RouterC(config-router)#exit
RouterC(config)#router ospf 1
RouterC(config-router)#redistribute eigrp 1 subnets
RouterC(config-router)#default-metric 64


RouterAのルーティング・テーブルを見てみます。
ネットワーク内にある六つすべての経路情報が登録されています。

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
      * - candidate default, U - per-user static route, o - ODR
      P - periodic downloaded static route

Gateway of last resort is not set

    172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
O E2  172.16.4.0/24 [110/64] via 172.16.2.2, 00:04:27, Serial0
O E2  172.16.5.0/28 [110/64] via 172.16.2.2, 00:04:24, Serial0
C     172.16.0.0/28 is directly connected, Loopback0
C     172.16.1.0/24 is directly connected, Loopback1
C     172.16.2.0/30 is directly connected, Serial0
O IA  172.16.3.0/30 [110/192] via 172.16.2.2, 00:04:33, Serial0


続いて,RouterBのルーティング・テーブルを確認してみます。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
      * - candidate default, U - per-user static route, o - ODR
      P - periodic downloaded static route

Gateway of last resort is not set

    172.16.0.0/16 is variably subnetted, 5 subnets, 4 masks
O E2  172.16.4.0/24 [110/64] via 172.16.3.2, 00:04:04, Serial1
O E2  172.16.5.0/28 [110/64] via 172.16.3.2, 00:04:01, Serial1
O     172.16.1.1/32 [110/65] via 172.16.2.1, 00:04:20, Serial0
C     172.16.2.0/30 is directly connected, Serial0
C     172.16.3.0/30 is directly connected, Serial1


192.168.0.0/28の経路情報が来ていません。
なぜならば,RouterAに直接接続されている経路情報がOSPFネットワークに再配信されていないからです。
直接接続された経路情報をOSPFで再配信するには,redistributeコマンドで「connected」オプションが必要です。
そこで,connectedオプションを使って,RouterAに直接接続されている経路情報を再配信します。

RouterA(config)#router ospf 1
RouterA(config-router)#redistribute connected subnets


RouterDのルーティング・テーブルを見てみましょう。
172.16.0.0/28の経路情報が流れてきました(下の赤字)。

RouterD#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
      * - candidate default, U - per-user static route, o - ODR
      P - periodic downloaded static route

Gateway of last resort is not set

    172.16.0.0/16 is variably subnetted, 6 subnets, 4 masks
C     172.16.4.0/24 is directly connected, Serial0
C     172.16.5.0/28 is directly connected, Loopback0
D EX  172.16.0.0/28 [170/46251776] via 172.16.4.1, 00:00:58, Serial0
D EX  172.16.1.1/32 [170/46251776] via 172.16.4.1, 00:08:55, Serial0
D EX  172.16.2.0/30 [170/46251776] via 172.16.4.1, 00:08:55, Serial0
D EX  172.16.3.0/30 [170/46251776] via 172.16.4.1, 00:08:55, Serial0


もちろん,間にあるRouterBとRouterBにも同じ経路情報が流れています。
これで,すべてのルーターに,全6個のネットワークが登録されました。

●RIPネットワークとEIGRPネットワークの違いは?
上の構成のネットワークでEIGRPがRIPだったときは,この時点で,172.16.0.0/28,172.16.1.0/30,172.16.2.0/30という三つの経路情報が来ていませんでした。
(詳しくは,「OSPFとRIPの再配信」の「●RIPネットワークへの再配信を考える」を参照して下さい。)
なぜ,RIPではこの三つの経路情報が流れて来なくて,EIGRPではこの時点ですべての経路情報が流れて来たのでしょうか?
その理由は,RIPが「クラスフル」のルーティング・プロトコルで,EIGRPが「クラスレス」のルーティング・プロトコルだからです。
EIGRPはクラスレスのルーティング・プロトコルなので,/28や/30といったサブネット・マスクも扱えます。
そのため,RouterCに特別な設定をしなくても,EIGRPネットワークにサブネット情報が流れたわけです。

再配信ラボ
RIPとIGRPの再配信
ルートマップを使った再配信
IGRPとEIGRPの再配信
OSPFとRIPの再配信
OSPFとEIGRPの再配信