ルートマップを使った再配信
・RouterBで,RIPの経路情報をIGRPで再配信する
・ルートマップを使い,サブネットごとにメトリックを変えて再配信する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
!
interface Serial1
no ip address
shutdown
!
router rip
network 192.168.0.0
network 192.168.1.0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Serial0
ip address 192.168.1.254 255.255.255.0
clockrate 64000
!
interface Serial1
ip address 192.168.2.254 255.255.255.0
clockrate 64000
!
router rip
network 192.168.1.0
!
router igrp 100
redistribute rip route-map rip_to_igrp ←RIPの経路情報をIGRP(AS100)で再配信
network 192.168.2.0
!
access-list 1 permit 192.168.0.0 ←アクセスリスト1
route-map rip_to_igrp permit 10 ←ルートマップ10行目
match ip address 1           ←再配信する経路情報がアクセスリスト1(192.168.0.0)に該当したら
set metric 56 100 255 1 1500    ←このメトリックを適用して配信

!
route-map rip_to_igrp permit 20 ←ルートマップ20行目
set metric 10000 100 255 1 1500 ←それ以外だったらこのメトリックを適用して配信

!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router igrp 100
network 192.168.2.0
network 192.168.3.0
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
再配信のときに,配信する経路情報の条件を指定することもできます。
例えば,「この経路情報を再配信するときはメトリックを〜にする」といった操作ができます。
このとき,「ルートマップ」と呼ばれる方法を使います。

●ルートマップを使った再配信
ルートマップを使った再配信は,再配信のコマンドであるredistributeコマンドのオプションで指定します。
例えば,以下がルートマップを使って,RIPの経路情報をIGRP(AS100)で再配信する際のコマンドです。

RouterB(config)#router igrp 100
RouterB(config-router)#redistribute rip route-map ルートマップ名


ここで指定した「ルートマップ名」のルートマップを作ることになります。

●ルートマップ設定前
それでは,ルートマップ設定前の状態から見ていきます。
上のRouterBのコンフィグで,太字で記したコマンドを入力していない状態です。
RouterAではRIPが,RouterCではIGRPが動いています。
RouterBのSerial0ではRIPが,Serial1ではIGRPが動いています。

この状態で,RouterBのルーティング・テーブルを見てみます。
192.168.0.0/24,192.168.1.0/24,192.168.2.0/24,192.168.3.0/24の四つすべての経路情報が見えています。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

R  192.168.0.0/24 [120/1] via 192.168.1.1, 00:00:18, Serial0
C  192.168.1.0/24 is directly connected, Serial0
C  192.168.2.0/24 is directly connected, Serial1
I   192.168.3.0/24 [100/8976] via 192.168.2.1, 00:00:04, Serial1


次に,RouterCのルーティング・テーブルを見てみます。
192.168.0.0/24と192.168.1.0/24の経路情報しか登録されていません。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

C  192.168.2.0/24 is directly connected, Serial0
C  192.168.3.0/24 is directly connected, Loopback0


なぜならば,RouterBでは,RIP側の経路情報をIGRPで再配信していません。
なので,RIP側の経路情報(192.168.0.0/24と192.168.1.0/24)は,RouterCに送信されていないのです。

●ルートマップを作る
RouterBに再配信させる際に,以下のような条件を付けてみましょう
 ・192.168.0.0のメトリックは「56 100 255 1 1500」にして再配信
 ・それ以外の経路情報のメトリックは「10000 100 255 1 1500」にして再配信
 (メトリック情報は左から,帯域幅(kbps),遅延(10マイクロ秒),信頼性(255で100%信頼できる),負荷(255で帯域が100%埋まっている),MTUサイズ(バイト))

以上の条件を実行するルートマップを作りましょう。
まず,192.168.0.0という経路情報をアクセスリスト1番として設定しておきます。

RouterB(config)#access-list 1 permit 192.168.0.0

以下が,ルートマップの作成です。
ルートマップ名は「rip_to_igrp」とします。
上の条件をルートマップで書くと,以下のようになります。

RouterB(config)#route-map rip_to_igrp 10
RouterB(config-route-map)#match ip address 1
RouterB(config-route-map)#set metric 56 100 255 1 1500
RouterB(config-route-map)#exit
RouterB(config)#route-map rip_to_igrp 20
RouterB(config-route-map)#set metric 10000 100 255 1 1500


あとは,ここで作ったルートマップを再配信の実行時に指定してやればOKです。

RouterB(config)#router igrp 100
RouterB(config-router)#redistribute rip route-map rip_to_igrp


●設定を確認する
RouterCのルーティング・テーブルを見てみましょう。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

I   192.168.0.0/24 [100/180671] via 192.168.2.254, 00:00:01, Serial0
I   192.168.1.0/24 [100/8576] via 192.168.2.254, 00:00:01, Serial0
C  192.168.2.0/24 is directly connected, Serial0
C  192.168.3.0/24 is directly connected, Loopback0


IGRPで経路情報が二つ登録されました。
二つとも,RouterB(192.168.2.254)がIGRPで再配信した経路情報です。
見ると,192.168.0.0/24のメトリックが「180671」,192.168.1.0/24のメトリックが「8576」になっています。
なぜこのような値になったのか確認してみましょう。

IGRPのメトリックは,デフォルトで以下のようになります。

メトリック=帯域幅+遅延
 ・帯域幅=10000000/経路上の最小の帯域幅(kbps)
 ・遅延=各リンクの遅延の合計(μsec)/10


192.168.0.0の経路情報のメトリックを考えてみます。
 ・帯域幅=10000000/56(再配信で指定した帯域幅:kbps)=178571
 ・遅延=100(再配信で指定した遅延:10μsec)+2000(Serial1の遅延:10μsec)=2100
よってメトリックは,178571+2100=180671

192.168.1.0の経路情報のメトリックも計算してみます。
 ・帯域幅=10000000/1544(Serial1の帯域幅:kbps)=6476
 ・遅延=100(再配信で指定した遅延:10μsec)+2000(Serial1の遅延:10μsec)=2100
よってメトリックは,6476+2100=8576

いずれも,計算と一致していますね。
ちなみに,RouterBの帯域や遅延は,show interfaceの表示でわかります。

RouterB#show interfaces serial 1
Serial1 is up, line protocol is up
 Hardware is HD64570
 Internet address is 192.168.2.254/24
 MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
   reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation HDLC, loopback not set
 Keepalive set (10 sec)
 Last input 00:00:09, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: weighted fair
 Output queue: 0/1000/64/0 (size/max total/threshold/drops)
   Conversations 0/1/256 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 1158 kilobits/sec
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
   1040 packets input, 60816 bytes, 0 no buffer
   Received 1040 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   971 packets output, 58348 bytes, 0 underruns
   0 output errors, 0 collisions, 3 interface resets
   0 output buffer failures, 0 output buffers swapped out
   4 carrier transitions
   DCD=up DSR=up DTR=up RTS=up CTS=up


また,ルートマップの内容は,show route-mapで表示されます。

RouterB#show route-map
route-map rip_to_igrp, permit, sequence 10
 Match clauses:
  ip address (access-lists): 1
 Set clauses:
  metric 178571 100 255 1 1500
 Policy routing matches: 0 packets, 0 bytes

route-map rip_to_igrp, permit, sequence 20
 Match clauses:
 Set clauses:
  metric 1000 100 255 1 1500
 Policy routing matches: 0 packets, 0 bytes


青い部分がルートマップの10行目,緑色の部分がルートマップの20行目です。
「178571」というのは,ルートマップ10行目で指定した,帯域幅のメトリック(10000000を56で割った値)です。
同様に「1000」は,ルートマップ20行目で指定した,帯域幅のメトリック(10000000を1000で割った値)です。
ルートマップで設定した内容が表示されていることが確認できました。

再配信ラボ
RIPとIGRPの再配信
ルートマップを使った再配信
IGRPとEIGRPの再配信
OSPFとRIPの再配信
OSPFとEIGRPの再配信