RIPの基本設定
・RIPで配信する経路情報を確認する
・スプリット・ホライズンの機能を確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip ←RIPの設定モードに入る
network 10.0.0.0 ←10.x.x.xのインタフェースでRIPを動かす
network 172.16.0.0 ←172.16.x.xのインタフェースでRIPを動かす
network 192.168.1.0 ←192.168.1.xのインタフェースでRIPを動かす

!
ip http server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
clockrate 500000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 500000
!
router rip ←RIPの設定モードに入る
network 192.168.1.0 ←192.168.1.xのインタフェースでRIPを動かす
network 192.168.2.0 ←192.168.2.xのインタフェースでRIPを動かす

!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Ethernet0
ip address 172.17.1.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip ←RIPの設定モードに入る
network 172.17.0.0 ←172.16.x.xのインタフェースでRIPを動かす
network 192.168.2.0
 ←192.168.2.xのインタフェースでRIPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
確認
以上の設定で,3台のルーターでRIPが動作しています。
RouterAの経路情報を見てみましょう。

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R 172.17.0.0/16 [120/2] via 192.168.1.2, 00:00:10, Serial0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Serial0
R 192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:10, Serial0


確かに,RouterBからRIPで172.17.0.0/16と192.168.2.0/24という二つの経路情報を受信していますね。
サブネット・マスクが/16と/24になっているのは,RIP(バージョン1)ではサブネット・マスク情報を運べないために,IPアドレスのクラスでサブネット・マスクを判断しているからなんですね。
(この機能は「自動集約」なんて呼ばれてたりするけど,結局はクラスフルの大雑把なやりかた)。

次に,RIPアップデートで通知している経路情報を見てみましょう。

RouterA#debug ip rip
RIP protocol debugging is on
*Mar 1 04:00:22.767: RIP: sending v1 update to 255.255.255.255 via Ethernet0 (172.16.1.1)
*Mar 1 04:00:22.771: RIP: build update entries
*Mar 1 04:00:22.771: network 10.0.0.0 metric 1
*Mar 1 04:00:22.775: network 172.17.0.0 metric 3
*Mar 1 04:00:22.779: network 192.168.1.0 metric 1
*Mar 1 04:00:22.783: network 192.168.2.0 metric 2
*Mar 1 04:00:37.351: RIP: sending v1 update to 255.255.255.255 via Serial0 (192.168.1.1)
*Mar 1 04:00:37.355: RIP: build update entries
*Mar 1 04:00:37.355: network 10.0.0.0 metric 1
*Mar 1 04:00:37.359: network 172.16.0.0 metric 1
*Mar 1 04:00:38.787: RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.1.1)
*Mar 1 04:00:38.791: RIP: build update entries
*Mar 1 04:00:38.795: network 172.16.0.0 metric 1
*Mar 1 04:00:38.795: network 172.17.0.0 metric 3
*Mar 1 04:00:38.799: network 192.168.1.0 metric 1
*Mar 1 04:00:38.803: network 192.168.2.0 metric 2


Serial0からは二つの経路情報が通知されていますね(赤字の部分)。
ここで,スプリット・ホライズンをオフにしてみます。

RouterA(config)#interface Serial 0
RouterA(config-if)#no ip split-horizon


すると,RouterAのRIPアップデートの内容はどうなるでしょう。

RouterA#debug ip rip
RIP protocol debugging is on
*Mar 1 04:08:05.214: RIP: sending v1 update to 255.255.255.255 via Serial0 (192.168.1.1)
*Mar 1 04:08:05.218: RIP: build update entries
*Mar 1 04:08:05.218: network 10.0.0.0 metric 1
*Mar 1 04:08:05.222: network 172.16.0.0 metric 1
*Mar 1 04:08:05.226: network 172.17.0.0 metric 3
*Mar 1 04:08:05.230: network 192.168.1.0 metric 1
*Mar 1 04:08:05.230: network 192.168.2.0 metric 2

*Mar 1 04:08:08.114: RIP: sending v1 update to 255.255.255.255 via Ethernet0 (172.16.1.1)
*Mar 1 04:08:08.118: RIP: build update entries
*Mar 1 04:08:08.118: network 10.0.0.0 metric 1
*Mar 1 04:08:08.122: network 172.17.0.0 metric 3
*Mar 1 04:08:08.126: network 192.168.1.0 metric 1
*Mar 1 04:08:08.130: network 192.168.2.0 metric 2
*Mar 1 04:08:09.510: RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.1.1)
*Mar 1 04:08:09.514: RIP: build update entries
*Mar 1 04:08:09.518: network 172.16.0.0 metric 1
*Mar 1 04:08:09.518: network 172.17.0.0 metric 3
*Mar 1 04:08:09.522: network 192.168.1.0 metric 1
*Mar 1 04:08:09.526: network 192.168.2.0 metric 2


今度はSerial0から五つの経路情報を通知しました(赤字の部分)。
増えた三つの経路情報は,RouterBが通知した経路情報です(192.168.1.0,192.168.2.0,172.17.0.0)。
スプリット・ホライズンで,RouterBからもらった経路情報は,RouterBへ返さなくなっていたことがわかりました。

RIPラボ
RIPの基本設定
パッシブ・インタフェースの設定
タイマーの設定
ユニキャスト・アップデートの設定
不連続サブネットの回避