RIPのパッシブ・インタフェース
・RIPでパッシブ・インタフェースを設定する
・パッシブ・インタフェース設定時に,通知している経路情報を確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip ←RIPの設定モードに入る
passive-interface Serial0 ←Serial0をパッシブ・インタフェースにする
network 10.0.0.0 ←10.x.x.xのインタフェースでRIPを動かす
network 172.16.0.0 ←172.16.x.xのインタフェースでRIPを動かす
network 192.168.1.0 ←192.168.1.xのインタフェースでRIPを動かす

!
ip http server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
clockrate 500000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 500000
!
router rip ←RIPの設定モードに入る
network 192.168.1.0 ←192.168.1.xのインタフェースでRIPを動かす
network 192.168.2.0 ←192.168.2.xのインタフェースでRIPを動かす

!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Ethernet0
ip address 172.17.1.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip ←RIPの設定モードに入る
network 172.17.0.0 ←172.16.x.xのインタフェースでRIPを動かす
network 192.168.2.0
 ←192.168.2.xのインタフェースでRIPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
確認
パッシブ・インタフェースは,「RIPアップデートは受信するけど送信しない」という機能です。
インタフェースでRIPはオンにしたいけど,RIPアップデートを30秒ごとに送りつづける(RIPのデフォルト)のは,帯域の無駄だから止めたい!ってときに使います。

以上の設定では,RouterAにpassive-interface Serial0を設定しました。
debug ip ripコマンドを使って,RouterAがどのような経路情報を送信しているのかを見てみましょう。

RouterA#debug ip rip
RIP protocol debugging is on
RouterA#
*Mar 1 01:05:03.271: RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.1.1)
*Mar 1 01:05:03.275: RIP: build update entries
*Mar 1 01:05:03.275: network 172.16.0.0 metric 1
*Mar 1 01:05:03.279: network 172.17.0.0 metric 3
*Mar 1 01:05:03.283: network 192.168.1.0 metric 1
*Mar 1 01:05:03.287: network 192.168.2.0 metric 2
*Mar 1 01:05:06.799: RIP: sending v1 update to 255.255.255.255 via Ethernet0 (172.16.1.1)
*Mar 1 01:05:06.803: RIP: build update entries
*Mar 1 01:05:06.807: network 10.0.0.0 metric 1
*Mar 1 01:05:06.811: network 172.17.0.0 metric 3
*Mar 1 01:05:06.811: network 192.168.1.0 metric 1
*Mar 1 01:05:06.815: network 192.168.2.0 metric 2


Loopback0とEthernet0に経路情報を送信しているけど,Serial0からは出していませんね。
ということは,RouterCに経路情報は届いていないはず。
RouterCの経路情報を見てみましょう。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets
C 172.17.1.0 is directly connected, Ethernet0
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:11, Serial0
C 192.168.2.0/24 is directly connected, Serial0


RouterAにつながる二つの経路情報(172.16.0.0/16と10.0.0.0/8)がありません。
172.16.0.0/16と10.0.0.0/8は,RouterAにつながる経路情報です。
RouterAがパッシブ・インタフェースで隣のルーターに経路情報を通知しなくなったので,RouterAにつながる経路情報がRouterCに通知されなくなったんですね。

パッシブ・インタフェース設定前のRouterCのルーティング・テーブルを見てみたくなりました(爆)。
それは以下。

RouterC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets
C 172.17.1.0 is directly connected, Ethernet0
R 172.16.0.0/16 [120/2] via 192.168.2.1, 00:00:17, Serial0
R 10.0.0.0/8 [120/2] via 192.168.2.1, 00:00:17, Serial0

R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:17, Serial0
C 192.168.2.0/24 is directly connected, Serial0


パッシブ・インタフェース設定によって,RouterAが赤字の部分の経路情報の通知を止めたわけですね。

RIPラボ
RIPの基本設定
パッシブ・インタフェースの設定
タイマーの設定
ユニキャスト・アップデートの設定
不連続サブネットの回避