RIPタイマーの設定
・RIPの各種タイマー(Update,Invalid,Holddown,Flush)を変更する
・RIPで経路情報を削除するときの動作を確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip ←RIPの設定モードに入る
timers basic 5 15 15 30 ←タイマーをUpdate:5秒,Invalid:15秒,Holddown:15秒,Flash:30秒に変更
network 10.0.0.0 ←10.x.x.xのインタフェースでRIPを動かす
network 172.16.0.0 ←172.16.x.xのインタフェースでRIPを動かす
network 192.168.1.0 ←172.168.1.xのインタフェースでRIPを動かす

!
ip http server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
clockrate 500000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 500000
!
router rip ←RIPの設定モードに入る
timers basic 5 15 15 30 ←タイマーをUpdate:5秒,Invalid:15秒,Holddown:15秒,Flash:30秒に変更
network 192.168.1.0 ←192.168.1.xのインタフェースでRIPを動かす
network 192.168.2.0 ←192.168.2.xのインタフェースでRIPを動かす

!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
interface Ethernet0
ip address 172.17.1.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router rip ←RIPの設定モードに入る
timers basic 5 15 15 30 ←タイマーをUpdate:5秒,Invalid:15秒,Holddown:15秒,Flash:30秒に変更
network 172.17.0.0 ←172.16.x.xのインタフェースでRIPを動かす
network 192.168.2.0
 ←192.168.2.xのインタフェースでRIPを動かす
!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
確認
RIPの動作は,Update,Invalid,Holddown,Flushという四つのタイマーが決めています。
それぞれは以下で,単位はすべて「秒」です。

Update…経路情報(RIPアップデート)を通知する間隔
Invalid…RIPアップデートが来なくなったときに,その経路情報を無効と判断するまでの時間
Holddown…無効と判断した経路情報を保持する時間
Flush…RIPアップデートが来なくなったときに,その経路情報をルーティング・テーブルから削除するまでの時間

タイマーのデフォルトは,Updateが30秒,Invalidが180秒,Holddownが180秒,Flashが240秒です。
これだと,無効になった経路情報がルーティング・テーブルから削除されるのに,最大で4分(240秒)もかかってしまいます。
そこで上の設定では,Updateを5秒,Invalidを15秒,Holddownを15秒,Flashを30秒に変更しています。
そのコマンドが,timers basic 5 15 15 30です。
タイマーの設定変更が反映されたか見てみましょう。

RouterA#show ip protocols
Routing Protocol is "rip"
Sending updates every 5 seconds, next due in 2 seconds
Invalid after 15 seconds, hold down 15, flushed after 30
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
Ethernet0 1 1 2
Loopback0 1 1 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
172.16.0.0
192.168.1.0
Passive Interface(s):
Serial0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 120 00:00:04
Distance: (default is 120)


タイマーの表示は,RouterA,RouterB,RouterCとも同じ結果が出るはずです。
さらに確かめるべく,RIPアップデートの送出時間をdebug ip ripで見てみましょう(RouterB)。
その前に,

RouterB(config)#service timestamps

と入れておくと,debug表示でタイムスタンプ(時間)が表示されます。
それでは,デバック開始!

RouterB#debug ip rip
RIP protocol debugging is on
RouterB#
07:13:18: RIP: sending v1 update to 255.255.255.255 via Serial0 (192.168.1.2)
07:13:18: RIP: build update entries
07:13:18: network 172.17.0.0 metric 2
07:13:18: network 192.168.2.0 metric 1
07:13:18: RIP: sending v1 update to 255.255.255.255 via Serial1 (192.168.2.1)
07:13:18: RIP: build update entries
07:13:18: network 10.0.0.0 metric 2
07:13:18: network 172.16.0.0 metric 2
07:13:18: network 192.168.1.0 metric 1
07:13:19: RIP: received v1 update from 192.168.1.1 on Serial0
07:13:19: 10.0.0.0 in 1 hops
07:13:19: 172.16.0.0 in 1 hops
07:13:23: RIP: received v1 update from 192.168.2.2 on Serial1
07:13:23: 172.17.0.0 in 1 hops
07:13:23: RIP: sending v1 update to 255.255.255.255 via Serial0 (192.168.1.2)
07:13:18: RIP: build update entries
07:13:23: network 172.17.0.0 metric 2
07:13:23: network 192.168.2.0 metric 1


Serial0から出したRIPアップデートに注目してみます(赤字の部分)。
07:13:18にRIPアップデートを出して,次に07:13:23に出しています。
RIPアップデートが5秒間隔(Updateタイマーの時間)で出ているのがわかります。

ここで,RouterCのSerial0から出ているRIPアップデートの送出を止めてみます。

RouterC(config)#router rip
RouterC(config-router)#passive-interface Serial 0


止めました!
1,2,3…と数えて15秒経ちました。
ここでRouterBのルーティング・テーブルを見てみましょう。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set


R 172.17.0.0/16 is possibly down, routing via 192.168.2.2, Serial1
R 172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:04, Serial0
R 10.0.0.0/8 [120/1] via 192.168.1.1, 00:00:04, Serial0
C 192.168.1.0/24 is directly connected, Serial0
C 192.168.2.0/24 is directly connected, Serial1

172.17.0.0/16は,possibly down(たぶんダウンしている)と表示されました。
ずいぶん自信なさげです(笑)。
というのも,172.17.0.0/16の送出インタフェースであるSerial1自体はupしているのですが,RIPアップデートが15秒間(Invalidタイマーの時間)来なかったので,「もしかしたらダウン?」と思っているのです。
このpossibly downの状態は,15秒間(Holddownタイマーの時間)続きます。
迷ってる証拠に,この15秒間はとりあえず172.16.0.0/16の経路情報をルーティング・テーブルに残しておきます。
この間,172.16.0.0/16あてのパケットはきちんとルーティングされます。

さらに15秒後に,ルーティング・テーブルを見てみましょう。

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:00, Serial0
R 10.0.0.0/8 [120/1] via 192.168.1.1, 00:00:00, Serial0
C 192.168.1.0/24 is directly connected, Serial0
C 192.168.2.0/24 is directly connected, Serial1


172.17.0.0/16の経路情報が削除されました。
172.16.0.0/16のRIPアップデートが来なくなってから30秒(Flushタイマーの時間)経ったので,ルーティング・テーブルから経路情報を削除したんですね。

別の実験をしてみましょう。
今度は,RouterBとRouterCがつながるケーブルをいきなり抜いてみます。
その前に,先ほどのpassive-interfaceの設定を元に戻します。

RouterC(config-router)#no passive-interface Serial 0

RIPアップデートが正常に送出されたことを確認して,ケーブルを抜きますっ!

08:14:16: %LINK-3-UPDOWN: Interface Serial1, changed state to down
08:14:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down

RouterB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:03, Serial0
R 10.0.0.0/8 [120/1] via 192.168.1.1, 00:00:03, Serial0
C 192.168.1.0/24 is directly connected, Serial0


リンク・ダウンのメッセージが出た直後に,ルーティング・テーブルを表示させたのが,上の表示です。
先ほどと違って,すぐにルーティング・テーブルから172.16.0.0/16の経路情報が削除されました。
リンクがダウンしたんだから迷うことなくダウンと判断して,すぐに経路情報を削除したんですね。

RIPラボ
RIPの基本設定
パッシブ・インタフェースの設定
タイマーの設定
ユニキャスト・アップデートの設定
不連続サブネットの回避