RIPのユニキャスト・アップデート
・ユニキャストを使ってRIPアップデートを送信する
・RIPアップデートがユニキャストで出ていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
RouterAのコンフィグ
!
version 12.3
service timestamps debug uptime
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
!
router rip ←RIPの設定モードに入る
network 192.168.1.0 ←192.168.1.xのインタフェースでRIPをオンにする

!
ip http server
ip classless
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
RouterBのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.2 255.255.255.0
!
!
router rip ←RIPの設定モードに入る
network 2.0.0.0 ←2.x.x.xのインタフェースでRIPをオンにする
network 192.168.1.0
 ←192.168.1.xのインタフェースでRIPをオンにする
!
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
RouterCのコンフィグ
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
!
interface Ethernet0
ip address 192.168.1.3 255.255.255.0
!
!
router rip ←RIPの設定モードに入る
network 192.168.1.0
 ←192.168.1.xのインタフェースでRIPをオンにする
!
ip kerberos source-interface any
ip classless
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
確認
RIPバージョン1のデフォルトでは,RIPアップデートはブロードキャスト(あて先アドレスは255.255.255.255)で送信します。
「すべてのコンピュータあてに送っておけば,ルーターも受信するだろう」という考えですね。

RouterBが送信しているRIPアップデートを見てみましょう。

RouterB#debug ip rip
RIP protocol debugging is on
RouterB#
00:30:28: RIP: sending v1 update to 255.255.255.255 via Loopback0 (2.2.2.2)
00:30:28: RIP: build update entries
00:30:28: network 192.168.1.0 metric 1
00:30:45: RIP: sending v1 update to 255.255.255.255 via Ethernet0 (192.168.1.2)
00:30:45: RIP: build update entries
00:30:45: network 2.0.0.0 metric 1


Loopback0とEthernet0にブロードキャストでRIPアップデートを送信しています。
ところがこのブロードキャスト,場合によっては問題になります。
RIPでは30秒に1回ブロードキャストが出るわけで,ルーターの多いセグメントはブロードキャストだらけになってしまうからです。
そんなときに使うのが,ユニキャスト・アップデートです。
その名の通り,ブロードキャストではなく,ユニキャストでRIPアップデートを送信します。

冒頭のネットワーク図にあるように,RouterBが192.168.1.1(RouterA)だけにユニキャストでRIPアップデートを送信するようにしてみましょう。
passive-interfaceコマンドとneighborコマンドを組み合わせると,それができます。

RouterB(config)#router rip
RouterB(config-router)#passive-interface Ethernet 0
RouterB(config-router)#neighbor 192.168.1.1


passive-interface Ethernet 0で,RIPアップデートの送信を止めています。
この状態では,まったくRIPアップデートが出ません。
次のneighbor 192.168.1.1が,ユニキャスト・アップデートのコマンドで,RIPアップデートのあて先を192.168.1.1(RouterA)に指定します。
こうすれば,RouterAは,192.168.1.1(RouterA)だけにRIPアップデートを送信するようになります。

RouterBが送信しているRIPアップデートはどのように変わったかを見てみましょう。

RouterB#debug ip rip
RIP protocol debugging is on
RouterB#
01:51:10: RIP: sending v1 update to 255.255.255.255 via Loopback0 (2.2.2.2)
01:51:10: RIP: build update entries
01:51:10: network 192.168.1.0 metric 1
01:51:10: RIP: sending v1 update to 192.168.1.1 via Ethernet0 (192.168.1.2)
01:51:10: RIP: build update entries
01:51:10: network 2.0.0.0 metric 1


Ethernet0へ出すRIPアップデートのあて先が,192.168.1.1になっています。
ブロードキャストではなく,ユニキャストで送信していることが,これで確認できました。
これで,同一セグメント上の他のコンピュータに迷惑をかけません。

ちなみに,RIPバージョン2では,224.0.0.9というマルチキャストあてに送信します。
これも,RIP2が動いているルーターだけをあて先とするアドレスなので,それ以外のコンピュータはパケットを受け取っても無視します。

RIPラボ
RIPの基本設定
パッシブ・インタフェースの設定
タイマーの設定
ユニキャスト・アップデートの設定
不連続サブネットの回避