PortFastの設定
・SwitchCのインタフェースにPortFastを設定する
・PortFastを有効にしたインタフェースにケーブルをつなぐと,すぐにフォワーディングになることを確認する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
spanning-tree vlan 1 priority 0  ←プライオリティを0に設定して,このスイッチをルート・ブリッジにする
!
interface FastEthernet0/1
no ip address
!
interface FastEthernet0/3
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
SwitchBのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchB
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
SwitchCのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchC
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/2
switchport mode access
no ip address
!
interface FastEthernet0/3
switchport mode access
no ip address
!
interface FastEthernet0/24
switchport mode access
no ip address
spanning-tree portfast ←このポートにPortFastを設定する
!
interface Vlan1
no ip address
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
確認
PortFastは,ユーザーを収容するアクセス・スイッチが使う機能です。
ユーザーがつながるポートを瞬時にフォワーディングにします。

●通常のスパニング・ツリーの動作を確認
ネットワークの構成は,逆三角形の構成です。
SwitchCがユーザーを収容するアクセス・スイッチで,SwitchAとSwitchBが上位のディストリビューション・スイッチというイメージです。
PortFastは,アクセス・スイッチであるSwitchCで使う機能です。
(なので,PortFastの動作を検証するだけなら,SwitchAとSwitchBはなくてもOKです。)

通常では,スパニング・ツリーを有効にしたスイッチにユーザーのパソコンをつなぐと,スパニング・ツリーのタイマーに則って,リスニング(15秒)とフォワーディング(15秒)を経てフォワーディングになります。
しかし,パソコンだけがつながるポートでは,これだけの時間待つ意味がありません。
それどころか,DHCPでIPアドレスが取れないなどの不都合が生じます。
そこで,「このポートは配下にスイッチがない」とスイッチに明示的に設定して,ケーブルがつながった瞬間にそのポートをフォワーディングにします。
これが,PortFastの機能です。

まず始めに,PortFastを設定していない,通常のスパニング・ツリーの動作を確認しましょう。
動作を見るために,SwitchCのデバッグ機能をオンにします。

SwitchC#debug spanning-tree events
Spanning Tree event debugging is on


ここで,SwitchCのFa0/24にパソコンをつなぎます。

00:12:02: set portid: VLAN0001 Fa0/24: new port id 8018
00:12:02: STP: VLAN0001 Fa0/24 -> listening
00:12:04: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up
00:12:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
00:12:17: STP: VLAN0001 Fa0/24 -> learning
00:12:32: STP: VLAN0001 sent Topology Change Notice on Fa0/3
00:12:32: STP: VLAN0001 Fa0/24 -> forwarding


Fa0/24が,リスニングとラーニングを経てフォワーディングになっているのがわかります。
時間に注目すると,フォワーディングになるまでに30秒かかっています。
ケーブルをつないでも,30秒間は通信できないわけです。

show spanning-treeコマンドでSwitchCの状態を見ると,以下のようになっています。

SwitchC#show spanning-tree

VLAN0001
 Spanning tree enabled protocol ieee
 Root ID  Priority  1
        Address   000a.8a7e.ebc0
        Cost    19
        Port    3 (FastEthernet0/3)
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority  32769 (priority 32768 sys-id-ext 1)
        Address   000e.d7f6.9180
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec
        Aging Time 15

Interface       Role Sts  Cost      Prio.Nbr  Type
---------------- ---- --- --------- -------- ----------------
Fa0/2         Altn BLK  19       128.2   P2p
Fa0/3         Root FWD  19       128.3   P2p
Fa0/24         Desg FWD  19       128.24   P2p


●PortFastを設定する
では,SwitchCにPortFastを設定してみます。
PortFastを有効にするインタフェースの設定モードに入って,spanning-tree portfastコマンドを入力します。

SwitchC(config)#interface fastEthernet 0/24
SwitchC(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION

%Portfast has been configured on FastEthernet0/24 but will only
have effect when the interface is in a non-trunking mode.


警告メッセージが表示されました。
内容は,「PortFastは,1台のホストがつながるポートで使うべき。ハブや他のスイッチが配下につながっていると,ループを起こす可能性がある」というものです。
このメッセージ通りPortFastは,ポートの配下でループが発生しないと保証されているポート,つまりパソコンがつながるポートで使う機能というわけです。

●PortFast設定時の動作を確認
PortFastをFa0/24に設定した状態で,Fa0/24にパソコンをつないでみます。

00:15:17: set portid: VLAN0001 Fa0/24: new port id 8018
00:15:17: STP: VLAN0001 Fa0/24 ->jump to forwarding from blocking
00:15:19: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up
00:15:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up


「ブロッキングからフォワーディングにジャンプした」というメッセージが出ました(上の赤字部分)。
その3秒後にインタフェースがアップしています。
つまり,通常ならばフォワーディングに30秒かかるところが,3秒になったわけです。

SwitchCの状態を再び確認してみます。

SwitchC#show spanning-tree

VLAN0001
 Spanning tree enabled protocol ieee
 Root ID  Priority  1
        Address   000a.8a7e.ebc0
        Cost    19
        Port    3 (FastEthernet0/3)
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority  32769 (priority 32768 sys-id-ext 1)
        Address   000e.d7f6.9180
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec
        Aging Time 300

Interface       Role Sts  Cost     Prio.Nbr  Type
---------------- ---- --- --------- -------- ---------------
Fa0/2         Altn BLK   19      128.2   P2p
Fa0/3         Root FWD  19       128.3   P2p
Fa0/24         Desg FWD  19      128.24   Edge P2p


PortFastを設定したFa0/24の「Type」に「Edge」と表示されました。
これは,Fa0/24の配下にスイッチがない「エッジ・ポート」であることを示しています。
これで,PortFastが目的のポートに正しく設定されていることが確認できました。


スパニングツリー・ラボ
STPの基本動作
ルート・ブリッジの設定
パス・コストの設定
PortFast
UplinkFast
BackboneFast
PVST
RSTP
MSTP