UplinkFastの設定
・SwitchCにUplinkFastを設定する
・SwitchAとSwitchC間のケーブルを抜いて,経路が瞬時に切り替わることを確認する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
spanning-tree vlan 1 priority 0 ←プライオリティを0に設定して,このスイッチをルート・ブリッジにする
!
!
interface FastEthernet0/1
no ip address
!
interface FastEthernet0/3
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
SwitchBのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchB
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
SwitchCのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchC
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree uplinkfast ←このスイッチでUplinkFastを有効にする
!
interface FastEthernet0/2
switchport mode access
no ip address
!
interface FastEthernet0/3
switchport mode access
no ip address
!
interface Vlan1
no ip address
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
確認
UplinkFastは,ユーザーを収容するアクセス・スイッチが使う機能です。
ユーザーがいる側ではなく,上位(アップリンク)側の切り替え動作を速くします。

●通常のスパニング・ツリーの動作を確認
ネットワークの構成は,逆三角形の構成です。
上位のSwitchAとSwitchBがバックボーンにつながるスイッチ(ディストリビューション・スイッチ)で,下位のSwitchCがユーザーを収容するスイッチ(アクセス・スイッチ)というイメージです。
まず始めに,UplinkFastを設定していない通常のスパニング・ツリーの動作を確認しましょう。

SwitchCの状態をshow spanning-treeコマンドで見てみます。
すると,Fa0/2のポートがブロッキングになっているのがわかります(赤字の部分)。

SwitchC#show spanning-tree

VLAN0001
 Spanning tree enabled protocol ieee
 Root ID  Priority  1
        Address   000a.8a7e.ebc0
        Cost    19
        Port    3 (FastEthernet0/3)
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority  32769 (priority 32768 sys-id-ext 1)
        Address   000e.d7f6.9180
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec
        Aging Time 300

Interface       Role  Sts  Cost    Prio.Nbr  Type
---------------- ---- --- --------- -------- ---------------
Fa0/2         Altn  BLK  19      128.2   P2p
Fa0/3         Root  FWD  19      128.3   P2p


この状態で,経路の切り替え動作を見てみましょう。
動作を調べるために,デバッグ機能をオンにします。

SwitchC#debug spanning-tree events
Spanning Tree event debugging is on


ここで,SwitchAとSwitchC間のケーブルを抜きます。

00:20:35: STP: VLAN0001 new root port Fa0/2, cost 38
00:20:35: STP: VLAN0001 Fa0/2 -> listening
00:20:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
00:20:37: STP: VLAN0001 sent Topology Change Notice on Fa0/2
00:20:37: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
00:20:50: STP: VLAN0001 Fa0/2 -> learning
00:21:05: STP: VLAN0001 Fa0/2 -> forwarding


Fa0/2が,リスニングとラーニングを経て最終的にフォワーディングになっているのがわかります。
切り替え時間に注目すると,フォワーディングになるまでにちょうど30秒(リスニングが15秒,ラーニングが15秒)かかっているのがわかります。
このように通常のスパニング・ツリーでは,SwitchCのアップリンクに発生した障害を回避するのに30秒間かかります。

●UplinkFastを設定する
それでは,SwitchCにUplinkFastを設定します。
グローバルコンフィグレーション・モードで,spanning-tree uplinkfastと入力します。

SwitchC#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SwitchC(config)#spanning-tree uplinkfast
SwitchC(config)#
00:21:41: setting bridge id (which=1) prio 49153 prio cfg 49152 sysid 1 (on) id C001.000e.d7f6.9180


すると,デバッグ機能がオンになっているので,上のようなメッセージが出ます。
これは,「ブリッジIDのプライオリティが49153になった」という内容です。
このように,スイッチにUplinkFastを設定すると,プライオリティがデフォルト32769からの49153に自動的に変更されます。
さらに,ポートのパス・コストに3000が加わります。
このようにして,自身がルート・ブリッジにならないようにするのです。
というのもUplinkFastは,ルート・ブリッジまでの経路(ルート・ポート)を瞬時に切り替える機能なので,ルート・ブリッジで使うことはできないからです。

切断した経路をつなぎ直して,状態を再び確認してみましょう。
プライオリティ値が49153になっていて,パス・コストにも3000が加わって3019になってるのがわかります(赤字の部分)。

SwitchC#show spanning-tree

VLAN0001
 Spanning tree enabled protocol ieee
 Root ID  Priority  1
        Address   000a.8a7e.ebc0
        Cost    3019
        Port    3 (FastEthernet0/3)
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority  49153 (priority 49152 sys-id-ext 1)
        Address   000e.d7f6.9180
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec
        Aging Time 15
 Uplinkfast enabled

Interface       Role  Sts Cost     Prio.Nbr  Type
---------------- ---- --- --------- -------- ---------------
Fa0/2         Altn  BLK  3019    128.2  P2p
Fa0/3         Root  FWD  3019    128.3  P2p


●UplinkFast設定時の切り替え動作を確認
ここからが本番。UplinkFastの切り替え動作を確認します。
UplinkFastを設定した状態で,SwitchAとSwitchC間のケーブルを抜きます。

00:24:44: STP: VLAN0001 new root port Fa0/2, cost 3038
00:24:44: %SPANTREE_FAST-7-PORT_FWD_UPLINK: VLAN0001 FastEthernet0/2 moved to Forwarding (UplinkFast).
00:24:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
00:24:46: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
00:24:46: STP: VLAN0001 sent Topology Change Notice on Fa0/2


UplinkFastによって,FastEthernet0/2がフォワーディングになったメッセージが出ました(上の赤字部分)。
直後に,FastEthernet0/3のリンクがダウンした旨の表示が出ています。
つまり,リンク・ダウンとほぼ同じタイミングでこれまでブロッキングだったFastEthernet0/2がフォワーディングになり,経路が切り替わったわけです。
UplinkFastを使うとこのように,通常なら30秒間かか経路の切り替え時間を,ほぼゼロにできるわけです。

SwitchCのポートの状態を見ると,確かにFa0/2がルート・ポートでフォワーディングになっているのがわかります(下の赤字部分)。

SwitchC#show spanning-tree

VLAN0001
 Spanning tree enabled protocol ieee
 Root ID  Priority  1
        Address   000a.8a7e.ebc0
        Cost    3038
        Port    2 (FastEthernet0/2)
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority  49153 (priority 49152 sys-id-ext 1)
        Address   000e.d7f6.9180
        Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec
        Aging Time 15
 Uplinkfast enabled

Interface       Role Sts  Cost     Prio.Nbr  Type
---------------- ---- --- --------- -------- -------------
Fa0/2         Root FWD  3019     128.2  P2p


また,show spanning-tree uplinkfastコマンドを使うと,UplinkFastについての情報が表示されます。

SwitchC#show spanning-tree uplinkfast
UplinkFast is enabled

Station update rate set to 150 packets/sec.

UplinkFast statistics
-----------------------
Number of transitions via uplinkFast (all VLANs)         : 1
Number of proxy multicast addresses transmitted (all VLANs) : 0

Name              Interface List
-------------------- ------------------------------------
VLAN0001           Fa0/2(fwd)


「Number of transitions via uplinkFast」が「1」になっており,UplinkFastによる切り替えが1回実行されたことがわかります

●アップリンク ファースト機能の説明と設定について(JapanTAC Web)
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/473/51-j.shtml

スパニングツリー・ラボ
STPの基本動作
ルート・ブリッジの設定
パス・コストの設定
PortFast
UplinkFast
BackboneFast
PVST
RSTP
MSTP