ポートVLAN
・ポートVLANを使ってSwitchAにつながるパソコン同士をVLAN10に所属させる
・SwitchAのポートにVLAN10が設定されていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←この(アクセスリンクの)ポートをVLAN10に所属させる
switchport mode access ←このポートをアクセスリンクにする
no ip address
!
interface FastEthernet0/2
switchport access vlan 10 ←この(アクセスリンクの)ポートをVLAN10に所属させる
switchport mode access ←このポートをアクセスリンクにする
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 5 15
!
end
確認
VLAN設定の基本は,なんと言っても「ポートVLAN」です。
インタフェース・ポートに「このポートはVLAN○番」と設定する方法です。

●VLANとは?
VLAN(バーチャルLAN)とは,その名の通り,LANを仮想的に作る技術です。
通常ならばLANスイッチは,全ポートにつながるマシンが一つのLANに所属します。
ところがVLAN機能を使うと,フレームをやりとりできるグループを「VLAN○番」というように設定できます。
こうすることで,あたかも異なるLANを作ったようにできるわけです。

●VLANを設定する
VLANの設定方法はいろいろありますが,ここでは,基本中の基本である「ポートVLAN」を使って設定してみます。
ポートVLANは,LANスイッチのポートにVLAN番号を設定する方法です。
Catalystのデフォルトは,すべてのポートがVLAN1に所属しています。
ここでは,SwitchAのFa0/1とFa0/2をVLAN10に所属させて,Fa0/1とFa0/2につながっているマシン同士しか通信できないようにします。

最初に,スイッチでVLAN10を定義します。
グローバル・コンフィグレーション・モードで「vlan 作りたいVLAN番号」と入力します。
すると,VLANの設定モードに入ります。
ここで「name VLAN名」とすると,VLAN名を設定できます。

SwitchA(config)#vlan 10
SwitchA(config-vlan)#name VLAN_10


次に,ここで作ったVLAN10に所属させたいポートにVLANを割り当てます。
switchport mode accessは,このポートをアクセス・ポートに設定しています。
スイッチの各ポートは,一つのVLANに属する「アクセス・ポート」または,複数のVLANに属する「トランク・ポート」のいずれかに所属します。
Fa0/1はVLAN10にしか所属しないので,アクセス・ポートに設定します。
そしてswitchport access vlan 10で,このアクセス・ポートにVLAN番号を設定します。

SwitchA(config)#interface fastEthernet 0/1
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 10


Fa0/2も同様に設定します。

SwitchA(config)#interface fastEthernet 0/2
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 10


設定は以上です。

●設定の確認
VLANの設定状況を確認しましょう。
show vlanコマンドを使います。

SwitchA#show vlan

VLAN Name               Status   Ports
---- --------------------- --------- -------------------------------
1   default               active   Fa0/3, Fa0/4, Fa0/5, Fa0/6
                               Fa0/7, Fa0/8, Fa0/9, Fa0/10
                               Fa0/11, Fa0/12
10   VLAN_10              active    Fa0/1, Fa0/2
1002 fddi-default             active
1003 token-ring-default        active
1004 fddinet-default          active
1005 trnet-default           active

VLAN Type SAID      MTU  Parent  RingNo BridgeNo  Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1   enet  100001    1500  -    -     -      -   -      0    0
10   enet 100010    1500  -    -     -      -   -      0    0
1002 fddi  101002    1500  -    -     -      -   -      0    0
1003 tr   101003    1500  -    -     -      -   -      0    0
1004 fdnet 101004    1500  -    -     -      ieee  -      0    0
1005 trnet 101005    1500  -    -     -      ibm  -      0    0

Remote SPAN VLANs
----------------------------------------------------------------------


Primary  Secondary  Type          Ports
------- --------- ----------------- -----------------------------------


Fa0/1とFa0/2が,VLAN10に所属していることがわかります(赤字の部分)。
それ以外のポートは,デフォルトのVLAN1に所属していることも確認できました。
ちなみにこのVLAN情報は,通常のコンフィグレーション・ファイルには保存されずに,vlan.datと呼ばれる設定ファイルに保存されます。

この状態で,同じVLANに所属する,Fa0/1のパソコンとFa0/2のパソコン同士は,通信できます。
それ以外のポートにつながるマシンとは通信できません。
つまり,Fa0/1とFa0/2だけが通信できるLANを作ったことと同じになったわけです。

●vlan databaseを使ってVLANを設定する
「VLANデータベース」を使ってVLANを設定することもできます。
今回の設定を,VLANデータベースを使って設定してみましょう。
特権モードでvlan databaseと入力して,VLANデータベースの設定モードに入って設定します。

SwitchA#vlan database ←VLANデータベースの設定モードに入る
SwitchA(vlan)#vlan 10 name VLAN_10 ←VLAN10(名前はVLAN_10)を定義する
VLAN 10 added:
  Name: VLAN_10
SwitchA(vlan)#show changes ←反映される予定の設定を表示させる
ADDED:
 VLAN ISL Id: 10
  Name: VLAN_10
  Media Type: Ethernet
  VLAN 802.10 Id: 100010
  State: Operational
  MTU: 1500
  Backup CRF Mode: Disabled
  Remote SPAN VLAN: No
SwitchA(vlan)#apply ←設定を反映する
APPLY completed.
SwitchA(vlan)#exit ←VLANデータベース設定モードから抜ける(これだけでも設定が反映される)

Exiting....

通常設定モードとの違いは,VLANを定義した段階では,まだ設定が反映されないところです。
applyまたはexitと入力した時点で,設定は反映されます。

ただし,最近のスイッチは,VLANデータベースモードに入ろうとすると,以下のような警告メッセージが出ます。

SwitchA#vlan database
% Warning: It is recommended to configure VLAN from config mode,
as VLAN database mode is being deprecated. Please consult user
documentation for configuring VTP/VLAN in config mode.


「コンフィグモードでVLANを設定することを推奨する。VLANデータベース設定モードは賛成しない」とあります。
VLANを設定するときは,通常のモードで設定するのがいいみたいですね。

●CatalystスイッチでのイーサネットVLANの作成
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/793/lan_switching/3-j.shtml

VLANラボ
ポートVLAN
トランク接続(タグVLAN)
VLAN間ルーティング(トランク非対応ルーター)
VLAN間ルーティング(トランク対応ルーター)
VLAN間ルーティング(レイヤー3スイッチ)
VTP
VTPプルーニング
プライベートVLAN
プライベートVLANエッジ(保護ポート)