トランク接続の設定
・スイッチ同士をトランク接続して,トランクリンクを複数のVLANに所属させる
・複数のスイッチを介してVLANが構築できることを確認する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←このポートをVLAN10に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport access vlan 20 ←このポートをVLAN20に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport mode trunk ←このポートをトランク・リンクにする
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
SwitchBのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchB
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←このポートをVLAN10に所属させる
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 20 ←このポートをVLAN20に所属させる
switchport mode access
!
interface FastEthernet0/12
switchport mode trunk ←このポートをトランク・リンクにする
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
確認
複数のVLANが所属するポートのことを「トランク・ポート」と呼びます。
複数のスイッチを介してVLANを構成する場合は,スイッチ同士がつながるポートをトランク・ポートにします。
2台のスイッチを使ってVLANを構成する場合の設定を見てみましょう。

●トランク接続のしくみ
アクセス・ポートでは,一つのVLANにしか所属できません。
しかし,1個のポートに複数のVLANのデータが行き交う場合もあります。
その場合,そのポートをトランク・ポートに設定します。
ポートをトランク・ポートに設定すると,そのポートでトランク・プロトコルが動作し,MACフレームにVLAN情報を付加して送り出すようになります。
この手法は「タグVLAN」とも呼ばれています。
トランク・プロトコルにはシスコ独自のISLと標準のIEEE802.1Qがありますが,Catalyst2950ではデフォルトでIEEE802.1Qが使われます。

このラボでは,スイッチ2台がつながるポート同士をトランク・ポートに設定してみましょう。
それぞれのスイッチにはVLAN10とVLAN20という二つのVLANを作り,トランク・ポートでその二つのVLANのトラフィックをやりとりできるようにします。

●VLAN設定を確認
最初に,VLANの設定を確認しましょう。
VLAN10とVLAN20が作られている状態です。

SwitchA#show vlan brief

VLAN Name               Status   Ports
---- ---------------------- --------- -------------------------------
1  default               active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                               Fa0/5, Fa0/6, Fa0/7, Fa0/8
                               Fa0/9, Fa0/10, Fa0/11
10  VLAN_10             active
20  VLAN_20             active

1002 fddi-default           active
1003 token-ring-default       active
1004 fddinet-default         active
1005 trnet-default          active

以上はスイッチAの設定ですが,スイッチBも全く同じ状態です。

●ポートにVLANを設定する
それでは,スイッチのポートにVLANを設定しましょう。
Fa0/1にVLAN10を設定します。

SwitchA(config)#interface fastEthernet 0/1
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 10


次に,Fa0/2にVLAN20を設定します。

SwitchA(config)#interface fastEthernet 0/2
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 20


最後に,Fa0/12をトランク・ポートに設定します。
コマンドは,switchport mode trunkとなります。

SwitchA(config)#interface fastEthernet 0/12
SwitchA(config-if)#switchport mode trunk

スイッチAの設定は以上です。
スイッチBも全く同じコマンドを入力します。
設定は以上です。

●トランク接続を確認
Fa0/12のトランク接続の状態を確認してみましょう。

SwitchA#show interfaces FastEthernet 0/12 trunk

Port    Mode     Encapsulation Status    Native vlan
Fa0/12   on      802.1q      trunking   1

Port   Vlans allowed on trunk
Fa0/12   1-4094

Port    Vlans allowed and active in management domain
Fa0/12   1,10,20

Port    Vlans in spanning tree forwarding state and not pruned
Fa0/12   1,10,20


Fa0/12がIEEE802.1Qを使ってトランクしていることがわかります。
また,このポートでは,VLAN1〜4094の全トラフィックを許可していることも確認できます。

●トランク・リンクで許可するVLANをVLAN10とVLAN20だけにする
ただ現状では,トランク・ポートでやりとりするトラフィックはVLAN10とVLAN20のものだけです。
なので,トランク・リンクでVLAN10とVLAN20のトラフィックだけを許可するようにしましょう。
トランク・ポートで,switchport trunk allowd vlanコマンドを入力します。

SwitchA(config)#interface fastEthernet 0/12
SwitchA(config-if)#switchport trunk allowed vlan 10,20


これで,トランク・ポートでVLAN10とVLAN20のトラフィックしか許可されなくなりました。
確認してみましょう。

SwitchA#show interfaces fastEthernet 0/12 trunk

Port    Mode     Encapsulation Status    Native vlan
Fa0/12   on      802.1q     trunking   1

Port   Vlans allowed on trunk
Fa0/12   10,20

Port    Vlans allowed and active in management domain
Fa0/12   10,20

Port    Vlans in spanning tree forwarding state and not pruned
Fa0/12   10,20


「Vlans allowed on trunk」の項目が,「10,20」に変わりました。
これで,トランク・リンク上にはVLAN10とVLAN20のトラフィックしか流れないようになったことが確認できました。

VLANラボ
ポートVLAN
トランク接続(タグVLAN)
VLAN間ルーティング(トランク非対応ルーター)
VLAN間ルーティング(トランク対応ルーター)
VLAN間ルーティング(レイヤー3スイッチ)
VTP
VTPプルーニング
プライベートVLAN
プライベートVLANエッジ(保護ポート)