VLAN間ルーティング(トランク非対応ルーター)
・VLAN10とVLAN20という異なるVLANに所属するパソコン同士を通信できるようにする
・トランク接続に対応していないルーター(10Mポートしか持たないCisco2500など)を使ってVLAN間通信を実現する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←このポートをVLAN10に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport access vlan 20 ←このポートをVLAN20に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/11
switchport access vlan 10 ←ルーター接続ポートをVLAN10に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport access vlan 20 ←ルーター接続ポートをVLAN20に所属させる
switchport mode access
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
RouterAのコンフィグ
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
interface Ethernet0
ip address 192.168.0.254 255.255.255.0 ←VLAN10のデフォルト・ゲートウエイ
!
interface Ethernet1
ip address 192.168.1.254 255.255.255.0 ←VLAN20のデフォルト・ゲートウエイ
!
line con 0
line aux 0
line vty 0 4
login
!
end
確認
異なるVLANに所属するマシン同士を通信させるにはいくつかの方法があります。
ここでは,トランク接続に対応していないルーターを使う,伝統的な方法を使ってみます。

●VLAN間通信とは?
スイッチにVLANを設定すると,異なるVLANに所属するマシン同士は通信できなくなります。
異なるVLANに所属するマシン同士を通信させるには,ルーターまたはレイヤー3スイッチを利用します。
ルーターにおいてVLANを一つのサブネットとして扱い,VLANを越える通信はルーティングしてやります。

ここでは,VLANごとに別々の物理インタフェースでVLANを収容する方法を実践してみます。
トランク接続に対応していないルーター(IOSが12.0(1)T以前,または,10Mポート)で使う方法です。
例えばCisco2500などは10Mポートしか持っていないので,この方法をとることになります。

●VLAN設定を確認
最初に,スイッチのVLAN設定を確認しましょう。
VLAN10とVLAN20が存在してる状態です。

SwitchA#show vlan brief

VLAN Name               Status    Ports
---- ---------------------- --------- -------------------------------
1  default               active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                               Fa0/7, Fa0/8, Fa0/9, Fa0/10
10  VLAN_10              active     Fa0/1, Fa0/11
20  VLAN_20              active     Fa0/2, Fa0/12

1002 fddi-default            active
1003 token-ring-default        active
1004 fddinet-default          active
1005 trnet-default           active


●スイッチのポートにVLANを割り当てる
まずはスイッチにVLANの設定をします。

まずは,Fa0/1とFa0/11をVLAN10に設定します。
こうすれば,VLAN10に所属するパソコンが出したブロードキャスト・フレームがルーターまで届きます。

SwitchA(config)#interface fastEthernet 0/1
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 10


SwitchA(config)#interface fastEthernet 0/11
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 10


次に,Fa0/2とFa0/12をVLAN20に設定します。
こうすれば,VLAN20に所属するパソコンが出したブロードキャスト・フレームがルーターまで届きます。

SwitchA(config)#interface fastEthernet 0/2
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 20


SwitchA(config)#interface fastEthernet 0/12
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 20


これで,二つのVLAN(ブロードキャスト・ドメイン)が1台のルーターに収容される格好になりました。

●ルーターの設定
ルーターには,それぞれのVLANを異なるサブネットとして認識してやります。
VLAN10は192.168.0.0/24というサブネットに対応させてやります。
そのため,ルーターのVLAN10側のインタフェース(Ethernet0)には,192.168.1.254/24を設定します。
ここで設定したアドレスが,VLAN10に所属するマシンのデフォルト・ゲートウエイになります。

RouterA(config)#interface ethernet 0
RouterA(config-if)#ip address 192.168.0.254 255.255.255.0


一方のVLAN20は,192.168.0.0/24というサブネットに対応させましょう。
ルーターのVLAN20側のインタフェース(Ethernet1)には,192.168.1.254/24を設定します。
このアドレスが,VLAN20に所属するマシンのデフォルト・ゲートウエイです。

RouterA(config)#interface ethernet 1
RouterA(config-if)#ip address 192.168.1.254 255.255.255.0


設定は以上です。
これで,VLAN10に所属する192.168.0.1/24のマシンと,VLAN20に所属する192.168.1.1/24のマシンで通信できます。

●ネットワークの状態を確認
上の設定をしたときのネットワークの状態は,以下の図のようになっています。
それぞれのVLANのブロードキャスト・ドメインの中に,ルーターのインタフェースが入っているのがわかります。
VLANを越えて通信するときはルーターあてにパケットを送り,ルーターにルーティングしてもらいます。
これが,ルーターのVLAN間ルーティングというわけです。




VLANラボ
ポートVLAN
トランク接続(タグVLAN)
VLAN間ルーティング(トランク非対応ルーター)
VLAN間ルーティング(トランク対応ルーター)
VLAN間ルーティング(レイヤー3スイッチ)
VTP
VTPプルーニング
プライベートVLAN
プライベートVLANエッジ(保護ポート)