VLAN間ルーティング(トランク対応ルーター)
・VLAN10とVLAN20という異なるVLANに所属するパソコン同士を通信できるようにする
・トランク接続に対応したルーター(100Mポートを持つCisco2620など)を使ってVLAN間通信を実現する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←このポートをVLAN10に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport access vlan 20 ←このポートをVLAN20に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport mode trunk ←このポート(ルーター接続ポート)をトランク・ポートにする
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
RouterAのコンフィグ
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
interface FastEthernet0
no ip address
duplex auto
speed auto
!
interface FastEthernet0.1 ←サブインタフェースFe0.1を作成
encapsulation dot1Q 10 ←トランク・プロトコルにIEEE802.1Qを使い,VLAN10に所属させる
ip address 192.168.0.254 255.255.255.0 ←VLAN10のデフォルト・ゲートウエイを設定
no snmp trap link-status
!
interface FastEthernet0.2 ←サブインタフェースFe0.2を作成
encapsulation dot1Q 20 トランク・プロトコルにIEEE802.1Qを使い,VLAN20に所属させる
ip address 192.168.1.254 255.255.255.0 ←VLAN20のデフォルト・ゲートウエイを設定
no snmp trap link-status
!
!
line con 0
line aux 0
line vty 0 4
!
end
確認
トランク接続機能を持つルーターを使ったVLAN間ルーティングを見てみましょう。
スイッチとルーターをつなぐリンクが1本でよいのが特徴です。
そのためこの方法は,「router on a stick」(1本の棒上のルーター)などとも呼ばれています。

●トランク接続機能を持つルーターとは?
トランク接続に対応したルーターとは,インタフェースにIEEE802.1Qなどのトランク・プロトコルを設定できるルーターです。
つまり,IEEE802.1Qのタグ付きフレームを受信して理解し,自らもタグ付きフレームを出せる機能を持っているわけです。
トランク接続は,IOSが12.0(1)T以降ルーターの100Mポートで利用できます。
例えば,Cisco2620などは100Mポートを持っているのでこの方法が使えるわけです。

ルーター側のリンクでは,サブインタフェースを使って,複数のVLANを収容します。
そのため,スイッチとルーターをつなぐリンクを1本にできます。

●スイッチにVLANを設定
スイッチのFa0/1をVLAN10に設定し,Fa0/2をVLAN20に設定します。
これは,トランク接続機能を持たないルーターを使う場合と同じです。

SwitchA(config)#interface fastEthernet 0/1
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 10


SwitchA(config)#interface fastEthernet 0/2
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 20


違うのは,ルーターとつながるFa0/12を,トランク接続にするところです。
こうして,スイッチがルーターにタグ付きフレームを送るようにします。

SwitchA(config)#interface fastEthernet 0/12
SwitchA(config-if)#switchport mode trunk


●ルーターの設定
次に,ルーターにサブインタフェースを作ります。

VLAN10を収容するサブインタフェースをFa0.1(Fa0の1番目のサブインタフェース)とします。
(ちなみに,サブインタフェース0番はメインインタフェース用に予約されているので利用できません)
「encupsulation dot1Q 10」というコマンドで,VLAN10のIEEE802.1Qのタグ付きフレームをやりとりできるようにします。
さらに,VLAN10のデフォルト・ゲートウエイになるアドレス(192.168.0.254/24)を設定します。

RouterA(config-if)#interface fastEthernet 0.1
RouterA(config-subif)#encapsulation dot1Q 10
RouterA(config-subif)#ip address 192.168.0.254 255.255.255.0


同様に,VLAN20を収容するサブインタフェースをFa0.2(Fa0の2番目のサブインタフェース)にします。

RouterA(config)#interface fastEthernet 0.2
RouterA(config-subif)#encapsulation dot1Q 20
RouterA(config-subif)#ip address 192.168.1.254 255.255.255.0


以上で設定は完了です。
これで,VLAN10に所属する192.168.0.1/24のマシンと,VLAN20に所属する192.168.1.1/24のマシンで通信できます。

●スイッチの設定を確認
以上の設定をした状態で,スイッチの設定を確認してみます。
VLANの設定を見ると,Fa0/1がVLAN10に所属しており,Fa0/2がVLAN20に所属していることがわかります(下の赤字)。

SwitchA#show vlan brief

VLAN Name                Status    Ports
---- ----------------------- --------- -------------------------------
1  default                active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                 Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                Fa0/11
10  VLAN_10              active      Fa0/1
20  VLAN_20              active      Fa0/2

1002 fddi-default            active
1003 token-ring-default       active
1004 fddinet-default          active
1005 trnet-default           active


show vlanコマンドでは,Fa0/12はトランク接続しているポートは表示されません。
そこで,トランク接続したFa0/12の状態を見てみましょう。

SwitchA#show interfaces fa0/12 trunk

Port    Mode     Encapsulation Status    Native vlan
Fa0/12   on      802.1q     trunking   1

Port   Vlans allowed on trunk
Fa0/12   1-4094

Port    Vlans allowed and active in management domain
Fa0/12   1,10,20

Port    Vlans in spanning tree forwarding state and not pruned
Fa0/12   1,10,20


確かに,IEEE802.1Qでトランク接続していることがわかります(上の赤字)。

●ルーターの設定を確認
ルーターの設定も確認しておきましょう。
Fa0.1の状態を見ると,確かにこのインタフェースでIEEE802.1QのタグVLANをを利用していることがわかります。

RouterA#show interfaces fastEthernet 0.1
FastEthernet0.1 is up, line protocol is up
 Hardware is PQ3_TSEC, address is 0012.808c.42c2 (bia 0012.808c.42c2)
 Internet address is 192.168.0.254/24
 MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
   reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation 802.1Q Virtual LAN, Vlan ID 10.
 ARP type: ARPA, ARP Timeout 04:00:00
 Last clearing of "show interface" counters never


Fa0.2も同様です。

RouterA#show interfaces fastEthernet 0.2
FastEthernet0.2 is up, line protocol is up
 Hardware is PQ3_TSEC, address is 0012.808c.42c2 (bia 0012.808c.42c2)
 Internet address is 192.168.1.254/24
 MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
   reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation 802.1Q Virtual LAN, Vlan ID 20.
 ARP type: ARPA, ARP Timeout 04:00:00
 Last clearing of "show interface" counters never


●おまけ
サブインタフェースを設定するときに,「encupasulation dot1Q」コマンドの前にIPアドレスを入力しようとすると…

RouterA(config-subif)#ip address 192.168.0.254 255.255.255.0

% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.


と表示されて怒られます。
サブインタフェースにIPアドレスを設定するときは,始めにIEEE802.1Qを使うことを宣言してからというわけです。

●外部ルータを使用したCatalyst 2900XL/3500XL/2950スイッチでのインターVLANルーティングとISL/802.1Qトランキングの設定
http://www.cisco.com/japanese/warp/public/3/jp/service/tac/473/50-j.html

VLANラボ
ポートVLAN
トランク接続(タグVLAN)
VLAN間ルーティング(トランク非対応ルーター)
VLAN間ルーティング(トランク対応ルーター)
VLAN間ルーティング(レイヤー3スイッチ)
VTP
VTPプルーニング
プライベートVLAN
プライベートVLANエッジ(保護ポート)