VLAN間ルーティング(レイヤー3スイッチ)
・レイヤー3スイッチを使って,異なるVLANに所属するマシン同士を通信できるようにする
・異なるVLANに所属するマシン同士が通信できていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
ip routing ←ルーティング機能を有効にする
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←このポートをVLAN10に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport access vlan 20 ←このポートをVLAN20に所属させる
switchport mode access
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10                ←VLAN10の仮想インタフェースにIPアドレスを設定する
ip address 192.168.0.254 255.255.255.0

!
interface Vlan20                ←VLAN20の仮想インタフェースにIPアドレスを設定する
ip address 192.168.1.254 255.255.255.0

!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
確認
レイヤー3スイッチは,ルーターとスイッチの両方の機能を持った機器です。
そのレイヤー3スイッチを使ってVLAN間ルーティングをすることもできます。

●VLAN作成と確認
VLANの作成と確認は,レイヤー2スイッチと同じです。
今回のラボ・シナリオでは,VLAN10とVLAN20を以下のように作ります。

SwitchA(config)#vlan 10
SwitchA(config-vlan)#name VLAN_10

SwitchA(config-vlan)#exit
SwitchA(config)#vlan 20
SwitchA(config-vlan)#name VLAN_20


そして,作ったVLANをポートに設定します。
Fa0/1をVLAN10に所属させます。

SwitchA(config)#interface fastEthernet 0/1
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 10


Fa0/2をVLAN20に所属させます。

SwitchA(config)#interface fastEthernet 0/2
SwitchA(config-if)#switchport mode access
SwitchA(config-if)#switchport access vlan 20


VLAN確認は,show vlanコマンドです。
Fa0/1がVLAN10に,Fa0/2がVLAN20に所属しているのがわかります(赤字の部分)。

SwitchA#show vlan brief

VLAN Name               Status    Ports
---- ---------------------- --------- -------------------------------
1  default               active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                              Fa0/7, Fa0/8, Fa0/9, Fa0/10
                              Fa0/11, Fa0/12, Fa0/13, Fa0/14
                              Fa0/15, Fa0/16, Fa0/17, Fa0/18
                              Fa0/19, Fa0/20, Fa0/21, Fa0/22
                              Fa0/23, Fa0/24, Gi0/1, Gi0/2
10  VLAN_10              active   Fa0/1
20  VLAN_20              active   Fa0/2

1002 fddi-default            act/unsup
1003 token-ring-default       act/unsup
1004 fddinet-default         act/unsup
1005 trnet-default          act/unsup


●VLAN間ルーティングの設定
ここからが,レイヤー3スイッチならではの設定です。

はじめに,スイッチでルーティング機能を有効にするip routingコマンドを入力します。
いろいろ設定してから「VLAN間ルーティングができない!」という場合,このコマンドを忘れているケースがよくあります。
忘れずに。

SwitchA(config)#ip routing

次に,VLANの仮想インタフェースにIPアドレスを割り当てます。
レイヤー3スイッチでは,VLANを作るとそのVLANごとに仮想インタフェースを作れるようになります。
そのVLAN用の仮想インタフェースが,VLANのマシンのデフォルト・ゲートウエイになるわけです。
VLAN用の仮想インタフェースは,SVI(switch virtual interface)とも呼ばれます。

VLAN10の仮想インタフェースに192.168.0.254/24を割り当てます。

SwitchA(config)#interface vlan 10
SwitchA(config-if)#ip address 192.168.0.254 255.255.255.0


同様に,VLAN20の仮想インタフェースに192.168.1.254/24を割り当てます。

SwitchA(config)#interface vlan 20
SwitchA(config-if)#ip address 192.168.1.254 255.255.255.0


以上で設定は完了です。
Fa0/1につながる192.168.1.1/24のパソコンと,Fa0/2につながる192.168.2.1/24のパソコンが通信できるようになります。

●ネットワークの状態を確認
上の設定をしたときのネットワークの状態は,以下の図のようになっています。
レイヤー3スイッチの中に,ルーターとスイッチが入っているイメージです。
ルーターがルーティング機能で,スイッチがVLANです。
VLANを作った数だけ,スイッチが作られる格好になります。
そして,ルーターがスイッチを収容する部分が,VLANの仮想インタフェースになるわけです。

ルーティングに関する設定は,ルーティング・テーブルを見ればわかります。
ルーターのように,show ip routeコマンドが使えます。

SwitchA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

Gateway of last resort is not set

C  192.168.0.0/24 is directly connected, Vlan10
C  192.168.1.0/24 is directly connected,
Vlan20

192.168.0.0/24がVLAN10に直接接続しており,192.168.1.0/24がVLAN20に直接接続している,と表示されました。
VLANの仮想インタフェースにIPアドレスが割り当てられたことが確認できました。
レイヤー3スイッチは,このルーティング・テーブルを参照してVLAN間通信をするわけです。

VLANラボ
ポートVLAN
トランク接続(タグVLAN)
VLAN間ルーティング(トランク非対応ルーター)
VLAN間ルーティング(トランク対応ルーター)
VLAN間ルーティング(レイヤー3スイッチ)
VTP
VTPプルーニング
プライベートVLAN
プライベートVLANエッジ(保護ポート)