VTPプルーニング
・スイッチでVTPプルーニングを有効にする
・VTPプルーニングによって,余分なVLAN情報のやりとりがカットされていることを確認する
ネットワーク構成(画像を別ウインドウで表示)
SwitchAのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchA
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←この(アクセスリンクの)ポートをVLAN10に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport access vlan 20 ←この(アクセスリンクの)ポートをVLAN20に所属させる
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport mode trunk
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
SwitchBのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchB
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10 ←この(アクセスリンクの)ポートをVLAN10に所属させる
switchport mode access
!
interface FastEthernet0/12
switchport mode trunk ←このポートをトランクポートにする
!
interface FastEthernet0/24
switchport mode trunk ←このポートをトランクポートにする
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
SwitchCのコンフィグ
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SwitchC
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q ←このスイッチはIEEE802.1QとISLを選べるのでIEEE802.1Qを指定する
switchport mode trunk ←このポートをトランクポートにする
no ip address
!
interface Vlan1
no ip address
shutdown
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
確認
VTPプルーニングを使うと,余分なVLANのトラフィックをトランクリンクに流さないようにできます。
実際に試してみましょう。

●VTPプルーニングを設定する。
ネットワークの構成は,スイッチ3台が一列につながった構成です。
スイッチ同士がつながるリンクはトランクリンクです。
SwitchAにはVLAN10とVLAN20が,SwitchBにはVLAN10が存在します。
3台すべてが,デフォルトのVTPサーバーの状態です。

この状態で,SwitchAでVTPプルーニングを有効にします。

SwitchA(config)#vtp pruning
Pruning switched on


SwitchAのVTPの状態を確認してみましょう。

SwitchA#show vtp status
VTP Version            : 2
Configuration Revision     : 26
Maximum VLANs supported locally : 64
Number of existing VLANs   : 7
VTP Operating Mode       : Server
VTP Domain Name         : ccstudy
VTP Pruning Mode        : Enabled
VTP V2 Mode            : Disabled
VTP Traps Generation      : Disabled
MD5 digest             : 0x06 0x10 0x67 0x6E 0xA4 0x82 0x6D 0xCF
Configuration last modified by 0.0.0.0 at 3-1-93 03:13:57
Local updater ID is 0.0.0.0 (no valid interface found)


SwitchBとSwitchCも,VTPプルーニングが自動的に有効(enable)になります。
以下はSwitchBのVTPの状態です。

SwitchB#show vtp status
VTP Version            : 2
Configuration Revision     : 26
Maximum VLANs supported locally : 250
Number of existing VLANs   : 7
VTP Operating Mode       : Server
VTP Domain Name         : ccstudy
VTP Pruning Mode        : Enabled
VTP V2 Mode            : Disabled
VTP Traps Generation      : Disabled
MD5 digest             : 0x06 0x10 0x67 0x6E 0xA4 0x82 0x6D 0xCF
Configuration last modified by 0.0.0.0 at 3-1-93 03:13:57
Local updater ID is 0.0.0.0 (no valid interface found)


そして以下が,SwitchCです。

SwitchC#show vtp status
VTP Version            : 2
Configuration Revision     : 26
Maximum VLANs supported locally : 1005
Number of existing VLANs   : 7
VTP Operating Mode       : Server
VTP Domain Name         : ccstudy
VTP Pruning Mode        : Enabled
VTP V2 Mode            : Disabled
VTP Traps Generation      : Disabled
MD5 digest             : 0x06 0x10 0x67 0x6E 0xA4 0x82 0x6D 0xCF
Configuration last modified by 0.0.0.0 at 3-1-93 03:13:57
Local updater ID is 0.0.0.0 (no valid interface found)


SwitchAのトランクリンク(Fa0/12)のVTPプルーニングの状態を調べてみます。

SwitchA#show interfaces fastEthernet 0/12 pruning

Port    Vlans pruned for lack of request by neighbor
Fa0/12   20


Port    Vlan traffic requested of neighbor
Fa0/12   1,10,20


「Vlans pruned for lack of request by neighbor」は,「ネイバーからの要求がなくてプルーニングされたVLAN」という意味です。
つまり,この先にはVLAN20がないので,VLAN20のトラフィックを出さなくなったわけです。

SwitchAのトランクポートの状態を見てみましょう。

SwitchA#show interfaces trunk

Port    Mode     Encapsulation Status    Native vlan
Fa0/12   on      802.1q     trunking   1

Port   Vlans allowed on trunk
Fa0/12   1-4094

Port    Vlans allowed and active in management domain
Fa0/12   1,10,20

Port    Vlans in spanning tree forwarding state and not pruned
Fa0/12   1,10


一番下の表示が,実際にトランクリンク上に流れているVLANのトラフィックです。
VLAN1とVLAN10のトラフィックが流れており,VLAN20のトラフィックはプルーニング(削除)されたことがわかります。

SwitchBのトランクリンク(Fa0/24)はどうでしょうか。
Fa0/24のVTPプルーニングの状態を見てみます。

SwitchB#show interfaces fastEthernet 0/24 pruning

Port    Vlans pruned for lack of request by neighbor
Fa0/24   10,20


Port    Vlan traffic requested of neighbor
Fa0/24   1,10,20


表示結果を見ると,VLAN10とVLAN20がプルーニングされているのがわかります。
SwitchBの先にはVALN10もVLAN20もないので,この二つのVLANのトラフィックがプルーニングされたわけです。
こちらも,show interface trunkコマンドで,現在トランクリンクに流れているトラフィックを確認してみましょう。

SwitchB#show interfaces trunk

Port    Mode     Encapsulation Status    Native vlan
Fa0/12   on      802.1q     trunking   1
Fa0/24   on      802.1q     trunking   1

Port    Vlans allowed on trunk
Fa0/12   1-4094
Fa0/24   1-4094

Port    Vlans allowed and active in management domain
Fa0/12   1,10,20
Fa0/24   1,10,20

Port    Vlans in spanning tree forwarding state and not pruned
Fa0/12   1,10,20
Fa0/24   1


Fa0/24には,VLAN1のトラフィックしか流れていないことがわかります。

つまり,SwitchAでVLAN20をプルーニングし,SwitchBでVLAN10とVLAN20をプルーニングしたことがわかります。
VTPプルーニングを使うとこのように,必要なVLANのトラフィックだけを自動的に運ぶようになるわけです。

VLANラボ
ポートVLAN
トランク接続(タグVLAN)
VLAN間ルーティング(トランク非対応ルーター)
VLAN間ルーティング(トランク対応ルーター)
VLAN間ルーティング(レイヤー3スイッチ)
VTP
VTPプルーニング
プライベートVLAN
プライベートVLANエッジ(保護ポート)